Wake on LAN over different VLANS



  • Good afternoon,

    I have trying to test wake on lan through fog over different vlans. On the same vlan as the fog server, wake on lan works perfectly, but when I try wake on lan over a different vlan thats when the packet seems to not go through. For example:

    My fog server IP is 10.1.0.119, if I try to wake on lan a pc with an IP address of 10.1.x.x, wake on lan works perfectly. I then tested computers with an IP of 10.2.x.x and an IP of 10.3.x.x, and the computer never wakes up. I used the same computer in all locations so the settings are the same just something is blocking the packet from going through.

    Anyone have any ideas?



  • Glad to see this is fixed. I helped to the extent of my abilities via forum chat but I came to a dead end basically. And Tom’s post explains why. Good to see a solution is found.


  • Senior Developer

    Okay, so I was an idiot when working with things. @szecca1 is using a NAS. I set Wake on lan to get all nodes to try waking up hosts. NAS cannot wake up hosts because the links that wake them up is not installed. Fixed this by adding the FOG_WEB_HOST as a starting point for WOL as well.

    It appears all is now working.


  • Senior Developer

    Please try updating to the latest. I altered some more of the code and things should work. Again, as I told you in chat, I don’t have physical systems for testing WOL on, so most of the time I’m just working blind and hoping for the best. Every once in a while I can test where I work, but this time of year, as I hope you all understand, it’s pretty unrealistic. Please let me know if it is working now.

    Thank you,



  • @Developers Where is package / code that actually sends the WOL ?



  • @Wayne-Workman I tried that and still the computer is not turning on. It has the same settings as before I switched to Fedora when the wake on lan worked with Ubuntu. Just confused haha



  • @Wayne-Workman If you’re talking about on the fog server where the storage node is, right now it is set to ‘bond0’ You’re saying to change that to ens32? and that should fix the wake on lan?



  • @Tom-Elliott I work from 8-4 every day during the week, but if you are only available at night I can make it work. I’m in NY as well so time wise will be the same



  • @szecca1 said:

    @Wayne-Workman This is the result
    upload-984f2935-52c0-4e55-a649-1ecc51ac149d

    Make sure that ens32 is set as the interface for that server’s storage node.


  • Senior Developer

    I’ll try to “schedule” it for tonight then, if that’s okay? I’m on EDT (New York).



  • @Wayne-Workman This is the result
    upload-984f2935-52c0-4e55-a649-1ecc51ac149d



  • @Tom-Elliott Take your time Tom! I am very patient and have any time you need so whenever you are free.



  • Can you provide the output of this?

    ip link show
    

  • Senior Developer

    If you’re patient when I get home I can possibly help.



  • @Wayne-Workman After we installed Fedora 21 server wake on lan no longer works even on the same vlan. I feel like i might have to install something but I can not find anything on the wiki. Would you be able to assist?



  • @Wayne-Workman First I want to apologize, I know you guys have worked hard to help me out and I could never repay you for all the help you have given so thank you very much. My company finally decided to work with me and we got it working in one building. They enabled direct broadcasts on both passports and now it is working fine. No one ever informed me that we had two passports which is fantastic. We are going to cleanup the switches and continue testing but seems like we may have figured it out, thanks to you guys!



  • There is one alternative that I thought of…

    You could use dedicated relays.

    Relays are generally used to encapsulate a UDP packet (or any packet) into a TCP packet, send it to a relay on another network, then the receiving relay would then decapsulate the packet back to UDP, and then send it out.

    I’ve seen this used for emergency broadcast systems before, it works well. I’m sure there are several software solutions that do it, both free and paid.

    Then, you could just point the WOL plugin to the local relay. Ofcourse, this is just an alternative if your network team just doesn’t want to make a change. You could setup relays without help from the network guys. It’s not ideal and would require you to run a relay on some computer on each network (like a server)… but it’d work.



  • @szecca1 said:

    @Wayne-Workman said:

    @szecca1 Better yet, see if you can get in touch with a Nortel person and see what they say about it. Or search their website for information.

    I think you are saying that FOG requires that broadcasts be allowed to travel across the router to other VLANs.
    This makes no sense - and even if it could be done - would not be advisable.
    That’s what I’m being told, does this sound correct?

    You came to us with questions about how this is done, and we’ve helped you to the best of our abilities to troubleshoot, identify the problem, and guide you to accomplish what you’re wanting. It’s not our place to say what’s advisable and what’s not for you. Those kinds of decisions should be made by you and your network team.

    We’re just here to help you do what you want, to help solve problems, etc.

    But, I’ll tell you, it sounds like your network team don’t fully understand how the WOL plugin works, and I’ll tell you that YES, it can be done. And while the packet is a broadcast packet, it’s a packet destined for another network. It’s not broadcast throughout it’s source network, only it’s destination network. The router needs only to forward it, like we’ve pointed out. When it’s broadcast at the destination network, when those broadcast packets hit the router, because the destination network matches the source network, the router ignores it.



  • @Wayne-Workman said:

    @szecca1 Better yet, see if you can get in touch with a Nortel person and see what they say about it. Or search their website for information.

    I think you are saying that FOG requires that broadcasts be allowed to travel across the router to other VLANs.
    This makes no sense - and even if it could be done - would not be advisable.
    That’s what I’m being told, does this sound correct?



  • @Wayne-Workman With this situation and me not being the network admin, my company would probably prefer me going directly to them first and then if possible calling Nortel. I will definitely keep you guys updated.


 

439
Online

41.8k
Users

12.3k
Topics

115.9k
Posts