SVN 3480 Setting up and starting MySQL...error



  • Centos 7 error updating to last svn build

    Confirming package installation.

    • Checking package: httpd…OK

    • Checking package: php…OK

    • Checking package: php-cli…OK

    • Checking package: php-common…OK

    • Checking package: php-gd…OK

    • Checking package: mysql…OK

    • Checking package: mysql-server…OK

    • Checking package: tftp-server…OK

    • Checking package: nfs-utils…OK

    • Checking package: vsftpd…OK

    • Checking package: net-tools…OK

    • Checking package: wget…OK

    • Checking package: xinetd…OK

    • Checking package: tar…OK

    • Checking package: gzip…OK

    • Checking package: make…OK

    • Checking package: m4…OK

      • Checking package: gcc…OK
      • Checking package: gcc-c++…OK
      • Checking package: lftp…OK
      • Checking package: php-mysqlnd…OK
      • Checking package: curl…OK
      • Checking package: php-mcrypt…OK
      • Checking package: php-mbstring…OK
      • Checking package: mod_ssl…OK

      Configuring services.

      • Setting up and starting MySQL…error reading information on service mysqld: No such file or directory
        Failed!


  • That’s a great line @Wayne-Workman !
    Installed without a hitch.

    Both time I have installed FOG though, the password given at the end of the install doesn’t work.
    Last time I looked up how to change it, after that I could log into the web interface.


  • Moderator

    @Rusty No. After helping here so much and learning so much about fog and linux, I don’t even follow instructions anymore. I just wing it. Like you would wing installing a new program on Windows.

    lets see, I think I can fit the entire installation into one single line…

    Execute this as root.

    yum update -y;yum install subversion -y;setenforce 0;systemctl stop firewalld;cd ~;mkdir svn;cd svn;svn co https://svn.code.sf.net/p/freeghost/code/trunk;cd trunk/bin;./installfog.sh

    of course that just stops SELinux and Firewall, it doesn’t disable them. I think that article needs re-written, it was last modified in February 2015. A lot has changed since then.

    And it looks like it gives you directions to install fog 0.32. Fog stable is 1.2.0, and Fog Trunk can install on CentOS 7 without any modifications besides selinux and firewall.

    If you want something more comprehensive and up-to-date, the Fedora 21 server article works on CentOS 7, there are notes on the one line that need altered or discarded for CentOS 7 and Fedora 22 server.



  • I am starting from scratch so I might just continue with that first…
    @Wayne-Workman did you follow all steps here ? https://wiki.fogproject.org/wiki/index.php/Installation_on_CentOS_7



  • I am running CentOS 7 with the latest FOG version


  • Moderator

    For the record, I just did a clean installation using SVN 4330 and CentOS 7 fully updated and it went just fine.


  • Senior Developer

    @Rusty what version of fog are you running? What OS and version of it too?



  • @Wayne-Workman Thanks Wayne. I tried uninstalling and reinstalling Mariadb. Fog installer recognises Mariadb has been installed but:

     * Setting up and starting MySQL...Note: Forwarding request to 'systemctl enable mysqld.service'.
    Failed to issue method call: No such file or directory
    OK
      * Backing up user reports...OK
      * Setting up and starting Apache Web Server...Note: Forwarding request to 'systemctl enable httpd.service'.
    Failed! (3)
    

  • Moderator

    @Rusty This particular thread’s solution is quite old. Tom has since made many changes to how the installer handles this. I think it’s best to wait for @Tom-Elliott 's input.



  • Can someone please explain what file this “fix” applies and maybe a bit more info for noobs like me to fix it ?
    Thanks ! :)



  • RHVER=awk '{for(i=1;i<=NF;i++) if ($i == "release") print $(i+1)}' /etc/redhat-release | cut -d. -f 1;

    Solve problem



  • SVN 3493 not fix issue with rhel/centos 7 update 1

    …/config.sh
    RHVER=awk ‘{for(i=1;i<=NF;i++) if ($i == “release”) print $(i+1)}’ /etc/redhat-release
    Receive Value = 7.1.1503

    RHVER=echo ${RHVER%.*}
    Receive Value = 7.1
    …/functions.sh

    configureMySql()
    {
    echo -n " * Setting up and starting MySQL…";
    if [ “7.1” == “7” -o “$linuxReleaseName” == “Fedora” ]; then
    systemctl=“yes”;
    systemctl enable mariadb.service >/dev/null 2>&1;
    systemctl restart mariadb.service >/dev/null 2>&1;
    else



  • What mean if you have repo installed with release file like atomic-release-1.0-19.el7.art.noarch , environment variable $rhver receive value 1 not 7 on centos/rhel 7… So detection of mariadb server not happening and mysql server absent by default on centos/rhel 7… What cause error :
    Setting up and starting MySQL…error reading information on service mysqld: No such file or directory


  • Senior Developer

    @sgennadi so…what’s this mean?



  • …/lib/redhat/config.sh
    RHVER=rpm -qa | grep release | xargs rpm -q --queryformat '%{VERSION}' | cut -c -1
    receive wrong value if atomic repo installed

    rpm -qa | grep release
    atomic-release-1.0-19.el7.art.noarch
    epel-release-7-5.noarch
    remi-release-7.0-1.el7.remi.noarch
    centos-release-7-1.1503.el7.centos.2.8.x86_64

    rpm -qa | grep release | xargs rpm -q --queryformat ‘%{VERSION}’ | cut -c -1
    1
    …/lib/redhat/functions.sh
    echo -n " * Setting up and starting MySQL…";
    if [ “$RHVER” == “7” -o “$linuxReleaseName” == “Fedora” ]

    “$RHVER” == "1"
    Setting up and starting MySQL… error

    $RHVER must be something like:
    /bin/rpm -qf /etc/redhat-release --qf “%{VERSION}\n”


  • Moderator

    Try these?

    [CODE]sudo yum remove MariaDB-client MariaDB-server
    sudo yum install MariaDB-server MariaDB-client[/CODE]



  • yum remove mysql-client mysql-server mysql-common mysql-devel
    Loaded plugins: fastestmirror, langpacks
    No Match for argument: mysql-client
    No Match for argument: mysql-server
    No Match for argument: mysql-common
    No Match for argument: mysql-devel
    No Packages marked for removal

    yum remove mariadb-libs.x86_64 mariadb-server.x86_64
    rm -rf /var/lib/mysql/
    rm -rf /etc/my.cnf
    yum install mariadb-libs.x86_64 mariadb-server.x86_64

    • Setting up and starting MySQL…error reading information on service mysqld: No such file or directory

  • Moderator

    Right. Do the MySQL commands not work with it?

    Either way, I think you should try to uninstall it and then re-run your FOG installer.

    Again, only delete your DB if you have it backed up.



  • Centos 7 default mariadb-server


  • Moderator

    Try to remove it, then reinstall.
    [CODE]yum remove mysql-client mysql-server mysql-common mysql-devel[/CODE]

    ONLY IF YOU HAVE YOUR Database BACKED UP!!! You can do this:
    [CODE]rm -rf /var/lib/mysql/
    rm -rf /etc/my.cnf[/CODE]

    Then try to re-run your r3480 installer and let us know what happens.


Log in to reply
 

920
Online

38968
Users

10709
Topics

101631
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.