Fatal Error: Failed to mount NFS volume



  • I apologize, I am a newbie but as far as I remember I created the mount point under images. I mounted the NAS drive under images/ to minize the editing of fog since I saw FOG saves its images to that folder. If I did something wrong please suggest away. I am open to anything at this point.


  • Moderator

    @szecca1 Where is mount your NAS on your server ?



  • I ran that command and still getting that same permissions error. Capture.PNG
    That is my file structure just so you can see. I am not sure as to why I am not getting access


  • Moderator

    @szecca1

    chmod 777 -R /images (your mount point)
    


  • Thank you very much. Yea the permission denied is weird because on the FOG management console it sees the drive perfectly. I followed your syntax and created the .mntcheck for both folder paths. It seems I am still getting the same error message but I have yet to do that 777 on the folder because I am unaware of how to do that.

    Is the a command I have to run to give 777 on folders dans files in /images and sub folders?


  • Moderator

    @szecca1

    Hi,

    You need to had in your NAS two empty files .mntcheck in your /FOG/Images/ and /FOG/Images/dev.
    If you have mounted your NFS share on you FOG server you can use the command touch like that : touch /mounted_nas_folder/.mntcheck and touch /mounted_nas_folder/dev/.mntcheck.

    Ensure you have 777 on folders dans files in /images and sub folders.

    Regards,
    Ch3i.


  • Senior Developer

    It’s possible you’re missing the .mntcheck files as you stated. They can be created with:

    sudo touch /images/{,dev/}.mntcheck
    

    However, the other part to note is that the NFS is getting permission denied. This leads me to believe that the mount point is not correct or the NFS server on the NAS is not running.


Log in to reply
 

259
Online

7.1k
Users

14.3k
Topics

135.1k
Posts