Issue with PXE and DHCP



  • So, I’m rather new to linux and completely new to fog but here’s what is going on,

    Right now I’m just playing around with fog and trying it out but I have a g5 rack server that has server 2012 on it, running hyper-V, the V-switch has been set to internal and I have 3 VM’s:

    Ubuntu 15.XX with Fog installed and when I set it up I set it to not be the dhcp server but then I changed it later when I found out that my router wouldn’t suffice (also when i made it an internal switch) and its now the dhcp server.

    Debian Wheezy (MineOS) which successfully pulls a DHCP IP from the Ubuntu VM

    The 3rd VM is blank and I’m trying to get the PXE fog menu to load. it says DHCP…X but it timeouts.

    Now according to the Ubuntu DHCP, it sees the DHCP request from the blank VM and sends it an offer, But that just loops.

    Any idea why this is happening?

    May 12 13:18:57 Fog dhcpd[631]: DHCPDISCOVER from 00:15:5d:00:01:04 via eth0
    May 12 13:18:58 Fog dhcpd[631]: DHCPOFFER on 192.168.3.53 to 00:15:5d:00:01:04 via eth0
    May 12 13:19:01 Fog dhcpd[631]: DHCPDISCOVER from 00:15:5d:00:01:04 via eth0
    May 12 13:19:01 Fog dhcpd[631]: DHCPOFFER on 192.168.3.53 to 00:15:5d:00:01:04 via eth0
    May 12 13:19:09 Fog dhcpd[631]: DHCPDISCOVER from 00:15:5d:00:01:04 via eth0
    May 12 13:19:09 Fog dhcpd[631]: DHCPOFFER on 192.168.3.53 to 00:15:5d:00:01:04 via eth0



  • I installed fog on my Ubuntu machine at home and it worked just fine. It was a real machine and not a VM. I also had the same machine running DHCP as well as fog. I just answered yes to the question about is the dhcp on the same server.

    Here at work it is on Fedora like 12 (dont laugh) I use a generic txt only dhcp server called dhcpdns ( [url]http://dhcp-dns-server.sourceforge.net/[/url]) for reasons not related to fog. It runs in widows with no install, in its config I had to put this…
    BOOTFILE=undionly.kpxe
    NEXTSERVER=10.95.95.100

    maybe try and run it on a the above little dhcp server which runs on windows with out an install and see if its a fog or dhcp issue.


  • Moderator

    Tom would say Red Hat Server (and he knows a WHOLE lot more about it than me).

    I’d say Fedora 21 Server.

    The differences between Red Hat based and Debian based aren’t so bad, really.

    You use YUM instead of Apt-Get, the web directory is /var/www/html instead of /var/www, the config files are basically the same but in different spots.

    Fedora has some nice systemctl commands to get status of services and such, and makes enabling services on boot pretty simple.

    And, for what it’s worth, I believe the very first version of FOG was developed on Fedora.



  • How different are the commands? All I’ve been messing with for the past few years is Debian and Ubuntu. Also, which would you recommend most?


  • Moderator

    Because this is at your house and you’re just experimenting, I’d really recommend getting away from Ubuntu.

    Maybe try Red Hat or Fedora or CentOS ?



  • Well I made a whole new VM and installed fog again, instead letting the script configure the DHCP server instead and it does some new stuff now, now it says could not configure console, no such file or directory and could not boot: no such file or directory.

    but it is connecting to the fog VM now, just not loading the menu



  • Alright I added that to dhcpd.conf (I didnt see the commented out section of anything like it so I added it manually) and nothing changed. Is dhcpd.conf where it is supposed to go?

    EDIT…

    Checked the status and It’s failing to start because of that line of code
    "[SIZE=14px][FONT=monospace][COLOR=#000000]dhcp-boot=undionly.kpxe[/COLOR][/FONT][/SIZE]"



  • So this isn’t done upon installing fog? I just got home now so I’m firing up the VM server now, will get back to ya in a sec. Thanks for the replies everyone :-D.


  • Developer

    except that should be [SIZE=14px][FONT=monospace][COLOR=#000000]dhcp-boot=undionly.kpxe[/COLOR][/FONT][/SIZE] instead



  • [COLOR=#666666][SIZE=12px][FONT=Arial]from google…Make sure that the “boot filename” option is present on your DHCP or BOOTP server, and that its value is set to the filename of the boot loader.[/FONT][/SIZE][/COLOR]
    [COLOR=#666666][SIZE=12px][FONT=Arial]When using Microsoft DHCP server, add option 067 (Bootfile Name) to your scope. When using a Unix/Linux based (ISC) DHCP server, use the “filename” parameter for this purpose[/FONT][/SIZE][/COLOR]
    [COLOR=#666666][SIZE=12px][FONT=Arial] [/FONT][/SIZE][/COLOR]
    [COLOR=#666666][SIZE=12px][FONT=Arial]from me…[/FONT][/SIZE][/COLOR]
    [COLOR=#666666][SIZE=12px][FONT=Arial]there are two options that need set. Option 66 and 67 ( I think its 66) Those are microsoft numbers. In linux is something like this[/FONT][/SIZE][/COLOR]
    [SIZE=14px][COLOR=black][FONT=monospace]# The boot filename.
    dhcp-boot=pxelinux.0[/FONT][/COLOR][/SIZE]
    [SIZE=14px][COLOR=black][FONT=monospace] [/FONT][/COLOR][/SIZE]



  • Alright, situation has changed, just realized that PXE has no interest in obtaining an IP, and in a blink of an eye it flashes pxe-e53 no boot filename



  • This post is deleted!


  • VM1 is fog and.dhcp, VM2 was already established and was just used to confirm that VM1’s DHCP server was working correctly.

    As for proxydhcp, I’m going to play with that next, but id like to get the full package working first. The PXE of vm3 is either not accepting the ip for some reason.or something else, I’m not sure because I’ve never dived into pxe before so I dont know how it should act

    As for trunk, I’m not sure what that is


  • Moderator

    You could try ProxyDHCP, maybe you’ll have better luck? [url]http://jbob.io/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]

    Also, give kernel 3.18.3 x86_x64 a try.

    And, since this is a test rig anyways, I’d highly recommend jumping head-first into Trunk. See about it here: [url]http://jbob.io/wiki/index.php/Upgrade_to_trunk[/url]



  • your trying to PXE VM3, via FOG VM1 using VM2 DHCP?


Log in to reply
 

448
Online

39209
Users

10856
Topics

103338
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.