Can't upload Dell Latitude 3440 image



  • We got in a few new Latitude 3440 laptops and have been unsuccessful in uploading an image. I have read countless forums here on trying different kernels and such, but no go. I have even tried multiple unofficial kernels, same issue.

    None of the 32-bit kernels work (even though one thread said that the 5000 series and the 3000 series used the same kernel). No luck. I keep getting to the point where FOG is “Using hard drive /dev/sda” and the nothing, it just sits there.

    I really could use some help!

    I am running Ubuntu Server 14.04, FOG 1.2.0, and have my bzImage configured for the 3.14.2 kernel. I have tried 12 different kernels thus far though.

    Thanks in advance!



  • @Wayne-Workman
    That did Wayne, thanks again for the help. Updating passwords between storage node in gui, and .fogsettings, so they match, was the final answer.


  • Moderator

    @pizzutoitalia You’d set the mysql password inside /opt/fog/.fogsettings and then re-run your installer. You’ll see three fields for it. host, username, and password. In most scenarios the user should be root, and password blank.

    Also - if the MySQL credentials that are set were not good, you wouldn’t even be able to use the web interface at all, whatsoever.

    Check what username/password is set in the web interface’s storage management area.



  • @Wayne-Workman
    I did the test, perhaps I wasn’t clear. I can login to ftp with username fog and password as password, I originally had everything working without a password, however it wants a password now. However I’m not sure where to update the password for FOG ftp in settings. I have edited the .fogsettings in opt/fog and the name and password field were blank. I have updated them to reflect the FOG / Password combo, however the error remains upon trying to capture image.
    I have Ubuntu 14.04 with Trunk 7827

    Cliffnotes: Everything was working until I update the storage node settings via config yesterday. Now I need to understand where to tell fog that I now have a sql password as opposed to blank like it was.


  • Moderator

    @pizzutoitalia Please do the simple FTP test in that article and see if it works?



  • @Wayne-Workman
    This has to do with editing the storage node in the FOG GUI. I changed the eth0 to eth1 in storage node, to make the bandwidth monitor on front page work, since then I have not been able to capture images (however the bandwidth monitor works great for deployment). Before that, I captured many images fine. It would appear my problem is that I left the fog SQL password blank, and when editing the storage node via gui, its does not let you save it with a blank password. Upon checking .fogsettings, I found that the password field has " " not ’ '. I have changed it back, and its still not working! Perrhaps I should start over again with a fresh install of ubuntu and fog? I seem to have different passwords everywhere now as I have started trying to resolve this!


  • Moderator

    @pizzutoitalia said in Can't upload Dell Latitude 3440 image:

    Message: ftp_login(): Login incorrect

    That line tells me that it’s FTP related, likely credentials.

    This article helps greater than 90% of folks with your problem:
    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP



  • @pizzutoitalia It has been a while, but from what I remember (at least in our environment) our 3440s were using a hybrid drive. I had to write 0s to the drive before loading Windows 7.

    My current environment is:

    Ubuntu 14.04
    SVN 7717
    Kernel: 4.5.3
    Boot file: undionly.kpxe

    Turned off secure boot and UEFI.



  • @pizzutoitalia
    This is the error I get at the end of imaging! Says image copied successfull then this below:

    Error returned: Type 2, File /var/www/html/fog/lib/fog/fogftp.class.php. Line 107, Message: ftp_login(): Login incorrect., Host: 192.168.1.1 Username :fog *reattempting to update database …Failed.



  • Can someone maybe pinpoint what the solution was here? I too, am not able to capture dell 3440 image. Everything works fine, looks like the image capture completes, then computer reboots. However the image file is empty, showing no data, and the dev folder / mac address has the image in it still? any ideas, I had no issues with dell 3440 on my old FOG 0.32 server on 2.8.8 kernel. I have tried most things above!



  • Can someone maybe pinpoint what the solution was here? I too, am not able to capture dell 3440 image. Everything works fine, looks like the image capture completes, then computer reboots. However the image file is empty, showing no data, and the dev folder / mac address has the image in it still? any ideas, I had no issues with dell 3440 on my old FOG 0.32 server on 2.8.8 kernel. I have tried most things above!


  • Senior Developer

    As I doubt you’re in the office now,

    Contact me via Conversation. If you can, please give me a gmail account we can chat through. I think I know what the problem is.



  • Yes sir. On Upload. We are able to upload other images (we just did an Optiplex 360 yesterday). But, we have been unable to upload one for our new Latitude 3440s.


  • Senior Developer

    This is on upload?


  • Moderator

    This post is deleted!


  • DHCP options 66 and 67 are set for the scope correctly.

    I have downloaded and tried both 4.0.0 and 4.0.0 (32 bit). I rename them from bzImage to 4_0_0 and 4_0_0_32 and am manually using that as the kernel in the host configuration. During the PXE process, it does read the correct kernel, followed by init.xz. However, still hanging on Using Hard Disk /dev/sda


  • Moderator

    http://fogproject.org/forum/posts/46336/

    @Tom Elliott, post: 46336, member: 7271 said:

    The kernel that you’re using is 64 bit? The four FOG logos at the top tell me you’re not using a 3.14.2 kernel.

    That said, there are newer kernels.

    On your FOG Server can you run:

    >wget -O /var/www/html/fog/service/ipxe/bzImage http://downloads.sourceforge.net/project/freeghost/KernelList/bzImage
    wget -O /var/www/html/fog/service/ipxe/bzImage32 http://downloads.sourceforge.net/project/freeghost/KernelList/bzImage32
    >```
     
    Firstly, see the path of those wget commands? /var/www/html/fog/service/ipxe/ file name ??
     
    On ubuntu, it'll be /var/www/fog/service/ipxe   (the paths above are for Fedora).
     
    Secondly, Backup your old ones using cp to <filename>.old before you execute those commands. This way, if something doesn't go right, you can just cp the <filename>.old to <filename> and you will be back where you started.


  • No luck yet.

    Have tried 4.0 kernel (32 bit and 64 bit). As with all 32 bit kernels, I get a kernel panic that says to use the init= option in the kernel.

    I have also set the DHCP 67 option to undionly.kkpxe. Does this need to be set somewhere in FOG also?



  • Where is the 4.0 kernel? I didn’t see it anywhere.


  • Moderator

    Can you try the 4.0 kernel? bzImage32 Version: 4.0.0

    Also, give the boot-file undionly.kkpxe a try. Edit your DHCP option 067.


Log in to reply
 

398
Online

38711
Users

10542
Topics

99799
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.