PXE boot stuck when fog is down



  • Sometimes i need to take fog down for backups and other work.

    The issue i have then is that all my pcs are set to boot to network. So the pc boots, gets an IP from DHCP and then sticks at PXE-E32: TFTP open timeout
    TFTP…

    The user then has to press escape to proceed.

    But users do not know that they need to press escape and our helpdesk gets flooded with calls about the problem.

    Is there a way to put a time out or something so that if it fails to connect to the TFTP it will just carry on and boot into windows?

    Many thanks

    Duncan


  • Moderator

    I follow. So its the SysAdmin’s responsibility on their end, not the FOG Project’s responsibility. :p



  • [quote=“need2, post: 46896, member: 21891”]Right, but you still have to get the hardware to actually let you write the ROM to it. And some manufacturers make their firmware harder to write to than others. And there’s just so many variables to consider when you are trying to take so many manufacturers and models into account.[/quote]

    That’s why you don’t do it, lol.

    I mean, if it was a serious issue with a particular model, then you’d build a ROM for THAT… You don’t just do it for the hell of it, ya know?


  • Moderator

    Right, but you still have to get the hardware to actually let you write the ROM to it. And some manufacturers make their firmware harder to write to than others. And there’s just so many variables to consider when you are trying to take so many manufacturers and models into account.



  • The rom-o-matic site does this for you…

    No coding; You just pick the options you want. I’ll never do it.


  • Moderator

    Well I have always been interested in firmware coding. Hey, maybe I could build a set of ROMs for everyone to install on their devices they want to use with FOG!

    No, not really. I’m not going to do that.



  • [quote=“need2, post: 46879, member: 21891”]Yeah sadly this is kind of on the PXE client embedded in each computer. Some are coded well and give up on PXE boot if they can’t get a good reply, others just kind of sit there and stare at the wall.[/quote]

    lol… Maybe for those, you would choose to build your own ROM.


  • Moderator

    Yeah sadly this is kind of on the PXE client embedded in each computer. Some are coded well and give up on PXE boot if they can’t get a good reply, others just kind of sit there and stare at the wall.


  • Moderator

    [quote=“Duncan, post: 46858, member: 26100”]ok great.

    I was kind of hoping i didn’t have to go down that route and i could of done it with the PXE boot on the pc.

    Seems you cannot do it this way.

    I will create a script for the next time i down fog.

    Many thanks.

    Duncan[/quote]

    To remove 66 option :
    [CODE]netsh dhcp server ip_of_your_dhcp_server scope ip_of_your_scope delete optionvalue 66[/CODE]

    To set 66 option :
    [CODE]netsh dhcp server ip_of_your_dhcp_server scope ip_of_your_scope set optionvalue 66 STRING ip_of_your_fog_server[/CODE]

    Regards,
    Ch3i.



  • ok great.

    I was kind of hoping i didn’t have to go down that route and i could of done it with the PXE boot on the pc.

    Seems you cannot do it this way.

    I will create a script for the next time i down fog.

    Many thanks.

    Duncan


  • Moderator

    The simple way is use a script to delete value of PXE option in your DHCP server using command line : [url]https://technet.microsoft.com/en-us/library/cc787375(v=ws.10).aspx#BKMK_delopval[/url]

    Regards,
    Ch3i.



  • Yeh DHCP is on Windows Server


  • Moderator

    Hi,

    You DHCP is on a Windows Server ?

    Regards,
    Ch3i.


 

570
Online

5.4k
Users

12.6k
Topics

118.9k
Posts