Lsblk: /dev/sda?: not a block device

  • I try to restore image on hdd with broken mbr/partition table and receive message:
    lsblk: /dev/sda?: not a block device
    Error: Could not stat device mklabel -No such file or directory
    Failed to initialize disk…

    I can’t erase mbr/partition with fastwipe … same mistake

    After recreate mbr/partition table with external tool all work

    Can you fix this case ?

  • Moderator

    Just ran into this too. Giving it a poke.

    The drive had Windows 10 on it before, and it worked. After running a fast wipe through FOG, I could no longer get any tasks to work (same error as above). More fiddling inbound.

  • Then this is probably a Tom question.

    I know he’s been doing A LOT of work with how HDDs are handled lately.

  • This post is deleted!

  • [quote=“Wayne Workman, post: 46802, member: 28155”]Are you using 1.2.0 ??[/quote]

    Yes - 1.2.0 revision 3356 - using Debian 7.8.0

  • Are you using 1.2.0 ??

  • After a quick FAT32 format, the system seems to work. I formatted the blank drive and was able to register the host and deploy Windows 7 to the hard drive. It also registers the host when the drive is formatted for Linux.

  • [quote=“Wayne Workman, post: 46765, member: 28155”]when you say “new hard drive”, do you mean a blank one? Or just a “newer” one that has some partitions on it ?[/quote]

    It’s actually new and blank with no partitions or data

  • when you say “new hard drive”, do you mean a blank one? Or just a “newer” one that has some partitions on it ?

  • This time after updating…

    trying to register older MSI computer with new hard drive connected to SATA (configured as SATA and not RAID)

    Error: could not stat device mklabel - No such file or directory

    ** An error has been detected **

    Failed to initialize disk

    ** Computer will reboot in 1 minute **

  • Senior Developer

    please update and try again, does the error still occur?

  • just tried it with a new hard drive (on the old MSI computer) and the update from a few minutes ago - same /dev/sda? error

  • I got it on a Toshiba Satellite notebook: M305D-S4830, an older computer with a K8T Neo-V MSI mainboard and a VirtualBox virtual machine.

  • Senior Developer

    Does this only happen on specific devices?

    I ask because I’ve been testing imaging since working on many different changes. I haven’t seen this pop up.

  • [SIZE=5][B][FONT=Trebuchet MS][FONT=Tahoma]lsblk: /dev/sda?: not a block device[/FONT]
    [FONT=Tahoma]Error: Could not stat device mklabel -No such file or directory[/FONT][/FONT][/B][/SIZE]

    I get that message all the time with the current revision - images do not restore and it’s impossible to register a new host.

  • Tom,
    I understand you very well and I said you right this is not bug , can I ask you future request? Can you do in fog menu something like quick image advanced where you script check computer compatibility if problem found not exit with error code, but give to the user option to fix problem (or try to fix problem automatically) and re-run check ?

  • Senior Developer


    I guess I don’t know how to explain this so you understand.

    If I clear the drive, before the system has even had a chance to start up, there’s a high chance your systems would lose data.

    This is the first time I’ve ever heard of a hard drive having a “bad” mbr that FOG couldn’t at least continue on. As it’s the first (and I’m sure it’s only been reported this first time), i’m not going to change it.

    If you knew your hard drive had a bad mbr written to it before imaging, then why would you think fog was just going to fix this for you?


    If I clear the MBR/HDD and it still can’t initialize the drive, there’s a huge potential for Data Loss. Once FOG knows it can use the drive safely, it will go through and clear the tables and present them back as the image needs it to. But during that initial start up I don’t think this is a good or safe option.

  • You are right when we talk about full / quick inventory but when we talk about quick image I think maybe you can add some extra question (option) if problem with disk detected (format, wipe, clear partition table, disktest, etc ) ?

  • Senior Developer

    Correct, but this only works if the disk can be initialized in the first place.

    Think about it in this regard.

    I have to validate that your disk is readable/usable on initial boot.

    if for some reason it cannot work with FOG (can’t initialize or whatnot which it tries if it can) and I clear the MBR, you suddenly have a system that may have worked (just not with FOG) inoperational.

  • I choose open image of hdd with one partition ( Single Disk - Resizable) and option resize image to fill all space on hdd, fog must destroy all data on the disk and overwrite mbr ?

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.