Cannot deploy Windows 7 image to Dell Latitude E5420.



  • Hello,

    I just rebuild my fog server from scratch with Ubuntu 14.04LTS and Fog 1.2.0. I have been able to successfully deploy Windows 7 images to E5440s and E5430s but have not been successful at deploying a Windows 7 Image to the E5420s. It does act like it is going to deploy the image but never does. It goes to Changin hostname and then to Updating Computer Database Status, Database Updated!, and then Task is completed, computer will now restart. Thank you in advance for any suggestions.

    Thanks,
    Reub


  • Senior Developer

    I’m about to run back to the future or forward to the past



  • kernel panic? I got dizzy and fell over! Hit my head on the sink and saw the flux capacitor…


  • Senior Developer

    It’s all good man. We get a laugh and you now understand a bit better how the fsid system works. No pain or anything on you.



  • I should have picked a better naming convention when I setup the partition and folder. Next time I will name the partition and folders something else. I will know next time to check my fsid’s first to make sure they are different. Thanks for all your help and sorry for the kernel panic with the /images/images/images.


  • Senior Developer

    Stack trace:> ~[] too many images in images with images:
    Unsure of which image you want to see images in:
    Error code :images


  • Developer

    no need to be sorry. it was just difficult to read. all i saw was “images were in images/images/images … exactly … like /images. …also images pointed to … images” and my brain threw a kernel panic



  • Ok. Found my problem. The problem was the fsid’s in the comments above. The fsid’s need to be different for each line. I changed the fsid’s and it lets me deploy images from the /images, /images/images, and the /images/images/images folders without a problem. I am sorry that the way that I have it setup is confusing but it is working now. Thank all of you that responded.

    Thanks,
    Reub



  • When I mounted the partition from my external hard drive the partition name is images and the folder inside of that is also called images. As for the /etc/exports, below is the output.

    /images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1,subtree_check)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2,subtree_check)

    /images/images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1,subtree_check)
    /images/images/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2,subtree_check)

    /images/images/images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure,fsid=1,subtree_check)
    /images/images/images/dev *(rw,sync,no_wdelay,no_root_squash,insecure,fsid=2,subtree_check)

    I think I my see the problem now. Shouldn’t the fsid be different for all of these?


  • Senior Developer

    Alright,

    How confusing can you potentially make this?

    First what’s the output of /etc/exports

    WHY SO MANY IMAGES folders inside images?



  • To the best of my knowledge, it was mounted because I could look at the data on it. The images were in /images/images/images. I had all the permissions set exactly like the ones for /images that were set during the fog install. I also had the images pointed to the correct folder to do the images.



  • External drive, or a 2nd or 3rd or 5th internal drive… it doesn’t matter. the drive needs mounted and the permissions have to be set.

    Also, you’ll need a storage node specifically for it if you want that drive to be detachable.



  • I resolved the issue by uninstalling and installing fog again and copying the images to the /images root directory. But the question still remains, why can I not deploy from my external drive when I could deploy from it before I rebuilt my fog server.



  • yeah it’s either permissions or something with the hardware on the E5420.

    Or perhaps a different switch model / switch settings that the E5420 machines are connected to.


  • Testers

    Check your permissions sample command below.
    ls -laR /images



  • I have double and triple checked the image type and os. I am deploying separate images to each model and I did sysprep and included the needed drivers. The only thing different from the plain jane/jim way of setting FOG up is that I have a secondary hard drive setup and I followed the instructions on this page, [url]http://www.fogproject.org/wiki/index.php/Moving_your_images_directory/Adding_Storage_to_the_Images_directory[/url], the part at the very bottom is how I have the drive connected to FOG. I may have messed something up when I did that because I switched it from being in the mount directory to the /image/newdrive directory.



  • Are you deploying the same image to all 3? Did you sysprep, did you include the needed drivers?


  • Testers

    Double check image type and os.


 

447
Online

41.7k
Users

12.2k
Topics

115.1k
Posts