TFTP stops on reboot after install



  • I just installed Ubuntu and FOG 0.32 after having difficulties with it running in Linux Mint 12. I have had the server working after install last night. I shut the system down, brought it to work today, and now I can’t get anything to boot from it.
    I’m using a crossover cable to minimize possible network issues. I ran “tftp -v 192.168.1.101 -c get pxelinux.0” and all I get is “Transfer timed out.”

    What can I do to fix the server to get it back up and running? Also, how do I keep this from happening again?

    Ubuntu 12.04 Beta1 (previously used Linux Mint 12 (based on Ubuntu 11.10) and had the same problem.)
    FOG 0.32


  • Developer

    This is a known issue with the 12.04 Ubuntu derivative, the services are started before an ip address is assigned to the machine.

    There are a number of posts ON THIS FORUM that explain how to rectify the issue and delay the start up of the job so that you don’t have to start them manually after each reboot.



  • Circling back here folks.
    SOLVED!
    From spiceworks post:
    This is kind of an old thread at this point, but I had the same issues so I wanted to put the information I found on here in the event it will help anybody else…what I found was that both DHCP, and TFTP had stopped working when I rebooted my 12.04 ubuntu LTS desktop. After doing some testing, here’s what I found that works for me to get it restarted quickly.
    FROM THE UBUNTU Desktop

    1. Open a command window
    2. ENTER: sudo start isc-dhcp-server (enter your password when asked)
    3. ENTER: sudo restart tftpd-hpa

    BAM!



  • Still can’t figure out why all of the sudden I’m getting the notorious PXE-E53 and PXE-M0F errors. Anyone with a solution? I’m behind my home router that does the DHCP, has been working great. My mistake was rebooting my fog server, now I got nothing > ugg!



  • Just curious since I have encountered this ‘bug’ with the Ubuntu releases all the time:

    Instead of restarting with:

    [FONT=Consolas][CODE]/bin/sleep 30 && /etc/init.d/tftpd-hpa restart[/CODE][/FONT]

    [FONT=Consolas]Isn’t there a way to delay the original start of the tftp daemon with a simple sleep () inserted somewhere in the Ubuntu start up script for all daemons?[/FONT]



  • [quote=“astrouga, post: 3627, member: 907”]I just stopped and started tfpd-hpa:
    [code]
    sudo stop tftpd-hpa
    sudo start tftpd-hpa
    [/code][/quote]
    I did the same, …actually aliased the command to “restart tftpd-hpd”



  • Thanks, that worked. Though you have a typo. It should be:

    [CODE]/bin/sleep 30 && /etc/init.d/tftpd-hpa restart[/CODE]

    (you had “htftpd-hpa”).

    astrouga



  • I think the reason is the Ubuntu start mechanism “Upstart”, where the daemons do not start step by step but almost simultaneously.
    So tftpd-hpa starts “to early”. You can fix this by editing the /etc/rc.local and ad the line

    (/bin/sleep 30 && /etc/init.d/htftpd-hpa restart)

    to restart the daemon after 30 seconds

    ullawolf1



  • More details:
    This is a common issue that keeps coming up in the forums. You install 12.04, install fog and reboot and then TFTP times out.

    Look in your /var/log/syslog file and you’ll see something like:
    [Code]
    May 22 14:16:22 yourServer in.tftpd[968]: cannot resolve local IPv4 bind address: 0.0
    .0.0, Name or service not known
    May 22 14:16:22 yourServer cron[1003]: (CRON) STARTUP (fork ok)
    May 22 14:16:22 yourServer kernel: [ 19.271357] init: tftpd-hpa main process (968)
    terminated with status 66
    May 22 14:16:22 yourServer kernel: [ 19.271374] init: tftpd-hpa main process ended,
    respawning
    [/code]
    Your nic doesn’t have an IP address when tftpd-hpa starts, so it isn’t going to work. Just do this from a terminal window:
    [Code]
    sudo stop tftpd-hpa
    sudo start tftpd-hpa
    [/code]
    This is a “confirmed” bug in 12.04.

    –astrouga



  • I just stopped and started tfpd-hpa:
    [code]
    sudo stop tftpd-hpa
    sudo start tftpd-hpa
    [/code]



  • For us in Ubuntu 12.04 the problem was tftpd-hpa was not starting because fog installation modified the file /etc/default/tftpd-hpa with an IP address of 0.0.0.0



  • Okay everyone, you guys are awesome, Thank you! I really appreciate your help.



  • [quote=“Jacob H. Weeks, post: 2228, member: 716”]Could Someone Please Provide A Step-By-Step Guide On How To Set The Server up on an Ubuntu system including everything that needs to be done before and after running ./installfog.sh?[/quote]

    How about this
    [url]http://fogproject.org/forum/threads/how-to-install-fog-on-ubuntu.5/[/url]
    Or this
    [url]http://www.fogproject.org/wiki/index.php?title=Installation[/url]

    The Tutorials section is helpful
    [url]http://fogproject.org/forum/forums/tutorials.13/[/url]



  • Could Someone Please Provide A Step-By-Step Guide On How To Set The Server up on an Ubuntu system including everything that needs to be done before and after running ./installfog.sh?



  • As ssx4life has said, check [B]WebUI > Other Information > FOG Settings > TFTP Server > FOG_TFTP_FTP_PASSWORD[/B]. This must match your FOG password, otherwise it won’t work. By default, it will appear a random key. This is the first thing to configure after installing FOG. Besides getting TFTP to work, you should now be able to update the kernel.
    I’ve attached an image of my config.

    [url="/_imported_xf_attachments/0/69_Picture 2012-03-15 23_06_03.png?:"]Picture 2012-03-15 23_06_03.png[/url]



  • your TFTP password must match the password on the user account (last time I checked anyway)



  • Yes, I am using FOG DHCP.

    Also, do you mean the “Master Password” under “PXE Boot Menu”.



  • Hello,

    Are you using FOG DHCP or external DHCP?
    Check the following:
    [CODE]FOG WebUI > About > FOG Settings > TFTP Server[/CODE]
    In the “Password” box, set your FOG password (by default, the same you use to login to the WebUI). Try now.



  • [quote=“kirksec, post: 2160, member: 289”]Did you set all the IP’s in all the proper places because obviously the IP changed now ?
    Maybe this link will help you [url]http://www.fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address[/url][/quote]

    Okay, so I checked this out and everything looked to be in order and correct except:
    [CODE]FOG WebUI > about > PXE Boot Menu > Save PXE Menu[/CODE]
    When I try to save, it wants a Master Password. I don’t want to put anything in there to mess things up more. Also:
    [CODE]DHCP server configuration file (/etc/dhcpd.conf) restart service after changes are made.

    * Next-server 192.168.1.50 [/CODE]
    

    The dhcpd.conf file is not present.

    Any help anyone can provide will be greatly appreciated.



  • Did you set all the IP’s in all the proper places because obviously the IP changed now ?
    Maybe this link will help you [url]http://www.fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address[/url]


Log in to reply
 

402
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.