Issues after migrating to new hardware


  • Testers

    I moved my fog server which was at svn 2952 after remembering all the places I had to change interfaces and passwords it seems to be working. The only issue seems to be when I edit a snapin or image the top and side menus disappear as shown in the screenshots attached. I have cleared my cache, tried ie and chrome, and even updated to svn 3078 and the issues is unchanged.
    OS is Ubuntu 12.04 server 64bit
    SVN 3078
    Fog install log
    Ubuntu
    .:###### .:;####:…;#;…
    …##… …##;,;##::::.##…
    ,# …##…##:::## …::
    ## .::###,##. . ##.::#.:######::.
    …##:::###::…#. … .#…#. #…#:::.
    …:####:… …##…##::## … #
    # . …##:,;##;:::#: … ##…
    .# . .:;####;::::.##:::;#:…
    # …:;###…

    ###########################################

    FOG

    Free Computer Imaging Solution

    [url]http://www.fogproject.org/[/url]

    Developers:

    Chuck Syperski

    Jian Zhang

    Peter Gilchrist

    Tom Elliott

    GNU GPL Version 3

    ###########################################
    Version: 1.3.0 Installer/Updater

    • Found FOG Settings from previous install at: /opt/fog/.fogsettings
    • Performing upgrade using these settings…
      Starting Debian / Ubuntu / Kubuntu / Edubuntu Installtion.
      #####################################################################
      FOG now has everything it needs to setup your server, but please
      understand that this script will overwrite any setting you may
      have setup for services like DHCP, apache, pxe, tftp, and NFS.
      It is not recommended that you install this on a production system
      as this script modifies many of your system settings.
      This script should be run by the root user on Redhat or with sudo on Ubuntu.
      ** Notice ** Redhat users will need to disable SELinux and iptables in
      order to use FOG
      Please see our wiki for more information at [url]http://www.fogproject.org/wiki[/url]
      Here are the settings FOG will use:
      Base Linux: Debian
      Detected Linux Distribution: Ubuntu
      Installation Type: Normal Server
      Server IP Address: 10.200.10.150
      DHCP router Address:
      DHCP DNS Address: 10.200.10.34
      Interface: eth0
      Using FOG DHCP: 0
      Internationalization: 0
      Image Storage Location: /images
      Donate: 0
      DHCP will NOT be setup but you must setup your
      current DHCP server to use FOG for PXE services.
      On a Linux DHCP server you must set:
      next-server
      On a Windows DHCP server you must set:
      option 066 & 067
      Option 066 is the IP of the FOG Server: (e.g. 10.200.10.150)
      Option 067 is the undionly.kpxe file: (e.g. undionly.kpxe)
      Are you sure you wish to continue (Y/N)
      Installation Started…
      Installing required packages, if this fails
      make sure you have an active internet connection.
    • Preparing apt-get
    • Packages to be installed: apache2 php5 php5-json php5-gd php5-cli php5-cur$
    • Skipping package: apache2 (Already installed)
    • Skipping package: php5 (Already installed)
    • Skipping package: php5-common (Already installed)
    • Skipping package: php5-gd (Already installed)
    • Skipping package: php5-cli (Already installed)
    • Skipping package: php5-curl (Already installed)
    • Skipping package: mysql-server (Already installed)
    • Skipping package: mysql-client (Already installed)
    • Skipping package: tftpd-hpa (Already installed)
    • Skipping package: tftp-hpa (Already installed)
    • Skipping package: nfs-kernel-server (Already installed)
    • Skipping package: vsftpd (Already installed)
    • Skipping package: net-tools (Already installed)
    • Skipping package: wget (Already installed)
    • Skipping package: xinetd (Already installed)
    • Skipping package: sysv-rc-conf (Already installed)
    • Skipping package: tar (Already installed)
    • Skipping package: gzip (Already installed)
    • Skipping package: build-essential (Already installed)
    • Skipping package: cpp (Already installed)
    • Skipping package: gcc (Already installed)
    • Skipping package: g++ (Already installed)
    • Skipping package: m4 (Already installed)
    • Skipping package: htmldoc (Already installed)
    • Skipping package: lftp (Already installed)
    • Skipping package: openssh-server (Already installed)
    • Skipping package: php-gettext (Already installed)
    • Skipping package: php5-mcrypt (Already installed)
    • Skipping package: php5-mysql (Already installed)
      Confirming package installation.
    • Checking package: apache2…OK
    • Checking package: php5…OK
    • Checking package: php5-json…OK
    • Checking package: php5-gd…OK
    • Checking package: php5-cli…OK
    • Checking package: php5-curl…OK
    • Checking package: mysql-server…OK
    • Checking package: mysql-client…OK
    • Checking package: tftpd-hpa…OK
    • Checking package: tftp-hpa…OK
    • Checking package: nfs-kernel-server…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: sysv-rc-conf…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: build-essential…OK
    • Checking package: cpp…OK
    • Checking package: gcc…OK
    • Checking package: g++…OK
    • Checking package: m4…OK
    • Checking package: htmldoc…OK
    • Checking package: lftp…OK
    • Checking package: openssh-server…OK
    • Checking package: php-gettext…OK
    • Checking package: php5-mcrypt…OK
    • Checking package: php5-mysql…OK
      Configuring services.
    • Setting up and starting MySql…OK
    • Backing up user reports…OK
    • Setting up and starting Apache Web Server…OK
    • Changing permissions on apache log files…OK
    • Downloading kernels and inits…OK
    • Copying back any custom hook files.
    • Copying back any custom report files.
      You still need to install/update your database schema.
      This can be done by opening a web browser and going to:
      [url]http://10.200.10.150/fog/management[/url]
      Press [Enter] key when database is updated/installed.
    • Setting up storage…OK
    • Setting up and starting DHCP Server…Skipped
    • Setting up and starting TFTP and PXE Servers…OK
    • Setting up and starting VSFTP Server…OK
    • Setting up sudo settings…OK
    • Setting up FOG Snapins…OK
    • Setting up and building UDPCast…OK
    • Installing init scripts…OK
    • Setting up FOG Services…OK
    • Setting up FOG Utils…OK
    • Starting FOG Multicast Management Server…OK
    • Starting FOG Image Replicator Server…OK
    • Starting FOG Task Scheduler Server…OK
    • Starting FOG Snapin Replicator Server…OK
    • Configuring Fresh Clam…OK
    • Setting up and starting NFS Server…OK
      Setup complete!

    Last page of apache error.log
    [Sat Mar 07 12:06:11 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /var/www/fog/lib/db/MySQL.class.php on line 156, referer: [url]http://fog/fog/management/index.php?node=image[/url]
    [Sat Mar 07 12:08:26 2015] [error] [client 10.200.50.189] File does not exist: /var/www/fog/management/css/default/ubuntu-regular-webfont.eot, referer: [url]http://10.200.10.150/fog/management/[/url]
    [Sat Mar 07 12:08:32 2015] [error] [client 10.200.50.189] File does not exist: /var/www/fog/management/css/default/ubuntu-regular-webfont.eot, referer: [url]http://10.200.10.150/fog/management/index.php[/url]
    [Sat Mar 07 12:08:35 2015] [error] [client 10.200.50.189] File does not exist: /var/www/fog/management/css/default/ubuntu-regular-webfont.eot, referer: [url]http://10.200.10.150/fog/management/index.php?node=image[/url]
    [Sat Mar 07 12:08:40 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /var/www/fog/lib/db/MySQL.class.php on line 156, referer: [url]http://10.200.10.150/fog/management/index.php?node=image[/url]
    [Sat Mar 07 12:25:31 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 71 bytes) in /var/www/fog/lib/fog/FOGController.class.php on line 348, referer: [url]http://fog/fog/management/index.php?node=image[/url]
    root@934fog2:/var/log/apache2#
    [IMG]https://dl.dropboxusercontent.com/u/24177483/snapins.png[/IMG][IMG]https://dl.dropboxusercontent.com/u/24177483/images.png[/IMG]


  • Moderator


  • Developer

    I’ve looked through the PHP code a couple of times but it’s very hard for me to get kickstarted with this much of code that I have not worked with very much yet. I probably won’t be of much help… :(

    But maybe I can point you to some general things I read about this sort of issues. There are a couple of good comments and tipps on debugging memory leaks within PHP code here: [url]http://stackoverflow.com/questions/849549/diagnosing-memory-leaks-allowed-memory-size-of-bytes-exhausted[/url]

    Have you worked with ‘memory_get_usage’ pointed out here?? [url]http://paul-m-jones.com/archives/262[/url]


  • Testers

    Strangely enough I just saw it in snapins and images when i edit individual ones.


  • Senior Developer

    Mostly its an issue if theres a lot of data for the section You’re looking at.


  • Developer

    [quote=“Tom Elliott, post: 43448, member: 7271”]I would LOVE some assistance to figure out this memory issue. I know db size plays some role but it seems a bit ridiculous that we should have to have that much memory to simply read db entries.[/quote]
    Is this an issue on the whole web interface or just with snapins or hosts…?


  • Testers

    Going to call this a win and leave it alone for now if you guys have any suggestions that won’t bring this down I can try them.


  • Testers

    384, 512, 640, and 768 all fail but 896 seems to work.


  • Senior Developer

    I would LOVE some assistance to figure out this memory issue. I know db size plays some role but it seems a bit ridiculous that we should have to have that much memory to simply read db entries.


  • Testers

    Ok bumped FOG_MEMORY_LIMIT to 1024 and that fixed it I may mess with this later and see if 512 or 728 will work.


  • Testers

    Ok increased to 256 restarted fog cleared error log same behavior error message is this in apache2/error.log

    [Sat Mar 07 15:51:10 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 71 bytes) in /var/www/fog/lib/fog/FOGBase.class.php on line 57, referer: [url]http://10.200.10.150/fog/management/index.php?node=snapin&sub=list[/url]


  • Testers

    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.103.50.73] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.103.50.73] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.103.50.73] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.103.50.73] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.6.50.45] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.6.50.45] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.49.194] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.49.194] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.49.194] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.49.194] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.41.50.207] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.41.50.207] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.41.50.207] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.41.50.207] PHP Warning: mysqli::query(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 120
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:20 2015] [error] [client 10.1.51.142] PHP Warning: mysqli::real_escape_string(): Couldn’t fetch mysqli in /var/www/fog/lib/db/MySQL.class.php on line 266
    [Sat Mar 07 15:27:22 2015] [notice] caught SIGTERM, shutting down
    [Sat Mar 07 15:27:23 2015] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.16 with Suhosin-Patch configured – resuming normal operations
    [Sat Mar 07 15:27:23 2015] [error] [client 10.1.48.19] PHP Fatal error: Class ‘EventManager’ not found in /var/www/fog/commons/init.php on line 268
    [Sat Mar 07 15:27:23 2015] [error] [client 10.1.48.200] PHP Fatal error: Uncaught exception ‘ReflectionException’ with message ‘Class HostManager does not exist’ in /var/www/fog/lib/fog/FOGBase.class.php:130\nStack trace:\n#0 /var/www/fog/lib/fog/FOGBase.class.php(130): ReflectionClass->__construct(‘HostManager’)\n#1 /var/www/fog/lib/fog/FOGCore.class.php(542): FOGBase->getClass(‘HostManager’)\n#2 /var/www/fog/commons/init.php(266): FOGCore->setSessionEnv()\n#3 /var/www/fog/commons/base.inc.php(7): require_once(’/var/www/fog/co…’)\n#4 /var/www/fog/service/servicemodule-active.php(2): require_once(’/var/www/fog/co…’)\n#5 {main}\n thrown in /var/www/fog/lib/fog/FOGBase.class.php on line 130
    [Sat Mar 07 15:27:23 2015] [error] [client 10.42.50.179] PHP Fatal error: Uncaught exception ‘ReflectionException’ with message ‘Class PluginManager does not exist’ in /var/www/fog/lib/fog/FOGBase.class.php:130\nStack trace:\n#0 /var/www/fog/lib/fog/FOGBase.class.php(130): ReflectionClass->__construct(‘PluginManager’)\n#1 /var/www/fog/lib/fog/FOGBase.class.php(553): FOGBase->getClass(‘PluginManager’)\n#2 /var/www/fog/lib/fog/FOGCore.class.php(539): FOGBase->getActivePlugins()\n#3 /var/www/fog/commons/init.php(266): FOGCore->setSessionEnv()\n#4 /var/www/fog/commons/base.inc.php(7): require_once(’/var/www/fog/co…’)\n#5 /var/www/fog/service/servicemodule-active.php(2): require_once(’/var/www/fog/co…’)\n#6 {main}\n thrown in /var/www/fog/lib/fog/FOGBase.class.php on line 130
    [Sat Mar 07 15:27:23 2015] [error] [client 10.117.50.165] File does not exist: /var/www/fog/service
    [Sat Mar 07 15:27:23 2015] [error] [client 10.111.50.39] File does not exist: /var/www/fog/service
    mkdir: cannot create directory `/var/www/fog//management/other/ssl/’: No such file or directory
    [Sat Mar 07 15:27:23 2015] [error] [client 10.117.50.185] PHP Warning: file_put_contents(/var/www/fog//management/other/ssl/srvpublic.key): failed to open stream: No such file or directory in /var/www/fog/lib/fog/FOGCore.class.php on line 530
    [Sat Mar 07 15:27:23 2015] [error] [client 10.117.50.185] PHP Fatal error: Class ‘MACAddress’ not found in /var/www/fog/lib/fog/FOGBase.class.php on line 543
    [Sat Mar 07 15:27:23 2015] [error] [client 10.1.48.144] File does not exist: /var/www/fog/service
    [Sat Mar 07 15:27:23 2015] [error] [client 10.3.50.134] File does not exist: /var/www/fog/service
    [Sat Mar 07 15:27:34 2015] [error] server reached MaxClients setting, consider raising the MaxClients setting
    [Sat Mar 07 15:29:40 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 7 bytes) in /var/www/fog/lib/fog/FOGController.class.php on line 90, referer: [url]http://10.200.10.150/fog/management/index.php?node=snapin&sub=list[/url]
    [Sat Mar 07 15:29:41 2015] [error] [client 10.200.50.189] File does not exist: /var/www/favicon.ico
    [Sat Mar 07 15:31:05 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 8 bytes) in /var/www/fog/lib/fog/FOGController.class.php on line 348, referer: [url]http://10.200.10.150/fog/management/index.php?node=image[/url]
    [Sat Mar 07 15:41:13 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 100 bytes) in /var/www/fog/lib/fog/FOGBase.class.php on line 131, referer: [url]http://10.200.10.150/fog/management/index.php?node=image&sub=list[/url]
    [Sat Mar 07 15:41:22 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 82 bytes) in /var/www/fog/lib/fog/FOGController.class.php on line 347, referer: [url]http://10.200.10.150/fog/management/index.php?node=snapin&sub=list[/url]


  • Senior Developer

    Based on this line:

    [code][Sat Mar 07 12:06:11 2015] [error] [client 10.200.50.189] PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 32 bytes) in /var/www/fog/lib/db/MySQL.class.php on line 156, referer: http://fog/fog/management/index.php?node=image[/code]

    My guess this is still the case.

    Can you change your memory limit to 256 and see if that helps you out? FOG Configuration Page->FOG Settings->General Settings->FOG_MEMORY_LIMIT


  • Senior Developer

    Anything in your apache error logs?


  • Testers

    OK now running 3084 exactly the same behavior.


  • Senior Developer

    As far as I know it is.


  • Testers

    I did from 2952 to 3078 is the latest stable?


  • Senior Developer

    Can you try upgrading?


  • Testers

    Probably unrelated but I show one queued task on the fog home screen but nothing on the tasks page.


Log in to reply
 

532
Online

39187
Users

10835
Topics

103152
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.