Can't login to management after saving FOG settings

  • Moderator

    Alright, I think I found it! It’s one single setting in the ‘globalSettings’ table…

    Go to phpmyadmin, select ‘fog’ database, then ‘globalSettings’, find the value with ID ‘106’ and name ‘FOG_INACTIVITY_TIMEOUT’. I guess it is set to ‘fog’ (at least it was in the dump). Change it to ‘1’ (one) and you should be able to login again…

    The rest is up to Tom I am afraid as I don’t know the web interface enough to see where this could happen. You said that it happended twice when you changed settings… Maybe Tom has an idea!?

    But I am still wondering why this is only happening to you?! So many people out there using it and I’ve never seen anyone reporting this. How come??


  • [quote=“Uncle Frank, post: 43614, member: 28116”]Would it be possible to dump your whole FOG database and upload that dump file to this forum?? I’d love to push this data into my database to see if it looks me out as well… I hope there is no sensitive data in it. Please look through the file an delete password hashes before posting the file here!
    [CODE]$ mysqldump --databases fog --user <your-db-user> -p > fog_dump.sql[/CODE][/quote]

    Have at it. 🙂

    [url="/_imported_xf_attachments/1/1779_fog_dump.zip?:"]fog_dump.zip[/url]

  • Moderator

    Would it be possible to dump your whole FOG database and upload that dump file to this forum?? I’d love to push this data into my database to see if it looks me out as well… I hope there is no sensitive data in it. Please look through the file an delete password hashes before posting the file here!
    [CODE]$ mysqldump --databases fog --user <your-db-user> -p > fog_dump.sql[/CODE]


  • [quote=“Mark Pickard, post: 43549, member: 609”][FONT=arial][COLOR=#222222]Globalsettings.[/COLOR][/FONT][FONT=arial][COLOR=#222222]fog_regenerate_[/COLOR][/FONT][FONT=arial][COLOR=#222222]timeout is set to [/COLOR][/FONT]0.5

    And just to review: my first two FOG installations that ended up locking me out were both on physical machines (both on the same hardware). I just recently brought up a third install in a VM as per your suggestion. That one is working OK so far.[/quote]

    That’s good. Just make a snapshot before each config change, and after each successful major change like a new image, new hosts, etc. Just be smart with your snapshots, you don’t need a whole lot. I normally keep just two.


  • [quote=“Wayne Workman, post: 43523, member: 28155”]Tom suggested that you check this (on the broken FOG vm) in the FOG data base: [FONT=arial][COLOR=#222222]Globalsettings.[/COLOR][/FONT][FONT=arial][COLOR=#222222]fog_regenerate_[/COLOR][/FONT][FONT=arial][COLOR=#222222]timeout[/COLOR][/FONT]

    [FONT=arial][COLOR=#222222]That’s the table and field for the timeout setting. it should NOT be set to zero…[/COLOR][/FONT]

    [FONT=arial][COLOR=#222222]beyond that, I’ve got nothing.[/COLOR][/FONT][/quote]

    [FONT=arial][COLOR=#222222]Globalsettings.[/COLOR][/FONT][FONT=arial][COLOR=#222222]fog_regenerate_[/COLOR][/FONT][FONT=arial][COLOR=#222222]timeout is set to [/COLOR][/FONT]0.5

    And just to review: my first two FOG installations that ended up locking me out were both on physical machines (both on the same hardware). I just recently brought up a third install in a VM as per your suggestion. That one is working OK so far.


  • [quote=“Wayne Workman, post: 43510, member: 28155”]What else are you doing on this Linux VM? Just FOG? What’s all the things that are installed? What versions?[/quote]

    On the FOG VM (this is the new install that’s currently working) all I’ve got going is FOG (other than Samba and RDP).


  • Tom suggested that you check this (on the broken FOG vm) in the FOG data base: [FONT=arial][COLOR=#222222]Globalsettings.[/COLOR][/FONT][FONT=arial][COLOR=#222222]fog_regenerate_[/COLOR][/FONT][FONT=arial][COLOR=#222222]timeout[/COLOR][/FONT]

    [FONT=arial][COLOR=#222222]That’s the table and field for the timeout setting. it should NOT be set to zero…[/COLOR][/FONT]

    [FONT=arial][COLOR=#222222]beyond that, I’ve got nothing.[/COLOR][/FONT]

  • Moderator

    [quote=“Wayne Workman, post: 43510, member: 28155”]What else are you doing on this Linux VM? Just FOG? What’s all the things that are installed? What versions?[/quote]
    Yeah, especially other PHP “apps” (other than phpmyadmin). In the end phpmyadmin might play a role too!!! But so far I don’t have any trouble and use it on most of my FOG servers…


  • What else are you doing on this Linux VM? Just FOG? What’s all the things that are installed? What versions?


  • It seems awfully odd that this is a “FOG” specific problem considering there’s how many different users out there, and from what I can tell you’re the first who seems to get completely locked out of the system in such a manner.


  • [quote=“Mark Pickard, post: 43507, member: 609”]Yeah, I came across that and a few others like it after Tom made some suggestions about the session files. If that’s what the problem is then it seems like it has to be a FOG problem since phpMyadmin is writing them OK.

    I’ve got another new FOG install up and running on Ubuntu 12.04 in a VM. This is the third install in the past two weeks with the first two ending in me being locked out of the web interface. Don’t know what else to try if this one locks me out again.[/quote]

    Until it gets solved, snapshots.

    There must be a way to fix it.


  • [quote=“Uncle Frank, post: 43419, member: 28116”]Hmmm, that’s interesting. So it’s FOG not being able to save session information properly. Not sure if this is related but someone had issues with wordpress writing zero size session files: [url]http://quirm.net/forum/topic.php?id=3950[/url]
    So far I couldn’t really see what was fixing the issue for him. But maybe this can lead us to where we should have a closer look…[/quote]

    Yeah, I came across that and a few others like it after Tom made some suggestions about the session files. If that’s what the problem is then it seems like it has to be a FOG problem since phpMyadmin is writing them OK.

    I’ve got another new FOG install up and running on Ubuntu 12.04 in a VM. This is the third install in the past two weeks with the first two ending in me being locked out of the web interface. Don’t know what else to try if this one locks me out again.

  • Moderator

    Hmmm, that’s interesting. So it’s FOG not being able to save session information properly. Not sure if this is related but someone had issues with wordpress writing zero size session files: [url]http://quirm.net/forum/topic.php?id=3950[/url]
    So far I couldn’t really see what was fixing the issue for him. But maybe this can lead us to where we should have a closer look…


  • Additional info:

    I’m able to login to phpMyadmin on this server and it appears to be generating PHP session files without a problem:

    [code]
    root@FOG:~# ls -al /var/lib/php5
    total 1500
    drwx-wx-wt 3 root root 1499136 Mar 6 11:54 .
    drwxr-xr-x 66 root root 4096 Feb 24 12:48 …
    drwxr-xr-x 2 root root 4096 Mar 4 16:16 old
    -rw------- 1 www-data www-data 23934 Mar 6 11:55 sess_pd6cadbemdnt9m3ks2bn1gpbguk4c75c
    root@FOG:~#
    [/code]


  • [quote=“Wayne Workman, post: 43327, member: 28155”]I’m going to assume you’ve tried logging in from a different computer, a different browser?[/quote]

    Yes to both.


  • I’m going to assume you’ve tried logging in from a different computer, a different browser?


  • Don’t know if it’s just a coincidence but both times this has happened (on two separate installations) I was changing settings on the FOG configuration page at /fog/management/index.php?node=about&sub=settings. Once it was AD settings and the other it was TFTP settings. As soon as I hit the “Save Changes” button it booted me back to the sign in page and from that point I could never sign back in.


  • [quote=“Tom Elliott, post: 43286, member: 7271”]Try this:

    [code]sudo service apache2 stop;sudo rm -rf /var/lib/php5/sess_*; sudo service apache2 start;[/code][/quote]

    It wiped the session files but I still see the same behavior.

    /var/lib/php5 after a couple attempts to login after running the above command:

    [code]
    root@FOG:/var/lib/php5# ls -al
    total 1476
    drwx-wx-wt 3 root root 1499136 Mar 5 08:10 .
    drwxr-xr-x 66 root root 4096 Feb 24 12:48 …
    drwxr-xr-x 2 root root 4096 Mar 4 16:16 old
    -rw------- 1 www-data www-data 0 Mar 5 08:10 sess_e60jnb59pcoqads486btknhsj4
    -rw------- 1 www-data www-data 0 Mar 5 08:10 sess_mqhj79o0eiih24g25cp37t4is2
    -rw------- 1 www-data www-data 0 Mar 5 08:10 sess_p1f43a9hrglme8diq0ptrmlu51
    [/code]


  • Try this:

    [code]sudo service apache2 stop;sudo rm -rf /var/lib/php5/sess_*; sudo service apache2 start;[/code]


  • [quote=“Tom Elliott, post: 43284, member: 7271”]What’s the alias you’ve got?[/quote]

    Line 3 of /etc/phpmyadmin/apache.conf is:

    [COLOR=#000000][code]Alias /phpmyadmin /usr/share/phpmyadmin[/code][/COLOR]

287
Online

9.1k
Users

15.7k
Topics

145.8k
Posts