Win 7 0xc0000225 boot failure Acer travelmate P245-M



  • So far I am unable to properly image my Acer Travelmate P245-M laptops using fog. The image is uploaded and downloaded successfully, however upon reboot after imaging, I get the 0xc0000225 error regarding boot failure and missing devices. The repair feature on the Win 7 x64 DVD does not help. I have run fogprep as well as sysprep with and without the generalized option selected when creating the image with the same results. The system is Windows 7 x64, boot is Legacy, and the hardware between machines is identical. I have not had issues imaging any other Windows machines, just these laptops. The bios is not terribly robust, but Legacy is selected properly. If I am missing some information that might help, please let me know and I will provide it ASAP.



  • @Bruno-Nogueira I’ve recently updated this: https://wiki.fogproject.org/wiki/index.php/Windows_8_UEFI_Imaging_Tips#Windows_8_and_8.1_Imaging_Problems

    Please look it over. Although it’s written for Win 8 / 8.1, I think it would probably apply to Win 7 as well.



  • Hi,
    I still can’t find a solution.
    After imaging the computer I have to follow this tutorial:
    Insert Windows 8 DVD and select repair computer
    Then select open command line and:
    Type in “diskpart”
    Type in “list disk”. Find out which disk the affected drive is.
    Type in “select disk #”, where # is the affected drive’s number
    Type in “list partition”, find the partition number of the system partition (it’s usually 100MB, 200MB, or 300MB), then type in “select partition #”, where # is the system partition’s number.
    Type in “assign letter=z”, assuming you don’t have a Z: drive.
    Exit out of diskpart by pressing CTRL+C
    Type in BCDBoot [Drive letter of affected drive’s Windows partition]:\Windows /S Z: /F UEFI So if the affected drive’s Windows partition is say G:, you would type in BCDBoot G:\Windows /S Z: /F UEFI

    Can this be done automatically after fog imaging?
    Thanks



  • @NCMikeD Holy cow… way to go man!



  • Gentlemen, I have found a bit of a workaround for my issue that I wanted to share with you. Here are the steps I took to get fog to image my Acer Travelmate p245 properly.

    1. Remove AF 4k hard drive from Acer P245 and attach to another computer via USB 3.0 cradle.
    2. Wipe the drive using EaseUS, removing the gpt and make the drive a logical unallocated drive.
    3. Install the hard drive into an Dell Optiplex 330 PC
    4. Install windows 7 x64 on hd mounted in optiplex. (Reason for this is because when Win 7 is installed on Acer, the GPT is recreated and an additional sda2 128mb fat 32 partition is created, whereas on the Optiplex, the basic sda1 100mb fat32 and sda2 499gb ntfs partition only partitions are created)
    5. After installation completes and Windows installer restarts for first time use, shut down optiplex and remove hard drive.
    6. Swap hard drive from optiplex to Acer P245 and complete windows install.
    7. Once image is created properly, remove hard drive from Acer P245 and place back into Optiplex 330
    8. Upload image from Optiplex 330 machine to FOG as Win 7 Single Disc - Re-sizable image type.
    9. Image another Acer P245 with standard GPT partitions and AF 4k and VIOLA!

    I do understand that this is not a solution, rather a workaround, and a rather insane one, but for right now it is going to hobble me into the school year until a real solution is created. hopefully some of this information will give insight as to where the disconnect currently is. I am also doing another experiment to upload the Win 7 image as a Windows 8 image, as far as fog knows that is. I will be back with pass fail results soon enough.



  • @NCMikeD It’s further explained at the bottom of this page: https://wiki.fogproject.org/wiki/index.php/SVN


  • Developer

    https://wiki.fogproject.org/wiki/index.php/Upgrade_to_trunk
    the trunk is the “work in progress” next version of fog. many upgrades and bug fixes are in the new code.



  • This particular acer bios does not have a way to disable UEFI. What is does have is an option to try legacy first then default back to UEFI. I know that these were designed with 8.1 in mind and we had them downgraded to 7 from the factory.

    @Wayne-Workman I will look at that article.
    @Junkhacker What is the difference between the normal upgrade process to 1.2.0 vs upgrading to trunk? Actually I may be asking that question incorrectly due to a lack of install knowledge with fog, but my sysadmin will certainly understand. Why would you assume upgrading to trunk would help?



  • @Tom-Elliott Thanks for your help.
    I’ve search on the internet and read the user manual but I can’t find the solution.
    I will call ASUS support again…


  • Senior Developer

    You should not have to turn off UEFI, but you should (for the time being) be able to disable secure boot.

    There’s almost always a way. It’s not that you’re turning off secure boot for the rest of time, but rather for the duration of the imaging process (whether up or down).

    Once the imaging process is complete turn Secure boot back on and all should work fine.

    If you can’t do this, then I don’t know how to be of any type of help.

    You can create the image, and you can deploy the image. You would need to repair every system for things to work though, which I think is what you’re trying NOT to do.

    Maybe there’s a hack to fix it, but I don’t know of it yet.



  • @Bruno-Nogueira Did you even check to see if turning it off allows you to turn off Secure Boot?



  • @Wayne-Workman I don’t would like to turn off UEFI, there has to be another solution



  • @Bruno-Nogueira Secure Boot is a UEFI thing. See if you can turn off UEFI, then this option shouldn’t be greyed out anymore.



  • @Tom-Elliott I can’t turn off Secure Boot. I can see the option in ASUS BIOS, but it is Gray.
    I called ASUS support and they tell me if it is gray and I have no visible button to change it, that means in this model I can’t do that.


  • Senior Developer

    Can you update SVN?

    Is SecureBoot turned off?



  • Hi, I’m having the same issue but with Windows 8.1 (UEFI)
    Windows 7 images (without UEFI) upload and download fine, but with UEFI after imaging with any error my Windows 8.1 show this:
    Recovery
    Your PC needs to be repaired
    A required device isn’t connected or can´t be accessed.
    Error Code: 0xc0000225

    I have the SVN 3603
    Thanks!




  • Developer

    you may have better luck if you upgrade to trunk



  • fog.png

    @Junkhacker We are running latest stable, 1.2.0


  • Developer

    @NCMikeD said:

    we have upgraded our fog server to the most current version with the same results.

    do you mean the latest official version (1.2.0) or the latest svn version, and if the svn version, what exact revision are you at?


 

556
Online

5.4k
Users

12.6k
Topics

118.9k
Posts