PXE menu not loading on Latitude 3540



  • I have imaged a couple of this model of computer when I was running .32, but I just upgraded to 1.2 (and updated DHCP to undionly.kpxe) (also, this is Ubuntu 12.04LTS) and this laptop will not load the menu. I also tried adding the host manually and telling it to download the image and it does not. It acts like it is going to load, flashes something too quick for me to catch and then goes into:
    initialising ipxe devices and then it does configuring (Mac address), then it flashes something else too quick to catch and then reboots the machine.

    I have successfully downloaded images to a couple of other models, so I don’t think it is a DHCP issue or anything like that. I have tried a few kernels (including a couple of Toms that aren’t under the published area), and so far nothing.

    Help me Obi Wan Kenobi, you’re my only hope!



  • The server is running just fine now. It has imaged a few computers, but it was still never able to be seen by that laptop, so I just built an image from scratch for it so that I could get it to the teacher that needed it. At this point I think there is something wrong with the switch in this room (rather old 3com switch). I am getting the superintendent to buy new switches, but one thing at a time (because of the price tag).


  • Developer

    Any news on this?? Please make sure TFTP is running and listening on the server:
    [CODE]sudo netstat -antup | grep “:69”[/CODE]



  • I don’t know what happened, but now after upgrading, my optiplex 380 won’t boot to Fog. It times out like it is a TFTP problem, but I rebooted the Fog machine and reset the tftp service on the Fog machine. I am about to leave this school and won’t be back until the 16th since they are at spring break next week. So, while I appreciate any responses, just know that I won’t be able to try anything until then.



  • It is still timing out. I would suggest that it is just a problem with this model, but I have already uploaded twice and downloaded once to and from a couple of laptops of the same model. Although now when it times out, it doesn’t do a full reboot, it kicks it straight to a windows startup.



  • Nevermind, upgrade in progress.



  • Does it matter which way I do it?


  • Developer

    [quote=“TThax, post: 43238, member: 27004”]Sorry if this is a stupid question, but update what to 3077?[/quote]

    [url]http://fogproject.org/wiki/index.php/Upgrade_to_trunk[/url]



  • Sorry if this is a stupid question, but update what to 3077?


  • Senior Developer

    Would you please upstate to 3077?



  • There was an update from A08 to A09. I updated it, same thing.


  • Developer

    have you checked for any bios updates available for that computer?



  • It appears to be drawing an IP before that screen. Attached is the two screens I see. I apologize for the poor quality, but it happens so fast that I couldn’t catch it when it was happening with a keystroke, so I shot video on my cellphone, and then took screenshots.

    All of this is happening on the same switch as 2 other computers that aren’t having this issue, and I have tried changing this computers patch cable to a port on the switch that one of the others was using just to make sure that it wasn’t a problem with a specific port config.

    [url="/_imported_xf_attachments/1/1747_fogsnip.PNG?:"]fogsnip.PNG[/url][url="/_imported_xf_attachments/1/1748_fogsnip2.PNG?:"]fogsnip2.PNG[/url]


  • Developer

    Are you getting this exact message and then it times out? If so then its not making it to the FOG MENU when this occurs. When this times out it means that this machine did not receive a DHCP address, thus never making it to the FOG MENU.



  • Wolfbane: All of my settings there look correct too. I just tried another latitude (E5530) that has never been imaged or registered with Fog, and it loaded the fog menu just fine. I changed it back to undionly.kpxe because the .kkpxe caused some different issues. It is doing what it did before, where it loads the screen attached, then it just reboots.

    [url="/_imported_xf_attachments/1/1746_morefog.jpg?:"]morefog.jpg[/url]


  • Developer

    Match your settings here is what I have. IF you didn’t change any of the locations of things.
    [ATTACH=full]1742[/ATTACH]

    [url="/_imported_xf_attachments/1/1742_Untitled.png?:"]Untitled.png[/url]



  • How would I correct that, Junkhacker?

    I am running Ubuntu 12.04LTS 64bit, and I tried both the 64 bit and 32 bit kernels. Each change I make, it still works fine with the optiplex 330 I have been using as a test machine, just not with the latitude.


  • Developer

    [quote=“TThax, post: 43015, member: 27004”]I changed it to undionly.kkpxe and now it does what you see in the image.[/quote]

    that looks to me like a kernel/init to 32/64 bit mismatch


  • Developer

    Interesting… I am not 100% sure but I think this is kind of the same issue I see when running FOG on our Macminis. [URL=‘http://fogproject.org/forum/threads/mac-support.11033/page-2#post-34584’]See here[/URL] on how I got this fixed. Maybe it works on your Latitude 3540 as well…?

    Seams like this was fixed in SVN at some point but maybe got reverted later on?!



  • I changed it to undionly.kkpxe and now it does what you see in the image.

    [url="/_imported_xf_attachments/1/1732_Fogissue.jpg?:"]Fogissue.jpg[/url]


Log in to reply
 

415
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.