Been a Long Time--- New TFTP Errors



  • Hey all…
    Been awhile.

    Got a new job, and one of the first things I’m charged with is getting a FOG server up and running. Of course, I’m not as well versed on this network as I am on the old place, so I need some more eyes/ears for this.

    I have Ubuntu Server 13.10 running Fog 1.2.0.

    Have everything installed.

    When I PXE boot a Dell Optiplex 580-- I was able to initially get to the FOG screen and register it. Then, I rebooted to upload an image.

    Receive the following:
    /default.ipxe…No such file or directory ([url]http://ipxe.org/2d12603b[/url])

    I was receiving this error prior, and we opened up some ports on our firewalls. I also disabled the firewall on the Fog server. That’s when I finally got it to boot the first time, but has not done it since…just keeps throwing that error.

    Any thoughts/suggestions here?


  • Developer

    Maybe try a different switch?!



  • Nope. In fact, both machines are sitting right here on my desk, connected to the same dumb switch.


  • Developer

    As a possibility, are the fog server and the client on different vlans?



  • Okay. I still cannot download the file directly, however I was able to access the FOG menu from an optiplex 960. I’m attempting an upload at this time.


  • Developer

    so running [code]tftp x.x.x.x get undionly.kpxe[/code] gave you a write error?

    If so then check to see if your firewall is disabled. It has been found, in other occurances, that ufw was disabled but iptables were not accepting all communication. If could also be permissions.

    Try running:
    [CODE]sudo ufw disable

    sudo iptables -F
    sudo iptables -X
    sudo iptables -t nat -F
    sudo iptables -t nat -X
    sudo iptables -t mangle -F
    sudo iptables -t mangle -X
    sudo iptables -P INPUT ACCEPT
    sudo iptables -P OUTPUT ACCEPT
    sudo iptables -P FORWARD ACCEPT[/CODE]

    TRY to get to the FOG menu now.

    Then to force “everyone” permissions for your tftp folder run:
    [CODE]chmod -R 777 tftpboot/[/CODE]

    TRY again to get to the FOG menu.



  • Tried restarting TFTPD-HPA service. It did. Still receiving the “write” error when trying to transfer the file. STP is NOT enabled on our switches.
    Again, could this be a permissions issue?


  • Developer

    Could tftp have crashed? Could you try restarting the tftp service and try again? If this does help there were updates to correct for this.

    If not then, try checking to see if STP is enabled on your switches. It’s a shot in the dark but sometimes STP will allow tftp then then suddenly deny the service.

    A quick run through of [URL=‘http://www.fogproject.org/wiki/index.php/Tftp_timeout…’]THIS[/URL] wiki may lead you to finding out your issue. If you find anything else that caused your issue I will be happy to add it to this wiki.



  • I actually did this prior to posting. I was able to obtain the undionly.kpxe file through my workstation using TFTP. Although, now I am unable to do so.
    Something funny is going on----TFTP seems to be working, and then not working for whatever reason.
    As I stated previously, I was able to get it to boot to the FOG screen once. I registered the workstation, and then rebooted to upload an image.
    It would not load FOG after that…just timing out, and I receive an error when trying to download via TFTP.

    “A problem occurred while trying to write to the file from x.x.x.x” Permissions issue, maybe?


  • Developer

    i would start with troubleshooting your tftp, make sure that’s working right by manually trying to download undionly.kpxe from a windows tftp client


Log in to reply
 

445
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.