New FOG setup, TFTP timeout-PXE-E32



  • Greetings, I have setup FOG 1.2 on Ubuntu 14.04 on a dedicated “server”. I get a PXE-E32 TFTP open timeout error when attempting to PXE boot a workstation. I followed the fog wiki on the config.

    I can ping the server, and can “get undionly.kpxe” on the server, but not on a workstation.

    I have followed several checklists, but cannot figure out what about the config won’t allow the tftp connection.

    Any suggestions on what to check/try next?

    Any help is greatly appreciated!!!



  • This post is deleted!


  • Update It was the leftover opt 67 pointing to the incorrect boot file causing the issue I was having after installing DNSMASQ.

    Well, I was going through and found that I already had a link from .kpxe to .0, I made sure the permissions were the same on both files…and just for fun I decided to see what happened and I actually just pulled up the FOG menu on the workstation which I just registered.

    I am now capturing my first image! I ‘think’ I may have left option 66/67 active in my DHCP server which was causing the issue.
    I have been going back and forth between my landesk PXE setup and the FOG setup when a new image was needed.

    I will test my theory and update.

    Thank you all, very much, for your help and suggestions in getting this going!


  • Developer

    wow, i seem to be getting a lot of details wrong today. maybe i should have taken another day off…


  • Developer

    [quote=“Tom Elliott, post: 42083, member: 7271”]That was specific the novell dhcp, and a version and below of that.

    The thing that sounds most likely that’s happening.

    ip-helper is not setup to direct traffic back to the dhcp server to even get the options.[/quote]

    To be specific Novell Netware 6.5

    The only reason I know all this is because My network is sorely outdated. I had to devise a plan to still be able to use FOG and the new iPXE without altering my network because it will not accept certain values.

    Matter of fact, Netware 6.5 has a VERY strict 8 character limit that even applies to groups, and usernames, it’s quite cumbersome.


  • Senior Developer

    That was specific the novell dhcp, and a version and below of that.

    The thing that sounds most likely that’s happening.

    ip-helper is not setup to direct traffic back to the dhcp server to even get the options.


  • Developer

    ok, so i got the part about the switches changing the requested file name wrong, but i think i remember someone having problems with switches not passing along undionly.kpxe as a boot file name, i suspect because it doesn’t fit within the 8.3 parameters of the old dos days, but undionly.0 or pxelinux.0 do.


  • Developer

    [quote=“Junkhacker, post: 42074, member: 21583”]Jaymes can correct me if i’m getting this wrong, but i believe he had a packet capture that showed switches changing the requested file from undionly.kpxe to undionly.0
    to fix the issue, he created a symbolic link between the actual file and the requested file
    ln -s /tftpboot/undionly.kpxe [FONT=Tahoma]/tftpboot/undionly.0[/FONT][/quote]

    It is a native function of dnsmasq, not sure why, but it does append the .0 to the file name, not the switches. Just to clarify.

    But the resolution was to symlink undionly.kpxe to undionly.0

    and it IS part of the installation instructions on the wiki for using DNSMASQ with iPXE.

    I have only tried DNSMASQ setup on Novell Netware 6.5 and a simple home network with a linksys router, I don’t have experience in other network environments.


  • Developer

    Jaymes can correct me if i’m getting this wrong, but i believe he had a packet capture that showed switches changing the requested file from undionly.kpxe to undionly.0
    to fix the issue, he created a symbolic link between the actual file and the requested file
    ln -s /tftpboot/undionly.kpxe [FONT=Tahoma]/tftpboot/undionly.0[/FONT]


  • Developer

    I’ve not heard about switches only passing files matching any sort of pattern (e.g. “*.0”) but you can still give it a try by renaming or linking ‘undionly.kpxe’ to ‘pxelinux.0’ (very common name).

    But I have heard about layer 3 switches doing some kind of magic like not forwarding but only relaying DHCP offers…


  • Developer

    that’s one of the reasons Jaymes recommends DNSMASQ, i believe there are instructions on the wiki for that scenario



  • [quote=“Junkhacker, post: 42057, member: 21583”]have you tried Tom’s suggestion? [CODE]sudo ufw disable[/CODE][/quote]

    Yes, disabling the firewall was one of the steps in the config.

    I’ve got it connected through an un-managed switch for the “imaging bench” (server resides in the same room for now), which connects to the rest of the network/servers through a layer 3 switch.

    I read somewhere that some switches will only pass a file with a “.0” at the end…I am wondering if that might be the case here…Any thoughts on that?


  • Developer

    [quote=“Junkhacker, post: 42061, member: 21583”]didn’t see that, i’m guessing it’s a switch issue than[/quote]

    Possibly along the lines of [url]http://fogproject.org/wiki/index.php/IPXE#What_do_I_enable_and_disable.3F[/url]


  • Developer

    didn’t see that, i’m guessing it’s a switch issue than


  • Developer

    [quote=“haste347, post: 41989, member: 28447”]
    Chain INPUT (policy ACCEPT 714K packets, 82M bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 27794 packets, 4641K bytes)
    pkts bytes target prot opt in out source destination[/quote]

    No iptables rules loaded and default policies set to ACCEPT. I doubt that a local firewall could be the issue.


  • Developer

    have you tried Tom’s suggestion? [CODE]sudo ufw disable[/CODE]


  • Developer

    Is your TFTP server really running and listening on the FOG server?
    [CODE]netstat -antup | grep ":69"
    udp 0 0 0.0.0.0:69 0.0.0.0:* 10149/in.tftpd[/CODE]

    If yes there probably is another firewall is involved. Any router/firewall/layer-3 switch between client and FOG server??? How are client and FOG server connected?



  • Oh, ok…Yes, I have already initialized the database when it asked.

    I am not able to ‘get’ from a workstation, still.


  • Developer

    When you navigate to the web GUI for the FOG server, if you haven’t done so already, it will ask you to update the schema.

    This will allow the database to be initialized and set up properly for your version of FOG.

    If you have already completed the schema update (required after installation of FOG) then it will not be necessary to complete the action again.

    It appears as if it did not receive the file in time. Are you able to now use the tftp get command on a windows workstation?



  • [quote=“Jaymes Driver, post: 41993, member: 3582”]When you say workstation, you mean a windows machine in the same network as the FOG server? If your DHCP options are correct, you should at least get some kind of out put.

    I highly recommend DNSMASQ. It seems that you are having difficulty resolving your bootfile name.

    [url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url][/quote]

    Alright, I followed this setup and I am now getting through. However, I am unclear what the instructions meant by “update the schema…” for the iPXE boot.

    When I PXE boot from a workstation, I choose “boot to network”, which then gets me to the attached screen/error.

    Would you enlighten me further, please? I’d hate to mess something up when the resolution seems so close!

    Thank you again for all your help!

    [url="/_imported_xf_attachments/1/1674_IMAG2049.jpg?:"]IMAG2049.jpg[/url]


Log in to reply
 

489
Online

38965
Users

10708
Topics

101618
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.