Install hangs on php5-mysqlnd



  • I have 2 servers I’ve been testing the fog SVNs on, and with the more recent updates the install always gets to installing php5-mysqlnd and just stops. I’ve let it sit for about 15 minutes, but every time I have to ctrl-c to end the script and then run it again and it completes okay. Anyone else noticing this?


  • Developer

    I’ve noticed the same thing, Ben



  • It was earlier today, I think I remember seeing 2968. Although it was on several versions before that too.

    But I did come across something, it might have something to do with phpmyadmin. Phpmyadmin wouldn’t load after I did the updates. So I re-installed it, and just happened to notice something about it removing mysqldn and then the apache log error file started filling up with fog errors. Then I ran the fog install script, got that working, and phpmyadmin was broken again. I’ll have to look into that more tomorrow when I’m back at work.


  • Developer

    [quote=“Joseph Hales, post: 41667, member: 18131”]On which SVN did this start I updated to 2952 last week and and didn’t see this behavior if its more recent maybe someone else can confirm the behavior or maybe something is bugged on your side if its not showing on anyone else’s installs. Also there is a better script for updating SVN’s that doesn’t run the installer if you are updating frequently in the FOG tweaks.
    [url]http://fogproject.org/forum/threads/fog-tweaks.12121/#post-39864[/url][/quote]
    BE WARNED: That script will not update kernels and init files. Using the install script may take a few seconds longer but it will always get the most up-to-date files. See details of [url]http://fogproject.org/wiki/index.php/Fog_Tweaks#Updating_Script[/url]

    [quote=“Ben Warfield, post: 41643, member: 17746”]I have 2 servers I’ve been testing the fog SVNs on, and with the more recent updates the install always gets to installing php5-mysqlnd and just stops. I’ve let it sit for about 15 minutes, but every time I have to ctrl-c to end the script and then run it again and it completes okay. Anyone else noticing this?[/quote]

    I have not noticed this issue with mysqldn. Try stopping mysql then run the update. Then after update confirm mysql is still running.


  • Testers

    On which SVN did this start I updated to 2952 last week and and didn’t see this behavior if its more recent maybe someone else can confirm the behavior or maybe something is bugged on your side if its not showing on anyone else’s installs. Also there is a better script for updating SVN’s that doesn’t run the installer if you are updating frequently in the FOG tweaks.
    [url]http://fogproject.org/forum/threads/fog-tweaks.12121/#post-39864[/url]


Log in to reply
 

354
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.