Image Size on Server 0GB



  • Hi There…
    Ubuntu 13.10
    Latest Version of FOG

    Uploaded image successfully. In image management it says Image Size on server is 0. When trying to download an image to a host it says that you have to upload an image first.

    I followed another thread with the same problem. I moved the image from /dev into /images and named it to match the image name in image manager. Set all the permissions to Chmod 777 and I am able to FTP to my fog server using the credentials. HELP been working on this forevverr. Thank you:)



  • [quote=“Wayne Workman, post: 43563, member: 28155”]Not a problem at all.

    So, the “r” means revision (at least in my head, it works, I’m not changing).

    Revision versions are newer than the latest release. The latest release is 1.2.0. The current latest revision is 3096 (but knowing Tom, it won’t be for long, probably within the hour).

    You’ll find lots and lots of bug fixes, feature implementations, performance increases, and a wider range of supported hardware and Linux distributions with the latest revision. You may also find bugs that aren’t known about, but also keep in mind that it’s very unlikely that a unknown bug would prevent you from imaging, and wouldn’t result in any information loss.

    To update to the latest revision, it’s pretty easy. Look at this wiki page: [url]http://fogproject.org/wiki/index.php/SVN[/url]

    I use Fedora 21, and the exact steps I take to update to a specific revision are like this:

    [COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]yum install svn[/CODE][/COLOR][/FONT][/FONT][/COLOR]
    [FONT=Tahoma]You only need to install svn once…[/FONT]

    [FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]svn co -r 3096 [URL]https://svn.code.sf.net/p/freeghost/code/trunk[/URL] /opt/fog_trunk[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT]
    [FONT=Tahoma]And, for whatever revision I want, I’d just change the number in this line.[/FONT]

    [FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]cd /opt/fog_trunk[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT]
    [FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]cd bin[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT]
    [FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]./installfog.sh[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT]

    [FONT=Tahoma]If you’re not using Fedora, I think the only thing that changes is the “yum” command. You’d instead use that apt-get thingy to install svn. So, for Ubuntu, you’d use something like this to install svn.[/FONT]
    [FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]sudo apt-get install subversion[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT]

    [FONT=Tahoma]When you run the installer, it should just carry over all of your current settings. It does for me at least. You’ll also be asked during the install to update your database schema. You do that by going to FOG’s Web GUI and just clicking the update button, and waiting for it to get done. There might be some errors from updating the database, but they are non-impacting and are related to supporting upgrading from much older versions I think.[/FONT][/quote]

    Wayne,

    Thank you very much for the detailed information. I will give this a try and let you know if it fixes the issue or not.


  • Moderator

    [quote=“Matthew N, post: 43558, member: 28939”]Wayne,

    I apologize but i’m not sure what you mean by r3096. I’m really new to fog.[/quote]

    Not a problem at all.

    So, the “r” means revision (at least in my head, it works, I’m not changing).

    Revision versions are newer than the latest release. The latest release is 1.2.0. The current latest revision is 3096 (but knowing Tom, it won’t be for long, probably within the hour).

    You’ll find lots and lots of bug fixes, feature implementations, performance increases, and a wider range of supported hardware and Linux distributions with the latest revision. You may also find bugs that aren’t known about, but also keep in mind that it’s very unlikely that a unknown bug would prevent you from imaging, and wouldn’t result in any information loss.

    To update to the latest revision, it’s pretty easy. Look at this wiki page: [url]http://fogproject.org/wiki/index.php/SVN[/url]

    I use Fedora 21, and the exact steps I take to update to a specific revision are like this:

    [COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]yum install svn[/CODE][/COLOR][/FONT][/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma]You only need to install svn once…[/FONT][/COLOR]

    [COLOR=#141414][FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]svn co -r 3096 [URL]https://svn.code.sf.net/p/freeghost/code/trunk[/URL] /opt/fog_trunk[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma][FONT=Tahoma]And, for whatever revision I want, I’d just change the number in this line.[/FONT][/FONT][/COLOR]

    [COLOR=#141414][FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]cd /opt/fog_trunk[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]cd bin[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][CODE]./installfog.sh[/CODE][/COLOR][/FONT][/FONT][/COLOR][/FONT][/COLOR]

    [COLOR=#141414][FONT=Tahoma]If you’re not using Fedora, I think the only thing that changes is the “yum” command. You’d instead use that apt-get thingy to install svn. So, for Ubuntu, you’d use something like this to install svn.[/FONT][/COLOR]
    [COLOR=#141414][FONT=Tahoma][COLOR=#000000][FONT=monospace][FONT=Tahoma][COLOR=#141414][FONT=Tahoma][CODE]sudo apt-get install subversion[/CODE][/FONT][/COLOR][/FONT][/FONT][/COLOR][/FONT][/COLOR]

    [COLOR=#141414][FONT=Tahoma]When you run the installer, it should just carry over all of your current settings. It does for me at least. You’ll also be asked during the install to update your database schema. You do that by going to FOG’s Web GUI and just clicking the update button, and waiting for it to get done. There might be some errors from updating the database, but they are non-impacting and are related to supporting upgrading from much older versions I think.[/FONT][/COLOR]


  • Moderator

    This post is deleted!


  • [quote=“Wayne Workman, post: 43556, member: 28155”]r3096 should fix this. It did for me.

    [IMG]http://s29.postimg.org/dvicl36fb/image_size.png[/IMG][/quote]

    Wayne,

    I apologize but i’m not sure what you mean by r3096. I’m really new to fog.


  • Moderator

    r3096 should fix this. It did for me.

    [IMG]http://s29.postimg.org/dvicl36fb/image_size.png[/IMG]



  • Hello Andrew,

    I am having the same issue you are describing in this post. Did you ever find a resolution to your issue?



  • Hello,

    I am having this same issue with the Image Size on server reporting 0. I have Fog 1.2 and CentOS 6.6. Do you know anything that I can check to see why I am reporting a size of 0 for image size on the server? I noticed that my Storage Node User/password is different than the Storage Management user/password. Should they be the same. Also my TFTP user/password is different as well.

    Thanks for any information or troubleshooting steps you can give.
    Andrew



  • [quote=“Tom Elliott, post: 39942, member: 7271”]Add seccomp_sandbox=NO to /etc/vsftpd.conf and restart the vsftpd service[/quote]

    OMG Success Thank you!


  • Senior Developer

    Add seccomp_sandbox=NO to /etc/vsftpd.conf and restart the vsftpd service



  • [quote=“Junkhacker, post: 39935, member: 21583”]have you tried logging into the fog server with an ftp client, such as filezilla, with the user “fog” ?[/quote]

    I got this message when trying to connect with FTP using the username and password.

    [url="/_imported_xf_attachments/1/1554_7.png?:"]7.png[/url]


  • Developer

    have you tried logging into the fog server with an ftp client, such as filezilla, with the user “fog” ?



  • Here are some screenshots

    [url="/_imported_xf_attachments/1/1548_1.png?:"]1.png[/url][url="/_imported_xf_attachments/1/1549_2.png?:"]2.png[/url][url="/_imported_xf_attachments/1/1550_3.png?:"]3.png[/url][url="/_imported_xf_attachments/1/1551_5.png?:"]5.png[/url][url="/_imported_xf_attachments/1/1552_6.png?:"]6.png[/url]



  • [quote=“Tom Elliott, post: 39886, member: 7271”]Have you ensured the Storage Nodes username and password are set to the same that allow you to login?[/quote]

    The only username and password thats different seems to be the fog_storagenode_mySQLUSER and _mysqlpassword which is randomly generated characters. how can i test this is correct?



  • [quote=“Tom Elliott, post: 39886, member: 7271”]Have you ensured the Storage Nodes username and password are set to the same that allow you to login?[/quote]

    Thank you for the response. Yes I set the same password everywhere when trying to troubleshoot the issue. What else should i check? Do you want screenshots of anything?


  • Senior Developer

    Have you ensured the Storage Nodes username and password are set to the same that allow you to login?


Log in to reply
 

365
Online

38984
Users

10712
Topics

101686
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.