Intel RAID



  • Hey guys,

    Does anyone know if Intel RAID (fake raid) is supported?

    I have a load of Optiplex 9020 that i need to image, but either when i pull or push, it will only grab or put to a single disk which breaks the raid 1 mirror.

    Using upload/download-debug shows the two drives (sda sdb) but it doesn’t seemt to see the mapper device for the raid.

    If it is not supported, can i ask that it be looked into? More and more systems we are getting are comming with RAID 1 (two drives) by default. And i can’t believe i am going to be the only one fighting this as time goes on.

    Any ideas.


  • Moderator

    Cross linking post: https://forums.fogproject.org/topic/7851/intel-raid0-image-capture

    We now know what is going on with this and there is a work around pending.



  • @Developers , @Senior-Developers

    I’m attempting to capture an image of a Lenovo Thinkpad W530 in Raid0.

    On latest trunk as of today at 9am.

    mstat.txt
    mdadm_examine.txt
    mdadm_assemble.txt (This file is empty. I ran the command several times and it never dumped any data into the .txt file)
    md_devices.txt

    Host options are :

    kernel arguments: mdraid=true
    primary disk: /dev/md126

    When running as “single disk - multiple partitions”, it goes great until it checks for partitions and then returns:

    “Could not find Partitions”

    Running a capture now as “Multiple Partitions - All Disks”

    Host options:

    kernel arguments: mdraid=true
    primary disk: [Empty]

    Only showing sda1 in part clone view, hopefully it will start sdb immediately after.

    EDIT: It appears it didn’t. Only made a RAW image of sda1.


  • Developer

    I am sorry but I feel pretty lost with this as I don’t have such a machine here to test!

    The only thing I can offer is to go through this again from the start step by step. Just an offer. It’s up to you if you want to.

    Let’s start with the client you are getting the image from. Configure a complete new image for that client in FOG and make it Multiple partition image - single disk (not resizeable). The run a debug session for that client, boot it up and wait till you get to the command shell. Then run the following commands and post the full output here in the forums or upload the text files. Replace x.x.x.x with the IP address of your FOG server.

    mkdir -p /mnt
    mount -t nfs -o rw,nolock x.x.x.x:/images/dev /mnt
    mdadm --examine /dev/sd? > /mnt/mdadm_examine.txt
    cat /proc/mdstat > /mnt/mdstat.txt
    mdadm --assemble --scan --verbose > /mnt/mdadm_assemble.txt
    ls -al /dev/md* > /mnt/md_devices.txt
    umount /mnt
    

    I just typed and copied those commands without testing. There might be typos.



  • When setting the “Host Primary Disk” to /dev/md126 because there is no /dev/md0.

    The following error message show up when restore a resizable windows 7 sysprep image.

    Problem opening /dev/md126p for reading! Error is 2.
    The specified file does not exist!
    Problem opening /dev/md126p for reading! Error is 2.
    The specified file does not exist!

    • Processing Partition: /dev/md126p1 (p1)
    • Partition File Missing: /images/W7/d1pp1.im*
      Problem opening /dev/md126p for reading! Error is 2.
      The specified file does not exist!
      Problem opening /dev/md126p for reading! Error is 2.
      The specified file does not exist!
      Problem opening /dev/md126p for reading! Error is 2.
      The specified file does not exist!

    It looks some kind of fog bugs when processing fakeraid Raid0 partition.

    It has problem to properly read the raid0 partition and it tries to read d1pp1.im* file instead of d1p1.im* file.


  • Moderator

    Just posting some of my own success with RAID and fog.

    I have a genuine hardware RAID setup at the house, I just got done installing CentOS 7 on it.

    It’s setup with two sata hard drives in RAID 1 configuration.

    I was having a very hard time trying to access the logical RAID 1 volume, and the below kernel options weren’t working, and I wasn’t having luck with finding what the system was refering to it as either.

    However - I think I might have come across a better solution.

    fdisk -l clearly shows two disks with exact size, model, and partitions.

    I simply created a new a new image using multiple partition image - single disk (not resizeable)

    and obviously I assigned that to the host, and for “host primary disk” I just entered /dev/sda and it worked like a charm.

    I’m a little curious about how my RAID 1 controller card would react if FOG tried to resize /dev/sda alone…

    Perhaps the RAID card will make those changes to sdb ? maybe the RAID 1 volume will degrade! lol

    I have no idea… but…

    this is a really good way to get an image off of a RAID 1 system and then put it onto a NON-RAID system. :-)

    I’ll experiment with this and the resizable images.


  • Developer

    Well, seams like it all depends. I cannot give you an easy solution like “just do it this way and you’ll be ok” as I don’t have a similar machine here to test.

    What do you see when running the following command in debug mode: gdisk -l

    Maybe those links are helpful: http://serverfault.com/questions/226053/intel-matrix-storage-raid-and-linux-mdadm and https://forums.gentoo.org/viewtopic-t-888520-start-0.html

    Also check out the device files you have in /dev/md/ and let us know.

    Edit: fakeraid is even more complicted than I had in mind: https://raid.wiki.kernel.org/index.php/RAID_superblock_formats
    See if you can find out how your RAID was setup in the first place. Then we might be able to find a solution to image this thing too.



  • Set the “Host Primary Disk” to /dev/md0 and test again and still no go.

    Went into debug mode to check the raid status

    mdadm -D /dev/md0
    shows the status of md0 is “inactive”

    cat /proc/mdstat
    shows only md126 is “active” and md127 is inactive

    The problem seems that FOG does not assemble /dev/md0 properly

    Re-run the task after setting the “Host Primary Disk” to /dev/md126
    still not go , it shows “Problem opening /dev/md126p1 for reading! Error is 2. The specified file does not exist!”

    The problem seems that FOG try to read from /dev/md126p1 instead of /dev/md126


  • Developer

    Re-reading your post and trying to find out a bit more about the RAID in Optiplex 9020 I noticed that I was totally wrong, sorry! This is not a real RAID but a fakeraid (as you already said in your first post :wink:). It is Intel ICH8R (82801HR) southbridge which they call a ‘firmware RAID’. After setting it up properly on the target machine (http://www.dell.com/support/article/us/en/19/SLN153494/EN) you still need to address this in linux as well.

    Do you have ‘Host Primary Disk’ configured for those hosts? FOG is not intelligent enough yet to find out about (fake)RAID setup and use the correct device just by itself! You might be fine not setting ‘Host Primary Disk’ for the host you are getting the image from as /dev/sda should be equal to /dev/sdb (FOG uses /dev/sda as default). But you need to set this to /dev/md0 to make FOG properly deploy to your RAID.

    By the way: “Multiple Partition Image - All Disks” probably won’t help you as the RAID array won’t be in sync if it is not properly deployed through the correct device file AFAIK.


  • Moderator

    @Uncle-Frank Very true.

    When you’re using hardware RAID, the OS is oblivious to it. Even FOG would be oblivious to a good hardware RAID setup.

    Since it’s clearly not hardware RAID, or a good hardware RAID - use “Multiple Partition Image - All Disks”


  • Developer

    What does it look like on the original system?? If this is a real RAID controller you shouldn’t see the two disks in Windows! A real RAID is not configured in Windows/Linux but has it’s own (BIOS-like) configuration. You’d have to configure the RAID on the target system before cloning. This cannot be done by FOG!


  • Moderator

    @mutant Not sure but I think that FOG only see the disk not the volume.



  • Upgrade the official published kernel from 4.2.0(Sept 17 2015) to 4.2.1 TomElliott (Sept 22 2015) and test again

    Optiplex 9020 with two 500GB physical hard drive.
    The system can network boot.
    Both of Raid0 and Raid1 test with deploy successfully to boot OS but only deploy to one disk.

    Raid1 (Mirror) 465.8GB
    Deploy a sysprep windows7 image result in degraded raid as it only deploy to one disk.
    Raid0 (Stripe) 931.5GB
    Deploy a sysprep windows7 image result in failed raid as it only deploy to one disk.
    Raid0 Image
    2015-09-24_101613.gif
    2015-09-24_101510.gif
    Raid1 Image
    2015-09-24_104638.gif
    2015-09-24_104609.gif


  • Moderator

    @mutant said:

    9020

    I have Dell Optiplex 9020s at work. The factory firmware settings come with the hdd operating in “RAID ON” mode instead of AHCI. I’ve been able to successfully image this system with FOG Trunk. Have you played with these HDD operation mode settings? Does the 9020 have two physical hard drives, or just one? What is not working? Can the system network boot? Can you upload an image? Can you download an image? Can you provide a photograph of the issue you’re seeing?


  • Senior Developer

    Again,

    I need more information.

    What is happening, what isn’t working? Does the system recognize the volumes at all?



  • Kernel was updated last week when upgrade using git to trunk version 4702.
    The git source “S99fog” file does have the $mdraid change.


  • Developer

    Did you download the new init and kernel files before testing?



  • 2015-09-23_152422.gif
    putting Host Kernel Arguments “mdraid=true” still result in the same issue that when deploy image it will break the raid and only image one disk.


  • Senior Developer

    I don’t know if this will help anybody.

    https://github.com/FOGProject/fogproject/pull/53

    But I’m not going to try auto mounting raid myself.

    Follow the instructions (essentially set the host’s kernelArgs to contain mdraid=true)


  • Senior Developer

    @mutant What is the issue that is still there?


Log in to reply
 

440
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.