Single Disk Multiple Partition works after a sector by sector but not before, partition problems.



  • Hi all,

    So I have had fog thrown at me by my company and told to make it work. Single partition stuff has been fine, we are just working on a faster solution using a GigE switch. However we have been unable to get any image using multiple partitions to work.
    It is a windows 7 64bit image with 4 partitions. I have managed to pull the image from the master however it does not push properly (giving a typical winload.exe error) however if I do a sector by sector push first, it works and then allows the original multiple partition image to be cloned over the top, presumably because it now has the correct partition table in place with the correct sizings.
    Could someone help/analyse our system to help the multiple partition image please.
    Thanks.


  • Banned

    This post is deleted!


  • i ll try it tomorrow but 1st i have to reinstall Fog because i ve a of problem with the last svn


  • Developer

    Thanks to Junkhacker I had a second look at how FOG saves GRUB. And it actually does “the magic” to save more than just the first sector (MBR). You might be lucky and it’ll all work out for you setting OSID to Linux. Or it might leave you with other trouble. Let us know! You definitely need OSID=Linux to make FOG save the extended grub4dos bootloader.



  • Thank you Uncle Frank, you was able to explain my problem in more clear way than i did… :-)
    Junkhacker, I ll try it tomorrow and i ll keep you posted


  • Developer

    for a grub4dos bootloader, perhaps try using “linux” as your OS type. for windows we assume BCD


  • Developer

    Well that’s kind of special setup, isn’t it!? From what I read here (see the last post!) [url]http://reboot.pro/topic/19651-missing-mbr-helper-when-restoring-a-full-clone-with-grub4dos-mbr/[/url] and in the source code I am pretty sure that FOG is not made to handle something like this at the moment.

    Maybe you want to try implementing this feature into FOG!? I am sure it is possible!



  • Well, it s “almost” working…
    The image is downloaded correctly on the clients but when I start them, I have an error “Missing MBR-Helper”.
    I m able to solve it by starting the computer with an usb key with Hiren boot cd => Mini windows 7 => InstallGrub4dos.cmd

    For sure you need some further explanation…
    [url]http://everyday-tech.com/using-clonezilla-to-create-a-custom-image-recovery-partition/[/url]
    I m using fog to deploy image to clients but each client has it s own local image locally made by Clonezilla. In that way, when a computer need to be reinstalled, i first run the local image.

    That command InstallGrub4dos.cmd changes the MBR (i believe) and is giving me a new boot menu. But i don’t know why it s not supported and why i get that error message.
    It s not so big problem cause i can make those step (create the recovery partition) after deploying the clients but for sure i would prefer not… :-)

    Any ideas ?

    thx


  • Developer

    Probably! We worked on issues with extended partitions in the last week(s). I hope your setup with extended partitions is working now. Please report if it does not!



  • So it means that that problem has been solved with the last fog version !
    :-)


  • Moderator

    I use this parititon table (dual boot Win/Deb) without problem :

    [CODE] Device Boot Start End Blocks Id System
    /dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
    /dev/sda2 206848 204802047 102297600 7 HPFS/NTFS/exFAT
    /dev/sda3 204802048 409602047 102400000 83 Linux
    /dev/sda4 409604094 625141759 107768833 5 Extended
    /dev/sda5 409604096 425988095 8192000 82 Linux swap / Solaris
    /dev/sda6 425990144 625141759 99575808 7 HPFS/NTFS/exFAT[/CODE]



  • hi,
    there is a 2967 now…
    So i updated Fog and it seems to work BUT i don’t know if it because i put primary partitions or because of the new version.
    I think that i kept my previous image version and i ll test it cause i believe it may help other people…

    Regards,

    R.D


  • Moderator

    [quote=“raymondub, post: 41616, member: 28342”]I ve now Version: 2961
    Is it good ?[/quote]
    Hi,

    The latest SVN is 2966.

    Regards,
    Ch3i.



  • I ve now Version: 2961
    Is it good ?



  • searching on the forum, i saw that i wasn’t the 1st to have the problem and maybe it was cause the partition.
    I have 1 hard drive with : 1 primary, 1 extended and 1 partition.
    I just change that and put convert them all into primary partition. I m making a new image and we’ll see.
    I think that i already upgrade the trunk byt doing the svn update. Is it the same thing ?

    [SIZE=2][B]Ubuntu[/B][/SIZE]
    [SIZE=2][B]Install Subversion[/B][/SIZE]
    [SIZE=2]sudo apt-get update [/SIZE]
    [SIZE=2] sudo apt-get install subversion[/SIZE]
    [SIZE=2][B]Download the package[/B][/SIZE]
    [SIZE=2]cd ~ [/SIZE]
    [SIZE=2] mkdir svn [/SIZE]
    [SIZE=2] cd svn [/SIZE]
    [SIZE=2] svn checkout [url]https://svn.code.sf.net/p/freeghost/code/trunk[/url][/SIZE]
    [SIZE=2][B]Install It![/B][/SIZE]
    [SIZE=2]cd ~/svn/trunk/bin [/SIZE]
    [SIZE=2] sudo ./installfog.sh[/SIZE]


  • Senior Developer

    I’d recommend upgrading to trunk and see if the issues persist still.



  • HI,
    i made the update this morning on my prod server but when i download the image on another computer, i still have the same error message…
    Do i need to upload a new image because of the update ?
    What info should i provide you ?

    R.D.



  • Thanks !
    I did it on the VM and indeed it s easy to install. But i think that during the process i saw Fog 1.3 but after the installation i saw in the web interface fog 1.2. Normal ? it s just a detail anyway.
    The install is completed in my test environment but I cannot yet tell you if it s working or not cause in the test, i have only VM with 1 partition and not like in production (not enough place on my laptop…).
    I ll give you news tomorrow !


  • Testers

    I am using 12.04 without any issues also.


  • Senior Developer

    Ubuntu 12.04 should work perfectly fine, in fact I recommend using it over the newest version of Ubuntu. That “package” is the only one you need. Just follow the instructions you copied and you should be good to go. Let us know if you have any issues.


Log in to reply
 

431
Online

38996
Users

10715
Topics

101725
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.