New image downloads very slowly...


  • Moderator

    I’ve encountered a strange issue today…

    I’m making a new windows image, (windows 7 64bit) and I’ve just uploaded it so that I can begin testing it on my other machines to make sure there are no problems…

    However when I try to download it, it only goes at about 200MB/min

    It was fine upon uploading and I’ve watched it get through the entire process, The image is about 24gb of data on HDD, Windows + Office, which seems to compress down to about 4.3GB.

    I uploaded twice as I thought this was strange. I’ve not had time to let it get to the end of the download to see if it it working properly… can do that when I’m next onsite.

    I suspected a problem with the network or the fog server, so checked for high CPU/RAM usage and for lack of disk space. no problems there.

    I also tested another image I have, the normal one I’ve been deploying for a very long time and it downloads on the same machine at over 5GB/min.

    So the only thing I am left with is the image itself causing problems… but since it’s just data I don’t see how it could make that much difference.

    It does image way beyond the 6GB mark (I stopped it there wondering why it had not finished to troubleshoot) so I’m leaning away from the compression being dead…

    Uploading machine is a Toshiba Satellite Pro (i3, 4GB RAM, SATA HDD), downloading machines are two dell vostros that I’ve tried (i3, 4GB RAM, SATA HDD) fog server is an older dual core that has been stable for a long time and still throws out the other images at fast speed. Fog is still on 0.32. 1.2 upgrade is scheduled but not until a storage upgrade goes in on my shared VM storage.

    Anyone ever seen this?


  • Developer

    I just ran into this problem also. The download took 8 hours to complete downloading at roughly 184MB/m. When I took the Host drive out and popped it into a Sata reader, Hard Disk Sentenal showed 282 bad sectors. Threw the drive out and put in a new drive. Image pulled down at 2.64GB/m again.

    My issue was a bad drive but don’t let that account for possible other issues.


  • Moderator

    Same issue when downloading back onto the laptop the image was on… there must be something very strange in the image or the hardware isn’t fully running nice with fog…

    Tried running a windows install from one of my older desktops and imaging round in a circle of machines including the laptop and then back to the original and that is working…

    Probably something that will solve itself once the UEFI stuff gets going. That’s the only real difference I can see between all the PCs.

    Now at least that I have an image that will move to other machines successfully I can get going do what I was hoping to have already done.


  • Senior Developer

    If it’s a windows 7 and cross platform, this is actually kind of expected. If it’s windows 7 and going basically on the same system from which it was created, it certainly sounds like there’s some type of corruption.


  • Moderator

    Image does not work properly, BootMGR is missing on the destination machine.


  • Moderator

    At approx 74% it stopped stuttering and is going up past 370MB/min

    right upto 86% and then stuttering again…

    I am definitely thinking there is something up with the compression on this image.


  • Moderator

    At work now, more updates installed on my exemplar laptop.

    Uploaded fine, Image is now 5GB in size.

    download is running at 256MB/M but seems to be stuttering (downloading a piece and then haulting etc)

    The time elapsed and remaining is also stuttering and not moving smoothly.

    just under 2 hours it’s estimating for download to see if the image works.


  • Senior Developer

    [quote=“Buddy, post: 38247, member: 225”]Can you shoot that image to something else besides those vostros to see if it is the same speed? Also might seem as a stupid question but I have seen it on a few things that caught me off guard… Do those vostros have 1Gbps cards in them? Or are they 10/100?[/quote]

    VincentJ and I talked over the weekend. It’s only a theory, but it does seem to be something with how the image is compressed.

    As he’s running 0.32, the upload of the file (unless it was changed) is defaulted to a compression rating of -3. Under this compression rating, the image is usually only compressed down to about a third of the original size of the image. As he stated the image and data takes a total of 24GB we’d expect to see a compression size of around 13-15 GB. Sure it could be less or more, but it seems really odd that the file is all the way down to 4.3GB. It doesn’t necessarily mean the image is bad, it’s just really odd. Because of the “extremeness” of the compression, I think it’s not really a networking problem occurring, but rather the CPU’s are working hard to decompress the image to read the file. As it’s not had time to process and write the data to the disk, it looks (from partimage/partclone perspective) that it’s actually transferring the file really slow. I don’t think this is the case.

    Hopefully we’ll find out more today/tomorrow.


  • Moderator

    they are gigabit. other images download at full speed on those same machines.

    current thinking is it might be the decompression holding things up…

    going in tomorrow to try and get things working.



  • Can you shoot that image to something else besides those vostros to see if it is the same speed? Also might seem as a stupid question but I have seen it on a few things that caught me off guard… Do those vostros have 1Gbps cards in them? Or are they 10/100?


Log in to reply
 

352
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.