HP EliteDesk 800 G1 TWR fails on undionly.kpxe and undionly.kkpxe

  • Hi,

    I am trying to PXE boot HP Elitedesk 800 G1 tower systems to a Fog server running on Ubuntu 14 server with Fog 1.2.0 .

    The PC’s will PXE boot in Legacy mode but once it tries to process the boot file undionly.kpxe it fails and moves onto the next boot device in boot order from BIOS.

    I have added the device and it’s MAC address into the FOG console and have created a new image and assigned that image to the machine.

    I am trying to PXE boot the PC to take a “factory” image first and then I will proceed in customizing the PC for our needs and take an image of that custom image as well but I cannot seem to successfully PXE boot.

    Are there other files I should consider booting from the TFTPboot directory?

    I have the BIOS set to perform a legacy boot on the NIC as UEFI did not work either.

    The boot goes so quickly I cannot seem to capture the error from the PC screen before it moves onto the next device to boot in sequence and clears the screen.

    Any suggestions?


  • Developer

    I think that you can do it :)

  • Developer

    So i can add this to the working hardware page?

  • Developer

    I just to update the FOG version, and with revision 2819 works fine. Now I have other problems with the dnsmaqs and tftpserver, but works fine

  • Developer


    Just to throw this out. Which kernels have you tried?

  • Developer

    I have the same problem. The kernel don’t install the network card and if you do a ifconfig in debug mode, only appears the loopback interface

  • Just so you know, the HP EliteDesk 800 G1 (TWR and SFF) will work with FOG 0.32, which I’m using.

  • Has anyone in this forum successfully booted unionly.kpxe on Fog 1.20 on an HP Elitedesk 800 G1? Please share specifics including fog
    version and system bios version.

  • No kernel panic on this one. I tried to run the register and inventory function from another laptop which is an older HP Compaq 6710b and it did exhibit a kernel panic error. The system I am trying to get working are HP EliteDesk 800 G1 TWR with Bios version 2.30 (dated 4/22/2014).

  • It boots in seconds to the PXE image then runs a few steps and then stops and moves on to the next in boot sequence.

  • Senior Developer

    Does it kernel panic? How long are you waiting to know its not working.

  • Tried the new bzImage but still no luck with booting this on this new PC. Anybody have any other ideas? :(

  • Tom,
    I noticed you have a new kernel out there on your server that works for many types of PC’s. If I download this kernel where do I replace the file bzImage. I found that file in /var/www/fog/service/ipxe and I assume that I would replace the file that is there in that directory? Would I then need to restart the server?


  • @Tom Elliott, post: 36820, member: 7271 said:

    I don’t know if it will fix anything, but can you try the files in svn:

    >svn co https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp
    cp tftp/* /tftpboot/
    Downloaded files from svn, but PC does the same thing in that it boots and passes with an OK on the following steps:
    Configuring OK
    boot.php OK
    bg.png OK
    Then it craps out and can't go any futher.

  • Senior Developer

    I don’t know if it will fix anything, but can you try the files in svn:

    svn co https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp
    cp tftp/* /tftpboot/

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.