Computer wont boot from hard drive after PXE from FOG



  • We just upgraded to FOG 1.2. The computers boot to the FOG PXE screen then when they go to boot from hard drive the screen goes black the cursor flashes in the upper left hand corner and nothing happens. The computers are DELL and we can press F12 to go to the boot menu and then we can select the hard disk and it will boot.

    Is there a way we can tell fog where the boot disk is?

    Thanks,



  • I know I’m gravedigging an old topic, but since this is all the Google could find for me on this topic I thought I’d post a solution for future reference.

    For my setup (FOG 1.3.5), the following allowed me to get my Dell Latitude M4800 and E7470 laptops to exit iPXE and continue booting the hard disk properly without the dreaded flashing cursor:

    FOG Configuration -> iPXE Boot Menu -> Exit to Hard Drive Type = GRUB_FIRST_HDD (default is SANBOOT, which was giving me trouble)

    Hope this helps someone.

    Jon


  • Developer

    @ciry fog 1.0+ versions do not use syslinux. fog uses ipxe.
    trying to boot a gpt uefi system with the bios set to legacy would not work regardless of pxe.
    fog gives you multiple methods to exit the pxe environment to try to load the OS, have you tried them all?



  • Hello all, i’m googling/reading a lot of thread from at least a week on this problem, just today i reg to this forum, only to say I have same issue with Acer P253M notebook.
    I tried recover image (from Acer dvd disks) with win7 and win10, same issue, Bios boot type was set to “legacy” (not uefi) but the O.S. was set by Acer with GPT partition.
    I fear this is the problem, the GPT Partition.
    I’m going to try with an “MBR partition”… (microsoft call the partition schema in this clear wrong way)…

    But after all i would ask: what kind of boot pxe-fog-booting-img use?!
    It’s Syslinux?
    May be it’s there the problem, could a syslinux update (or downgrade) to solve the problem?

    I found this workaround for an old version of Fog in wiki:
    https://wiki.fogproject.org/wiki//index.php?title=Boot_looping_and_Chainloading
    and other site
    http://community.spiceworks.com/how_to/108551-fog-boot-looping-and-chainloading

    But i can’t apply this method just because i can’t find /tftpboot/pxelinux.cfg/default
    i’m going off road…?

    Thank you.


  • Moderator

    @MJR I was asking for exact models, lol. But that’s fine - you can do what I was going to do. Please look through these two lists, you’ll know what you’re looking at:

    https://wiki.fogproject.org/wiki/index.php/WorkingDevices

    https://wiki.fogproject.org/wiki/index.php/ProblematicDevices

    Now, if you find some that are noted as working but are not working for you - we need to explore those.



  • @Wayne-Workman Thanks for your response; I don’t know how specific you need me to be but we are 90% Dell.
    Generally speaking, there’s at least one Optiplex 780 (2012?), a few Optiplex 3010’s (2013), and 3 or 4 Dell Latitude E6520’s (2011). Our Network Engineer suggested maybe a certain brand/model of NIC’s…


  • Moderator

    @MJR Can you provide a list of models that are problematic?



  • @MJR Correction; the Quick Image worked (after turning back on PXE) , it apparently just hung on the final reboot in the same place it always does.



  • Microsoft AD environment with 200+ computers. Upgraded fog server to 1.2 from 0.32. No previous similar problems.
    On approximately 10% of campus computers, we are also seeing the “perma-blinking” top left cursor after
    the Fog Menu screen during PXY boot. Laptops and Desktops running Windows 7. Have to turn off PXY boot
    for work around. Today tried my first Fog “Quick Image” on a Dell Latitude with this issue and it also hangs about
    15 minutes into the reimage on the same blinking cursor screen. Hoping for some information, directions, questions.
    Thanks very much.



  • @SupEric

    I have the same problem you had at the time of loading the image I get black screen and a blinking in the corner hairline.
    Do you have the solution to this problem?
    Could you help me fix it?



  • @Tom-Elliott
    yes but,

    I have a good connection and restart the computer and turn it off and still the same . I do not know what it is :( and not found.


  • Senior Developer

    @alli
    Yep,

    Make sure your network is good to go. In some cases you may also need to power down completely, and “cold” start the system.

    First, check the network though. I actually saw this exact issue today. All other systems were perfectly fine, it was just this one system that had the issue. Replaced patch cable and restarted system. Everything succeeded.



  • The start of computers to display FOG PXE Then when they go to boot from the hard disk goes black screen the cursor flashes in the upper left corner and nothing happens.
    Someone has the solution to this problem
    :(



  • Forgot to mention. Thank you very much for your help on this:):)



  • We fixed this by runing startup repair with the windows 7 install disk. For some reason with fog .32 it was using the bootmanager from the fox pxe boot image.


  • Developer

    this is not a kernel issue. it is a ipxe issue. updating the kernel will not help



  • when you updated to 1.2 I believe it updates the default kernel, there are some newer ones you can download them from the fog configuration tab, there is an option for downloading kernels.

    downloading an additional PXE boot image, save it as a custom option bzimage###. then go to your system inventory and set the machine to use a custom boot loader, fog/kernel/bzimage###. Then make sure that you delete the pending task, so that it picks up the custom kernel when it creates the new task. Since your other systems are working fine with the current default it would be best to test a different kernel without overwriting the current one.

    you can look here [url]http://www.fogproject.org/wiki/index.php/WorkingDevices[/url] to see if your system is on the list and what kernels have been tested to work with it.



  • How do you know what kernel you are currently using?



  • Havent tried a different kernel. It is on the lates bios. What is the best way to update the kernel?



  • did you try downloading a different kernel? also check to see if there are bios updates for the XE


Log in to reply
 

542
Online

39006
Users

10720
Topics

101778
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.