Surface Pro 3 PXE:



  • I get the same result when using ipxe.efi where the tftp boot server is asking for an IP address. I tried the ip address and the full path, e.g. [url]http://192.168.0.1/ipxe.efi[/url] and it just times out When I tried snp.efi and got to the menu, but it just resets back to the menu when I try to inventory.



  • [quote=“MRCUR, post: 40217, member: 25116”]I know this is an older thread, but I just got a few Surface Pro 3’s that I’d like to image through Fog. I installed the latest SVN build of Fog onto Ubuntu 13.10 this morning. I have the DHCP server set to ipxe.efi.

    After disabling secure boot on a Surface, I was able to get it to the iPXE menu. Entered the server’s IP when prompted and after about 20 seconds received a timeout message.

    Any ideas Tom?[/quote]

    I’d like to know if there are any solutions for this as well? I don’t get any sort of connection. We may be implementing this as a standard tablet and it would be a bummer if I can’t create and deploy an image to them. I will add, I am only on version 1.2.1, because of the XP deployment bug (something to do with PartClone?) that a few of us encountered (yes , we still deploy XP to older systems).


  • Testers

    I know this is an older thread, but I just got a few Surface Pro 3’s that I’d like to image through Fog. I installed the latest SVN build of Fog onto Ubuntu 13.10 this morning. I have the DHCP server set to ipxe.efi.

    After disabling secure boot on a Surface, I was able to get it to the iPXE menu. Entered the server’s IP when prompted and after about 20 seconds received a timeout message.

    Any ideas Tom?


  • Senior Developer

    You could, if you’re brave, attempt booting the Surface Pro 3’s natively through uefi pxe boot.

    Download all the files from [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp[/url] to your /tftpboot folder.

    I don’t know what your dhcp looks like, but for now, you could set the option 67/boot filename to ipxe.efi or snp.efi and see if it boots you up.



  • Thanks for the info…might have to try was hoping for something slightly easier but maybe the Devs will figure out something soon. Thanks!



  • [quote=“Junkhacker, post: 35126, member: 21583”]does this model of computer have legacy boot support (ability to disable uefi)?[/quote]
    It doesn’t Unfortunately. You have to turn off a setting in BIOS to get it load tftp at all though.
    [LIST]
    []Get in to Bios
    [/LIST]
    [LIST=1]
    [
    ][LIST=1]
    []Turn off the surface
    [
    ]Hold the power up key
    []Press and release the power button on your Surface, then release the volume-up button.
    The UEFI menu will display within a few seconds.
    [/LIST]
    [/LIST]
    Alternative way
    [LIST=1]
    [
    ][LIST=1]
    []While the surface is on hold the shift key and then hit the power off
    [
    ]Go to troubleshooting
    []Then their is an option to boot to UEFI settings
    [/LIST]
    [/LIST]
    [LIST]
    [
    ]Turn off Secure Boot Control - otherwise due to security it wont boot at least with the Surface Pro 1
    [/LIST]
    I still had issues after doing this so I also ended up changing tftpboot service to use .efi
    [LIST=1]
    []Download from code [url]http://sourceforge.net/p/freeghost/code/HEAD/tree/trunk/packages/tftp/[/url]
    [
    ]Copy [URL=‘http://sourceforge.net/p/freeghost/code/HEAD/tree/trunk/packages/tftp/ipxe.efi’]ipxe.efi[/URL] to /tftpboot and point your DHCP towards it
    [*]run the following command: restart tftpd-hpa
    [/LIST]
    After doing this the image successfully uploaded. Keep in mind ipxe.efi will not work with hardware that doesn’t support UEFI so you would have to manually it change back and forth. Not ideal but it works

    Also want to note there are two versions of the Microsoft adapter one is 10/100 the other is a Gigabit adapter the 10/100 wont work at all to boot into fog.


  • Developer

    does this model of computer have legacy boot support (ability to disable uefi)?



  • Getting the Device to PXE boot is the easy part. Im trying to get it to load to the Fog Menu or allow me to register the device with the fog server so i can image it. I am using the expensive Microsoft Branded NIC if that makes any difference. Thanks!


  • Developer

    a bit of quick google says that it will work with the latest firmware and official adapter.
    [CODE]Plug in the Microsoft Ethernet Adaptor into the USB port
    Power off the Surface - a reboot is not sufficient
    Press and HOLD the Volume DOWN button (on the left side of the tablet)
    Press and HOLD the Power button for FIVE seconds (on the top of the tablet)
    Release the Power button after five seconds but KEEP HOLDING THE VOLUME button until your see PXE start[/CODE]


Log in to reply
 

413
Online

6.3k
Users

13.8k
Topics

129.9k
Posts