IPXE : Could not start download: Operation not supported


  • Hi,

    I am using Fog Version: 1.2.0 Ubuntu: 12.04 LTS (Fresh Install )

    I am getting the the below error during pxe boot.

    [ iPXE initialising devices…ok
    Configuring (net0 x❌x❌x)… ok
    [B]Could not start download: Operation not supported ([url]http://ipxe.org/3c092003[/url])[/B]
    [B]Selected boot device failed. Press any key to reboot the system. ][/B]

    But sometimes I can Register the host, Upload and download the image without any issue.

    Please help. Image attached for reference.

    Thanks&Regards,
    Siva

    [url="/_imported_xf_attachments/1/1198_Ipxe.png?:"]Ipxe.png[/url]


  • this is a little embarrassing. I dont know if i am losing my mind or if a co-worker is fucking with me but the dhcp settings were removed. We are using windows dhcp, added options 66 and 67 back in and its working again.

    Thanks a lot guys. This community is great!

  • Moderator

    Which DHCP Server do you use? The one configured by FOG or a different one. Here is an interesting post on missing ‘next-server’ DHCP option: [url]http://comments.gmane.org/gmane.network.ipxe.devel/3529[/url]

    And here is another one on wrong scope: [url]https://communities.vmware.com/message/2139349[/url]

    Please provide some more information about your setup and which DHCP server is used (plus configuration…).


  • any ideas what i can try next?


  • no. i set this vm up a couple weeks ago. clean install of win7.


  • my best guess, did you upgrade the Hardware version/OS of the VM?


  • i edited the tftp config file. it listed root as the user and 0.0.0.0:69 as the ip address. I changed these to ‘fog’ and 127.0.0.1: respectively.

    any ideas where i could find a log of why the connection is failing for this vm? it has worked on this vm in the past.


  • the VM is running in VMWare esxi 5.5. i setup a win7 vm to sysprep to create an image from.


  • What VM?


  • so im getting the “operation not supported” message when i try to pxe boot a VM but a physical machine is able to.

    I think i read a post about there being some updated pxe files?


  • I don’t know if it will, but it seems, to me, to be related to the tftp command possibly.


  • i ran the re-install of fog and pxe booting is working again. strangely enough the tftp test on the server still fails as does the client side test.

    I will ignore it for now unless you think it will cause me headaches down the road.


  • i found a random blog post that said to run “[SIZE=13px][FONT=Georgia][COLOR=#333333]./installfog.sh --no-upgrade” after changing the server IP. This looks like it was for pre 1.x versions so I dont know if it would be ok to run or not.[/COLOR][/FONT][/SIZE]


  • tftpd-hpa is running. service --status-all shows it and i restarted it and it started without error.

    the tftp test is still failing on the server but i am getting a different error on the client side.

    when it tries to boot it references the old IP. I have gone through all the settings in the webui and .fogsettings. where else can it be pulling the old IP from?


  • Based on the fact that a normal “test” to see if tftp is actually operating seems to fail, is the tftpd-hpa service actually running?

    [code]sudo service tftpd-hpa restart[/code]



  • The image isn’t showing or displayed.


  • i posted a screen shot earlier today. let me know if you dont see it.


  • Can you give me an exact “permission denied” message?


  • I am still getting the “permission denied” error when i do the test from the fog server. when i try to pxe boot the message flashes up so quickly i have not been able to pause quick enough to see if it is still the same.

    i did notice some settings that i did not expect when i looked at .fogsettings. a little more back story, about two weeks ago i changed the fog server ip and went through another forum post that referenced some locations to update the IP. It had been working until today and i did see the correct IP in many locations in the webui but in .fogsettings it had the old IP still. I updated it.

    in .fogsettings i updated, password="<the new reset unix local ‘fog’ account password>"

    I tried restarting tftp-hpa but it didnt help.

    Thanks for the help. I am confident we will get this resolved, im sure i just missed somehting somewhere.

275
Online

9.6k
Users

16.0k
Topics

147.9k
Posts