Image Management doesn't show Image Size: ON SERVER



  • Hi,

    i don’t think this is right?

    [IMG]http://i.imgur.com/3CnndON.png[/IMG]

    Disk Information got it.
    [IMG]http://i.imgur.com/VSQa1J3.png[/IMG]
    I am on FOG SVN 2086 under Ubuntu 13.10

    Regards X23



  • Finally worked, but I had to cp the image from /images/dev/MAC_ADDRESS…

    I’m kind a noob in linux, so with you can send a step-by-step to fix this problem I will appreciated…

    Thanks and sorry for any trouble from my part.



  • Now I tried to upload a image to /images/sict…the name of image is sict
    So, I change every user in fog to ‘fog’ and put the same password…I did this in web app and /var/www/fog/lib/Config.class.php (Iguess)
    Right now I create a sict diretory and moving the images from /images/dev/MAC_ADDRESS to /images/sict

    Hope work…

    FOG version: 1.2.0



  • [quote=“Alexander Fiabane, post: 35058, member: 25509”]Hello Tom Elliot,

    Sorry about my ignorance. Can you paste the link please?

    I saw in /images/dev/mac_address, that uploaded image is there, but i don’t know why doesn’t convert to /images/image_name… Any glue?

    PS.: I did put in all users (mysql, server root|fog, fog web, storage, tftp) the same password.
    except the [COLOR=#555555][FONT=Ubuntu]FOG_STORAGENODE_MYSQLUSER, [/FONT][COLOR=#000000]and keep the same user ‘fogstorage’[/COLOR][/COLOR][/quote]

    Here the syslog when update task was finished:

    [QUOTE]Aug 8 16:39:01 fogserver CRON[1365]: (root) CMD ( [ -x /usr/lib/php5/maxlifetime ] && [ -x /usr/lib/php5/sessionclean ] && [ -d /var/lib/php5 ] && /usr/lib/php5/sessionclean /var/lib/php5 $(/usr/lib/php5/maxlifetime))
    Aug 8 16:41:54 fogserver kernel: [25380.107153] type=1326 audit(1407526914.657:41): auid=4294967295 uid=65534 gid=65534 ses=4294967295 pid=1479 comm=“vsftpd” sig=31 syscall=96 compat=0 ip=0x7fff09b2cdff code=0x0
    Aug 8 16:42:24 fogserver in.tftpd[1499]: tftp: client does not accept options[/QUOTE]



  • [quote=“Tom Elliott, post: 35050, member: 7271”]The issues reported here have already been fixed in SVN.

    You don’t need to update unless you want it working for you.[/quote]

    Hello Tom Elliot,

    Sorry about my ignorance. Can you paste the link please?

    I saw in /images/dev/mac_address, that uploaded image is there, but i don’t know why doesn’t convert to /images/image_name… Any glue?

    PS.: I did put in all users (mysql, server root|fog, fog web, storage, tftp) the same password.
    except the [COLOR=#555555][FONT=Ubuntu]FOG_STORAGENODE_MYSQLUSER, [/FONT][COLOR=#000000]and keep the same user ‘fogstorage’[/COLOR][/COLOR]


  • Senior Developer

    The issues reported here have already been fixed in SVN.

    You don’t need to update unless you want it working for you.



  • Same corner?

    Wrong image size, wrong date
    The storage is local on the fog server.

    Image Management On Client On Server
    Multiple Partition Image - All Disks (Not Resizable) 346.68 GiB 2.02 GiB Today, 4:29pm

    ll -h

    total 4.8G
    drwxrwxrwx 2 root root 4.0K Aug 7 18:29 ./
    drwxrwxrwx 8 root root 4.0K Aug 7 18:29 …/
    -rwxrwxrwx 1 root root 512 Aug 7 18:16 d1.mbr*
    -rwxrwxrwx 1 root root 8.0M Aug 7 18:16 d1p1.img*
    -rwxrwxrwx 1 root root 4.8G Aug 7 18:29 d1p2.img*
    -rwxrwxrwx 1 root root 18M Aug 7 18:29 d1p3.img*

    An other image:
    Multiple Partition Image - All Disks (Not Resizable) 0.00 iB 4.01 GiB 01-01-1970 12:00am

    ll -h

    total 9.2G
    drwxrwxrwx 2 root root 4.0K Oct 18 2013 ./
    drwxrwxrwx 8 root root 4.0K Aug 7 18:29 …/
    -rwxrwxrwx 1 root root 4 Oct 18 2013 bla.txt*
    -rwxrwxrwx 1 root root 512 Oct 18 2013 d1.mbr*
    -rwxrwxrwx 1 root root 8.0M Oct 18 2013 d1p1.img*
    -rwxrwxrwx 1 root root 3.6G Oct 18 2013 d1p2.img*
    -rwxrwxrwx 1 root root 577K Oct 18 2013 d1p3.img*
    -rwxrwxrwx 1 root root 5.6G Oct 18 2013 sys.img.000*



  • This post is deleted!


  • Another image from the images/[ATTACH=full]1272[/ATTACH]

    [url="/_imported_xf_attachments/1/1272_imagesDir.png?:"]imagesDir.png[/url]



  • I put the same password in each fog user, but i don’t know why the image don’t go to the server =/
    Sorry to open this post again, but I’m kind noob on network…so id you have any solution, please, tell step by step what I should do.

    Thanks



  • Hello,

    First congratulation to FOG team for FOG project.

    I did read this post and follow the steps, but I’m stiil have the same problem: no sized image ON SERVER =/

    Here some images:
    [ATTACH=full]1267[/ATTACH][ATTACH=full]1275[/ATTACH][ATTACH=full]1270[/ATTACH][ATTACH=full]1271[/ATTACH][ATTACH=full]1274[/ATTACH]

    [url="/_imported_xf_attachments/1/1270_userweb.png?:"]userweb.png[/url][url="/_imported_xf_attachments/1/1267_image.png?:"]image.png[/url][url="/_imported_xf_attachments/1/1271_userlinux.png?:"]userlinux.png[/url][url="/_imported_xf_attachments/1/1274_storage.png?:"]storage.png[/url][url="/_imported_xf_attachments/1/1275_tftp.png?:"]tftp.png[/url]



  • FIXED:

    [IMG]http://i.imgur.com/SGwa0gl.png[/IMG]
    i made an additional image

    [IMG]http://i.imgur.com/4e6b0Oa.png[/IMG]
    ;)

    Regards X23



  • Hi,

    thanks, that are also my thougth’s my only fault i couldn’t remember how fog was doing this.
    Ok but how to correct this? Sorry but iam a little confused as normal this will be autogenerated but have i check the ftp conf manually to get the current password to put it into the storage node ftp configuration or will the password the one i enter there?

    Edit:

    I am on my way…

    [quote=“Philip S Hall, post: 3354, member: 1090”]I encountered this problem and discovered that it was the FTP credentials being used for the storage server.

    Go to the Storage Management section. list all storage nodes and select the one the one that is being used (in my case it was the ‘default member’).

    Check the username and password there and make sure there is a corresponding user account on the fog server with the right access priviliges on the images folder shown in fog managment.

    In my case it was set to username ‘fog’ with a very long password. I don’t know how this ended up as ‘fog’ instead of ‘fogstorage’ but it appeared to have been configured with some randomly generated password.

    BTW I knew it was an access problem because the fog server’s ‘auth.log’ file showed the authentication error.[/quote]

    [quote=“Sebastian M., post: 9597, member: 229”]Same error here. Changed the password from the user fog (linux user fog) to the password from the linux user fog and now the problem is solved.[/quote]

    [quote=“Kevin, post: 10566, member: 3”]It’s ok to have the Fog user in the defaultmember. The password that you would need would be the same as your tftp password which can be found under Other Settings > FOG Settings > TFTP > FOG_TFTP_FTP_PASSWORD. If you haven’t changed the password for the default FOG user, it will be a long randomly string of letters and numbers.[/quote]

    I set a password under fog settings tftp server and also under the defaultmember node, now i need to reupload an image that will take some time…

    Stupid me on my way from fog in virtualbox to vmware player to esx5 over vmware converter… lol… i changed the fog webif users password different to the fog linux users password i initially set.

    Regards


  • Developer

    the image uploads in /images/dev/<mac address> by nfs
    when image uploading is done, the <mac address> directory is moved and renamed to /images/<image name> by ftp
    the images page of the webgui pulls the size of each image by ftp

    your ftp does not appear to have a valid login in storage management. it therefore cannot get the correct size of images, or properly finish the upload process.



  • Hi,

    no problem with navigating through the dir’s
    [IMG]http://i.imgur.com/vTkeo4H.png[/IMG]

    I renamed the machine before i made the image from it’s mac name to it3809 shouldn’t the images be stored in a dir under dev named by it’s name or is these wrong memories?

    For my understanding the server just have to check the filesize in filesystem, it looks like thats possible by shell but where is the bug? hmmm Maybe FTP Problem?

    Afaik after the image process something is done by ftp and i mean i could remember that there should be ftp login details on the defaultmaster? Look here its empty after fresh install

    [IMG]http://i.imgur.com/st8yyz1.png[/IMG]

    hmm there must be something wrong with ftp
    something else, wasn’t the node name always filled with its given name?
    Also master node isn’t checked, very strange it was a install from scratch!

    [IMG]http://i.imgur.com/TYGoPCv.png[/IMG]

    FTP Service itself is running but i cannot login to check if that works, whats the password, should i define new where to set it? iam sure size on server in webif is zero because the scripts try to check /images/it3809 but the image is still in dir under its mac number as you can see on screenshot.

    Edit:

    For fun i created dir it3809 in dev gave it 777 and placed a 10mb file in there but nothing new in webif, maybe this is counted after image creation, ftp move processes and file size infos are stored to db?

    [IMG]http://i.imgur.com/mOe2yvi.png[/IMG]

    webif remains zero

    [IMG]http://i.imgur.com/XbAEVQW.png[/IMG]

    I dont know 100% exactly when if fog doing what so don’t laugh about my trys :D

    Regards


  • Senior Developer

    I’ve heard and seen the issue and am trying to pinpoint where it is. That said this isn’t impeding the natural operation of fog is it?


  • Developer

    if you go to /images/it389 can you do a ls -a:

    Are there any files located in this directory? Do these files have any significant size?


Log in to reply
 

413
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.