Image Download Problem



  • I can upload images fine using partclone and partimage, but when it comes to downloading them, I can’t. Once I initiate the download and ipxe boot, the computer does the typical fog process and downloads the MBR, I think (it’s the part before partclone starts) but then I see the text flash by that says 'Imaging Complete" and it never gets to the partclone screen.

    Permissions for my /images folder and all its contents are: fog:root 777



  • Okay, I’ll give that a try as a final attempt of using fog. I have a server ready to go with Server 2008r2 on it to get WDS setup since I’ve had nothing but problems with FOG/Linux since the day I started using it. All of everyone’s help is deeply appreciated.


  • Testers

    You should try the debug.download task under advanced, after it tells you it’s completed and going to reboot, you can hit Ctrl-C to get to a shell. It might let you see exactly where the problem is, in the past I’ve found it useful to try running that script and when I get to the point of failure. I would look at the partition table first
    [CODE]
    $ sfdisk -l
    [/CODE]
    Make sure the partition table matches the image you are trying to deploy. Assuming it is OK, you can try partimage manually.



  • I enabled that feature before I added the images, and when I added them I set them to partimage except for 1 of them which was uploaded using 1.1.2 before I reinstalled Ubuntu.


  • Testers

    Fog, 1.1.2 defaults to partclone so that might be the problem. I think you can manually say that they are partimage images by enabling the image type flag in “Fog Configuration -> Fog Settings -> General Settings”, look for [FONT=Ubuntu][COLOR=#555555]FOG_FORMAT_FLAG_IN_GUI[/COLOR][/FONT] and mark it with a checkbox then save your settings. Now you can go back to one of your images and you will see an “Image Manager” dropdown, switch the type to partimage and retry the download.



  • Junkhacker: Permissions to everything under /images are: owner fog and group root

    ianabc: I made sure to match the file names exactly, I copy and pasted most of them from the filesystem to the web interface. All of my images except for one are partclone. I only uploaded one after upgrading from .32 to 1.1.2 the first time. All of these images were created over the years and used partimage.


  • Testers

    Also
    [LIST=1]
    []Be VERY careful with the filenames to make sure that the image definitions match the filesystem paths
    [
    ]Make sure the image type is correct (partimage or partclone).
    [/LIST]


  • Developer

    you may need to verify that the ownership and permissions are correct on those files then.



  • To kind of give you more info on what I’ve got, I just did a clean install that you guys helped my with the other day and I had my images backed up to my NFS server and transferred them back over today. I went into FOG and created new images and put the image file locations in so that FOG knew where to look for the images. Did I do something wrong? I don’t really have the machines available to re-upload from, they’re all in production and aren’t clean images anymore.


  • Senior Developer

    Anybody want to take reign on this one?

    Hint, GPT,

    Looks like you need to reupload your images. First, schedule the systems in upload-debug from the advanced tasks.

    Before you type fog on the client
    run:
    [code]fixparts /dev/sda
    y
    w
    y[/code]

    Then type fog.


Log in to reply
 

375
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.