After PXE FOG menu screen appears and then restarts



  • Hi everyone,

    I have this weird issue:
    The first time a pc enter net boot and load iPXE, the FOG menu screen appear and then immediately the pc restart.
    I can’t select anything in the menu- it restarts before I can choose…
    The second time the pc enter net boot, the FOG menu screen appears and then I can choose, I can register the computer (Perform a Full Registration…).

    Has anyone experienced this odd problem?
    This is driving me nuts,

    Thank you,
    Meitar



  • Hi,

    When I changed the file to indionly.kkpxe it won’t start- doesn’t even get to the FOG menu…
    I solved this problem by changing the [FONT=Ubuntu][COLOR=#555555]FOG_PXE_MENU_TIMEOUT value in the fog configuration menu-> FOG boot settings…[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]Thanks for all the help[/COLOR][/FONT]



  • [quote=“Meitar Ronen, post: 29681, member: 24536”]Hi,
    Yes I think I know how to change the files in the /tftp folder but where can I get the undionly.kkpxe from?

    thanks[/quote]
    You can download the latest versions from [url]https://svn.code.sf.net/p/freeghost/code/trunk/packages/tftp/[/url] and put them in your /tftboot/ directory.
    Remember to backup your actual files, just in case…



  • [quote=“Wolfbane8653, post: 29683, member: 3362”]uh look in the /tftpboot folder…

    Just change your Option 67 to undionly.kkpxe (or ipxe.kpxe, ipxe.kkpxe, etc.)[/quote]

    I will try this and post the results…
    thanks


  • Developer

    uh look in the /tftpboot folder…

    Just change your Option 67 to undionly.kkpxe (or ipxe.kpxe, ipxe.kkpxe, etc.)



  • [quote=“Baite, post: 29679, member: 24308”]THe best thing is to narrow possibilities. You should try, if possible, in a similar PC with idential (equal) hardware and see if that also happens.
    If it happens in severall machines, then it might be something related wit the kpxe file not fully supporting your system.
    For example, in my case, had to use undionly.kkpxe in place of undionly.kpxe. Do you know how to change this files in /tftpboot/ ?[/quote]

    Hi,
    Yes I think I know how to change the files in the /tftp folder but where can I get the undionly.kkpxe from?

    thanks



  • [quote=“Meitar Ronen, post: 29667, member: 24536”][IMG]http://fogproject.org/forum/c:\users\meitar\desktop\caputre.png[/IMG]
    FOG_PXE_MENU_TIMEOUT= 3
    FOG_PXE_MENU_HIDDEN= not checked
    FOG_NO_MENU= not checked

    I’ve added a print screen…

    Thanks[/quote]

    This is a brand new computer…
    How can I run the memtest?



  • [quote=“Meitar Ronen, post: 29667, member: 24536”][IMG]http://fogproject.org/forum/c:\users\meitar\desktop\caputre.png[/IMG]
    FOG_PXE_MENU_TIMEOUT= 3
    FOG_PXE_MENU_HIDDEN= not checked
    FOG_NO_MENU= not checked

    I’ve added a print screen…

    Thanks[/quote]

    THe best thing is to narrow possibilities. You should try, if possible, in a similar PC with idential (equal) hardware and see if that also happens.
    If it happens in severall machines, then it might be something related wit the kpxe file not fully supporting your system.
    For example, in my case, had to use undionly.kkpxe in place of undionly.kpxe. Do you know how to change this files in /tftpboot/ ?


  • Developer

    I had this twice when using v0.32…One time was a bad piece of RAM and the other a bad motherboard/onboard vid card. Double check your hardware and if you can get into the for menu run the memtest option on the fog menu.

    Using parts from broken machines you really don’t know what your getting until everything boots.



  • [quote=“Baite, post: 29614, member: 24308”]What setting do you have in Fog Configuration > Fog Settings > Fog Boot Settings > FOG_PXE_MENU_TIMEOUT + FOG_PXE_MENU_HIDDEN + FOG_NO_MENU[/quote]

    [IMG]http://fogproject.org/forum/c:\users\meitar\desktop\caputre.png[/IMG]
    FOG_PXE_MENU_TIMEOUT= 3
    FOG_PXE_MENU_HIDDEN= not checked
    FOG_NO_MENU= not checked

    I’ve added a print screen…

    Thanks

    [url="/_imported_xf_attachments/0/948_Capture.PNG?:"]Capture.PNG[/url]



  • What setting do you have in Fog Configuration > Fog Settings > Fog Boot Settings > FOG_PXE_MENU_TIMEOUT + FOG_PXE_MENU_HIDDEN + FOG_NO_MENU


Log in to reply
 

407
Online

38955
Users

10706
Topics

101576
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.