TFTP Not Found



  • I recently update my server to Ubuntu 12.04LTS and my fog server to 1.1.0. Updated fog and made sure 66 and 67 were pointing where they need to be. 66 to my server 67 to undionly.kpxe. I have tested tftp and transfers were successful. but when I try to boot to fog i get TFTP not found. Any suggestions. I am a newb with linux

    [url="/_imported_xf_attachments/0/921_IMAG0514.jpg?:"]IMAG0514.jpg[/url]



  • Hi, I have the same problem.
    Ubuntu 12.04 with 0.32 is working fine, as soon as I put the upgrade 1.1.0 I have this error :

    [ATTACH]981[/ATTACH]

    I have double check the 066 and 067, 067 is undionly.kpxe.

    Here is my ipxe boot.php :
    #!ipxe
    cpuid --ext 29 && set arch x86_64 || set arch i386
    colour --rgb 0xff6600 2
    cpair --foreground 7 --background 2 2
    console --picture [url]http://10.6.2.102/fog/service/ipxe/bg.png[/url] --left 100 --right 80
    :MENU
    menu
    colour --rgb 0xff0000 0
    cpair --foreground 0 3
    item --gap Host is NOT registered!
    item --gap – -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 60000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.6.0.12 keymap= web=10.6.2.102/fog/ consoleblank=0 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.6.0.12 keymap= web=10.6.2.102/fog/ consoleblank=0 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.sysinfo
    kernel bzImage32 root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns=10.6.0.12 keymap= web=10.6.2.102/fog/ consoleblank=0 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    autoboot

    [url="/_imported_xf_attachments/0/981_IMG_20140612_083144.jpg?:"]IMG_20140612_083144.jpg[/url]


  • Senior Developer

    [quote=“Gilberto Ferraz, post: 29559, member: 2615”]Hello

    I’Have te same problem, I use fog 0.32 and work. Update for 1.1.0 and dosn work this is my config.php

    define(‘TFTP_HOST’, “172.16.17.250”);
    define(‘TFTP_FTP_USERNAME’, “fog”);
    define(‘TFTP_FTP_PASSWORD’, “962fed”);
    define(‘TFTP_PXE_KERNEL_DIR’, ‘/var/www/html/fog/service/ipxe/’);
    define(‘PXE_KERNEL’, ‘bzImage’);
    define(‘PXE_KERNEL_RAMDISK’,127000);
    define(‘USE_SLOPPY_NAME_LOOKUPS’,true);
    define(‘MEMTEST_KERNEL’, ‘memtest.bin’);
    define(‘PXE_IMAGE’, ‘init.xz’);
    define(‘PXE_IMAGE_DNSADDRESS’, “172.16.17.252”);
    define(‘STORAGE_HOST’, “172.16.17.250”);
    define(‘STORAGE_FTP_USERNAME’, “fog”);
    define(‘STORAGE_FTP_PASSWORD’, “962fed”);
    define(‘STORAGE_DATADIR’, ‘/images/’);
    define(‘STORAGE_DATADIR_UPLOAD’, ‘/images/dev/’);
    define(‘STORAGE_BANDWIDTHPATH’, ‘/fog/status/bandwidth.php’);
    define(‘UPLOADRESIZEPCT’,5);
    define(‘WEB_HOST’, “172.16.17.250”);
    define(‘WOL_HOST’, “172.16.17.250”);
    define(‘WOL_PATH’, ‘/fog/wol/wol.php’);
    define(‘WOL_INTERFACE’, “eth0”);
    define(‘SNAPINDIR’, “/opt/fog/snapins/”);
    define(‘QUEUESIZE’, ‘10’);
    define(‘CHECKIN_TIMEOUT’,600);
    define(‘USER_MINPASSLENGTH’,4);
    define(‘USER_VALIDPASSCHARS’, ‘1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_()^!#-’);
    define(‘NFS_ETH_MONITOR’, “eth0”);
    define(‘UDPCAST_INTERFACE’, “eth0”);
    define(‘UDPCAST_STARTINGPORT’, 63100 ); // Must be an even number! recommended betw$
    define(‘FOG_MULTICAST_MAX_SESSIONS’,64);
    define(‘FOG_JPGRAPH_VERSION’, ‘2.3’);
    define(‘FOG_REPORT_DIR’, ‘./reports/’);
    define(‘FOG_UPLOADIGNOREPAGEHIBER’,true);
    define(‘FOG_DONATE_MINING’, “0”);
    I think that is the way the problem seems to directory IPXE[/quote]

    FOG 1.1.0’s config.php file doesn’t look like this anymore. Are you using the right config.php file?

    None of those values really mean anything except on a Fresh Installation of FOG anyway. So just because you see data here doesn’t mean it actually is doing anything. Changing information within this file (besides the database information) will not actually have an impact on the rest of your system.

    Are you sure Option 66 is set to 172.16.17.250 AND Option 67 is set to undionly.kpxe?

    Is there, possibly, another TFTP server handing out file information that FOG cannot get to at the moment? I ask because the image shows that pxelinux.0 is still the file it’s trying to send. How do I know this? Because you stated if you put FOG 0.32 in place, everything works. Is your FOG Server also your dhcp server?



  • /var is a reserved work NOT ?



  • Hello

    I’Have te same problem, I use fog 0.32 and work. Update for 1.1.0 and dosn work this is my config.php

                 define('TFTP_HOST', "172.16.17.250");
                define('TFTP_FTP_USERNAME', "fog");
                define('TFTP_FTP_PASSWORD', "962fed");
                define('TFTP_PXE_KERNEL_DIR', '/var/www/html/fog/service/ipxe/');
                define('PXE_KERNEL', 'bzImage');
                define('PXE_KERNEL_RAMDISK',127000);
                define('USE_SLOPPY_NAME_LOOKUPS',true);
                define('MEMTEST_KERNEL', 'memtest.bin');
                define('PXE_IMAGE', 'init.xz');
                define('PXE_IMAGE_DNSADDRESS', "172.16.17.252");
                define('STORAGE_HOST', "172.16.17.250");
                define('STORAGE_FTP_USERNAME', "fog");
                define('STORAGE_FTP_PASSWORD', "962fed");
                define('STORAGE_DATADIR', '/images/');
                define('STORAGE_DATADIR_UPLOAD', '/images/dev/');
                define('STORAGE_BANDWIDTHPATH', '/fog/status/bandwidth.php');
                define('UPLOADRESIZEPCT',5);
                define('WEB_HOST', "172.16.17.250");
                define('WOL_HOST', "172.16.17.250");
                define('WOL_PATH', '/fog/wol/wol.php');
                define('WOL_INTERFACE', "eth0");                                        
                define('SNAPINDIR', "/opt/fog/snapins/");
                define('QUEUESIZE', '10');
                define('CHECKIN_TIMEOUT',600);
                define('USER_MINPASSLENGTH',4);
                define('USER_VALIDPASSCHARS', '1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklmnopqrstuvwxyz_()^!#-');
                define('NFS_ETH_MONITOR', "eth0");
                define('UDPCAST_INTERFACE', "eth0");
                define('UDPCAST_STARTINGPORT', 63100 );                                         // Must be an even number! recommended betw$
                define('FOG_MULTICAST_MAX_SESSIONS',64);
                define('FOG_JPGRAPH_VERSION', '2.3');
                define('FOG_REPORT_DIR', './reports/');
                define('FOG_UPLOADIGNOREPAGEHIBER',true);
                define('FOG_DONATE_MINING', "0");
    

    I think that is the way the problem seems to directory IPXE


  • Developer

    Can you verify that undionly.kpxe is located in /tftpboot?
    What do you get when you go to: [url]http://<ipofserver>/fog/service/ipxe/boot.php?[/url]
    What is your Fog Settings --> [FONT=Ubuntu][COLOR=#555555]FOG_TFTP_PXE_KERNEL[/COLOR][/FONT] read?

    Machine gets ip from dhcp–> machine can’t access undionly.kpxe --> Machine exits ipxe


Log in to reply
 

350
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.