Wiki: Troubleshooting Multicast


  • Developer

    [url]http://fogproject.org/wiki/index.php?title=Troubleshooting_a_multicast[/url]


    [SIZE=6]Troubleshooting Multicast[/SIZE]

    On your server open up terminal and kill any running udpcasts by typing
    [code]sudo killall udp-sender[/code]

    now run this command
    [code]udp-sender --file /opt/fog/log/multicast.log --ttl 1[/code]

    you should see [I]broadcasting control to:[/I] and it should be the highest address of the subnet your fogserver is on
    the line before that should say your fogserver ipaddress and the interface

    Now boot up 1 client go to your pxe menu and select debug mode. Do this on the same subnet if possible. Type in:
    [code]udp-receiver --mcast-rdv-address yourfogserver[/code]
    On your server you should see that 1 client connected and then you can press any key to start the transfer
    On your client you should see the contents of your multicast log file scrolling by the screen. You can press ctrl-C to stop it.

    Hopefully that worked. Now we need to test 2 clients.

    Run the command on your server again but this time change the [I]–ttl 1[/I] to [I]–ttl 32[/I]

    You will see that this time your broadcast control is 224.0.0.1 this is the multicast address

    Boot both clients in debug mode and run the client command on each. Once you see that both clients have connected to the server press any key and see if the log file transfers again to both machines this time.

    If it does not then chances are something is not setup properly in your router possibly routing tables or multicast settings.If it does work then good lets try one more step

    On your server run this:
    [code]gunzip -c “/images/anyimagename” | /usr/local/sbin/udp-sender --min-receivers 2 --portbase 9000 --interface yourInterface --half-duplex --ttl 32[/code]

    Now boot up 2 clients in debug mode and enter
    [code]udp-receiver --portbase 9000 --mcast-rdv-address fogserverIP | partimage -f3 -b restore /dev/sda stdin[/code]

    You might need to change /dev/sda to your correct harddrive if it’s different use fdisk -l to find out

    If the clients start imaging then it seems that all of your multicast settings are correct and the problem may lie within fog configuration if it doesn’t work then you need to check your router settings



  • yes, the server is dhcp. i tried another switch , same resaults , i will test some more options, and update in the coming days.
    thanks


  • Developer

    [SIZE=3][FONT=Arial][COLOR=#333333]seems like a ‘dumb’ switch (“No configuring is required.”) so you are using fog as your dhcp also? you may want to try another switch, crossover cable test, or try using dnsmasq.[/COLOR][/FONT][/SIZE]

    [SIZE=2][FONT=Arial][COLOR=#333333][url]http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE[/url][/COLOR][/FONT][/SIZE]



  • simple 10/100 switch [url]http://www.tp-link.com/en/products/details/?model=TL-SF1016DS[/url]
    just one , the server and the clients


  • Developer

    Do your [U]ALL[/U] network switches currently have portfast enabled? or is STP disabled?



  • i havemanualy managed to send the log file to two clients , that went well, but gunzip recieve command just loaded the partiton image 0.6.9 inteface instead of recieving the file


  • Developer

    Have you tried the refereed to wiki documentation yet?
    [url]http://fogproject.org/wiki/index.php/Multicasting[/url]

    Try the 1 client and then the 2 clients and please let us know of your results. [U]Usually[/U] we find that it is an environment setup issue and no an issue with Fog.



  • [QUOTE]Got the same issue I had before. It gets to the partclone screen and just sits saying

    "Starting to restore image (-) to device (/dev/sda1) [/QUOTE]

    i am having this issue with multicast . upload/download images works ok ,but not multicast.
    i do see one error that might be related and might not : "populating /dev using udev: udevd[2166]: error creating epoll fd: function not implemented"
    any thoughts are welcome.
    thanks
    using svn 2966


  • Moderator

    This issue has been resolved. Tom got me going, big thanks!

    I’ll be getting my installation documentation up on the wiki soon.


  • Senior Developer

    Can you PM me your Gmail Address?

    I can try working out issues directly as these kinds of troubleshooting is much more useful in near realtime communications.


  • Moderator

    [quote=“Tom Elliott, post: 40882, member: 7271”][url]http://fogproject.org/wiki/index.php/Upgrade_to_trunk[/url][/quote]

    I was able to get the version in Fog_Trunk going.

    I saw the new multicast settings, that’s great.

    Did have a few problems with NFS service, but I got them sorted out. The installer changed my configuration in /etc/exports and added a line to a directory that didn’t exist. I got rid of that, and set the settings back the way I had them for ProxyDHCP, then restarted NFS and all was well.

    After that, I double checked the other files that I made custom changes to and they were all fine. I input my multicast settings & port number. Then gave the FOG server a reboot for good measure.

    I created a multicast task to one client (a group with just one machine in it), and tried… and it doesn’t work… :-(

    Got the same issue I had before. It gets to the partclone screen and just sits saying

    "Starting to restore image (-) to device (/dev/sda1)

    inside /opt/fog/log/multicast.log there aren’t any new errors… just old ones from the 13th saying “StorageNode Not found on this system.” I think that error was from when I was still figuring out how to get NFS, and FTP to work right for the imaging process…

    Keeping in mind that unicast works for uploading & downloading… My images move from the /images/dev folder to the /images folder properly via FTP (that was a hard one to fix).

    Where should I look next? OR, Tom Elliott, would you like to mess with the multicast feature more? I understand you made these changes YESTERDAY, and man are you quick! So there might be a glitch somewhere you overlooked… I’ll be patient, because you guys are awesome.


  • Senior Developer


  • Moderator

    [quote=“Tom Elliott, post: 40849, member: 7271”]I understand what needs to be changed. I’ve already added it, but I’ll admit I haven’t tested it.

    If you’d be willing and report back if it’s helping.

    I’ve added two parts.

    First is the Multicast Address to use. If it’s set, it should specify what to use, though I’m not 100% sure if th init needs to be directed as well, which I’m guessing it may be.

    Second is the Multicast Port Override. Normally FOG creates tasks and it randomly generates a new port to allow multiple sessions as needed. However the override will not use random ports and will always use the override if set.[/quote]

    I’d like to try it out. Where can I find the installer?
    I’ll report back on how it goes.


  • Senior Developer

    I understand what needs to be changed. I’ve already added it, but I’ll admit I haven’t tested it.

    If you’d be willing and report back if it’s helping.

    I’ve added two parts.

    First is the Multicast Address to use. If it’s set, it should specify what to use, though I’m not 100% sure if th init needs to be directed as well, which I’m guessing it may be.

    Second is the Multicast Port Override. Normally FOG creates tasks and it randomly generates a new port to allow multiple sessions as needed. However the override will not use random ports and will always use the override if set.


  • Moderator

    Also,

    Just to suggest how the functionality should work, it should be in the fog configuration, via the management console. It should be added to “Multicast settings”

    There should be a field in there for setting the Multicast address, however the default auto-calculated one that works for probably 99% of people should be there as default.


  • Moderator

    [quote=“Wolfbane8653, post: 40840, member: 3362”]“Latest Version” is really r2901. Or are you saying the latest [U]Release[/U][U]?[/U]

    Tom is currently working on the multicast issue in the “Beta” of fog. There are multicast issues in 1.2.0 and some have been corrected in the beta.

    I have to say that this ability to “Change the Multicasting Address” is not a current feature. BUT you have sparked our interest.[/quote]

    I’m happy to have sparked your interest to offer a feature that allows us to change the auto-calculated multicast address, because my network administrator is NOT going to update our (over 600) switches to a standard multicast configuration… He’s said so… lol, and I don’t blame him.

    So, without the ability to change the auto-calculated broadcast address to 224.0.2.224 with stream port set to 7800, I won’t be multicasting with FOG, ever.

    Pretty please with sugar on top!

    Thanks,
    Wayne


  • Developer

    “Latest Version” is really r2901. Or are you saying the latest [U]Release[/U][U]?[/U]

    Tom is currently working on the multicast issue in the “Beta” of fog. There are multicast issues in 1.2.0 and some have been corrected in the beta.

    I have to say that this ability to “Change the Multicasting Address” is not a current feature. BUT you have sparked our interest.


  • Moderator

    [quote=“Wolfbane8653, post: 40833, member: 3362”]New page. I will be merging these wiki pages together.
    [url]http://fogproject.org/wiki/index.php/Multicasting[/url][/quote]

    I’ve reviewed both of those pages before you merged them. There aren’t any instructions to change the multicast data address.

    I’ve found instructions on other sites & forms but they are for FOG 0.32 and 0.33. I’m working with FOG 1.2.0 on Fedora 21 workstation. The files referenced here: [url]http://www.gravitycomputing.co.nz/fog-multicast-server-032/[/url] don’t exist on my installation.

    This site [url]http://www.digriz.org.uk/debian/freeghost[/url] towards the bottom mentions changing the multicast address on Debian, however when I open those files, they look nothing like what the site has.

    Thanks,
    Wayne


  • Developer

    New page. I will be merging these wiki pages together.
    [url]http://fogproject.org/wiki/index.php/Multicasting[/url]


  • Moderator

    Hello,

    I work in a large organization and years ago, our old network admin did custom multicast setup for all of our sites. So, the standard broadcast address for our FOG server’s broadcast domain does not work.

    Unicast works though, like a charm!

    I need to change the multicast address to is 224.0.2.224 and I was told to use “streamport 7800”, whatever that is.

    I’m using Fedora 21 and the latest version of fog.

    If anyone can offer assistance, it’d be greatly appreciated.

    Thanks,
    Wayne


Log in to reply
 

522
Online

39.4k
Users

11.1k
Topics

105.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.