MYSQL & TFTP Stops randomly after update from 0.32 to 1.0.1 and 12.04 to 14.04



  • Hi guys hope you can help…i’ll go through what i did to get these issues…

    i was running 12.04 with 0.32 no problems… on my lunch break checked to see if fog 0.33 had been released…

    1.0.1! woohoo!

    So i updated to 1.0.1 no probs…it was running like this for 4hrs approx…

    i decided to update ubuntu 12.04 to 14.04 and everything seemed to go fine…

    after an hour or so after updating ubuntu… i started getting “unable to connect to database” error in the web gui…

    however TFTP still worked…after a restart, tftp stopped working as well as the webgui.

    i did

    “sudo stop tftpd-hpa”
    “sudo start tftpd-hpa”
    “sudo service mysql stop”
    “sudo service mysql start”

    this fixes both issues…until i restart or it randomly stops working again… if i run the above in terminal it starts working again straight away.

    i thought i was asking too much updating fog as well as ubuntu…

    so i made a fresh server for testing…installed 14.04 from the off… and then 1.0.1.

    the above problems appeared within 20mins!

    is this a 14.04 issue? i didn’t have 1.0.1 installed on 12.04 long enough to see if the issue was there…

    anyhelp would be great!

    thanks



  • To add, actually it seems almost 100% stable with this modification, no crashes today…

    Maybe the one crash after I made this change was a fluke and/or I had not rebooted yet, I cannot remember with all the different testing that I’ve been doing…



  • This has been plaguing me as well, especially because it is difficult to replicate the problem consistently.

    Running the permission modification below does seem to stabilize SQL on Ubuntu 14.04 x64. Although it did still crash once, it certainly seems “better” after this modification:

    sudo chmod 775 /var/lib/mysql

    Your mileage may vary, but try that to start. I understand that the whole “it’s better but it still occasionally crashes” is not a scientific or conclusive answer at all, but that is all that I’ve been able to come up with so far…

    Thanks,
    D.L.



  • This post is deleted!


  • I just did a clean installation of 13.10 (after a clean install of 14.04 gave me this trouble too) and I’m having the exact same issue. Restarting MySQL fixes it temporarily, but in my case mysql is stopping while I’m actively logged into and using the web interface.

    I’ll try to do a clean install of 12.04 but really people, what could be the problem?



  • Thanks for the link, but the service randomly stops also.


  • Developer



  • Thats all makes sense then…thanks for the reply


  • Senior Developer

    Too my knowledge, this seems to be an issue with 14.04, not 1.0.1. I don’t know why, it just seems to cut programs at random intervals, though after the first fail, performing service <servicename> restart or the upstart equivalent seems to work until next load up.


Log in to reply
 

427
Online

38969
Users

10711
Topics

101663
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.