Lenovo M73 will not boot from local disk



  • [FONT=Arial][COLOR=#333333]I have ThinkCentre M73 machines. After I deploy an image the machine boots and hangs at “Booting from local disk”. I can fix this by running repair and/or sfc. However this needs to be done on every machine. I am currently using FOG version.32 on Ununtu Server 10.04. I had been on the 3.2.2 kernel and tried 3.8.8 and neither worked with the Leneovo M73. Currently I am running the most current kernel from Tom’s site. I can image M72s with the official kernel, but not the 73’s[/COLOR][/FONT]



  • Another issue I found was the M73 would load the Fog menu but than would hang on booting from Hard drive but if I switched the boot order back to hard drive first that would fix the issue and it would boot right up after imaging, now this was on a fog server running 0.32 not sure about the newer versions of fog.



  • I tried the suggestion above and it has helped me to load on WINXP on the Lenovo M73 10B6 model. Big Problem - CERTAIN DRIVERS JUST WONT WORK! The Realtek Ethernet driver, the Video Controller, USE Controller, SM Bus Controller and Audio Driver does not work. I’ve tried the lenovo site, but those drivers not working…Help Please…



  • I haven’t had any luck with my Lenovo M73 machines yet. It seems like it goes through the process of doing an upload and a download. Uploaded image has about 20 gb on the server so something is there. I do the download to a machine and it goes through the process (approx 15-20 minutes) but won’t boot. Plug the drive into my working computer and it shows it is empty and no partitions are there. I have tried about every kernel on the config page and still no luck. Any advice?



  • Kernel 3.12.5 on Fog 0.32 works for me.

    The BIOS for the Lenovo ThinkCentre M73z (10bb-s00y00) is also a bit backwards talking.

    I use these settings on BIOS fgkt28a:

    [FONT=Arial] [/FONT]
    [FONT=Arial]RESTART / hold [B][I][F1][/I][/B][/FONT]
    [FONT=Arial] [/FONT]
    [FONT=Arial]@ [B]Lenovo BIOS Setup Utility[/B][/FONT]
    [FONT=Arial]Depress: [B][I][F9][/I][/B][I] … to load setup default configuration[/I][/FONT]
    [FONT=Arial]@ [B]Load Optimized Defaults?[/B][/FONT]
    [FONT=Arial] Select: [B][I][YES][/I][/B][/FONT]
    [FONT=Arial] [/FONT]
    [B][FONT=Arial]Main[/FONT][/B]
    [B][FONT=Arial] \ System Time & Date \ [/FONT][/B][FONT=Arial]System Time [U] [/U] [B][I][ … set to correct time … ][/I][/B][/FONT]
    [B][FONT=Arial] \ [/FONT][/B][FONT=Arial]System Date [U] [/U] [B][I][ … set to correct date … ][/I][/B][/FONT]
    [FONT=Arial] [/FONT]
    [B][FONT=Arial]Power[/FONT][/B]
    [FONT=Arial] \ After Power Loss[B] [U] [/U] [I][Power Off][/I][/B][/FONT]
    [FONT=Arial] [/FONT]
    [B][FONT=Arial]Security[/FONT][/B]
    [FONT=Arial] \ Set Administrator Password[B] [U] [/U] [I]“… your BIOS password here …”[/I][/B][/FONT]
    [FONT=Arial] \ [/FONT][FONT=Arial]Require Admin Password when Flashing[B] [U] [/U] [I][YES][/I][/B][/FONT]
    [FONT=Arial] \ POP Changeable by User[/FONT][B][FONT=Arial] [U] [/U] [I][NO][/I][/FONT][/B]
    [B][FONT=Arial] \ Fingerprint Setup \ [/FONT][/B][FONT=Arial]Preboot Authentication[/FONT][B][FONT=Arial] [U] [/U] [I][disabled][/I][/FONT][/B]
    [B][FONT=Arial] \ TCG Feature Setup [/FONT][/B][FONT=Arial] TCG Security Feature[/FONT][B][FONT=Arial] [U] [/U] [I][disabled][/I][/FONT][/B]
    [FONT=Arial] [/FONT]
    [B][FONT=Arial]Startup[/FONT][/B]
    [FONT=Arial] \ [B]Primary Boot Sequence[/B][/FONT][B][FONT=Arial] [U] [/U] 1st device [I][U][Network 1][/U][/I][/FONT][/B]
    [B][FONT=Arial] 2nd device [I][U][SATA 1][/U][/I][/FONT][/B]
    [FONT=Arial] \ [B]Automatic Boot Sequence[/B][/FONT][B][FONT=Arial] [U] [/U] 1st device [I][U][Network 1][/U][/I][/FONT][/B]
    [B][FONT=Arial] 2nd device [I][U][SATA 1][/U][/I][/FONT][/B]
    [FONT=Arial] \ [B]Error Boot Sequence[/B][/FONT][B][FONT=Arial] [U] [/U] 1st device [I][U][Network 1][/U][/I][/FONT][/B]
    [B][FONT=Arial] 2nd device [I][U][SATA 1][/U][/I][/FONT][/B]
    [FONT=Arial]** \ Boot Mode [/FONT][B][U][FONT=Arial] [/FONT][/U][/B][B][FONT=Arial] [I][Legacy Only][/I][/FONT][/B]
    [FONT=Arial] \ Option Keys Display[/FONT][B][FONT=Arial] [U] [/U] [I][disabled][/I][/FONT][/B]
    [FONT=Arial] \ [/FONT][FONT=Arial]Startup Device Menu Prompt[B] [U] [/U] [I][disabled][/I][/B][/FONT]
    [FONT=Arial] [/FONT]
    [B][FONT=Arial]EXIT[/FONT][/B]
    [FONT=Arial] \ Save Changes and Exit[B] [U] [/U] [I][YES][/I][/B][/FONT]

    [FONT=Arial] [/FONT]
    ** this may be the key to your problem as it switches off UEFI. AUTO brings back some UEFI elements that FOG doesn’t like.



  • Tom,

    Yes I have the correct Kernel. I tried imaging, repairing and then imaging the repaired machine. That worked on the M72’s, but did not work for me on the M73s. Other posts mention that you have to use IDE mode or reformat the hard drive with one partition. I don’t really want to do either, but I can set the hard drive to IDE if I have to.


  • Senior Developer

    You’ve tried my kernel’s and the don’t work? There’s another kernel floating around the forums that was built specifically for lenovo machines for, from what I can tell, the M73’s though I was pretty sure my kernel’s worked on them pretty easily. Did you copy the right kernel for 0.32? ([url]https://mastacontrola.com/fogboot/kernel/bzImage32[/url])


  • Developer

    Well have you tried changing it to IDE to see if this was successful?



  • My image is Multiple Single Disk. Unfortunately the BIOS does not allow a Compatilbility mode for the SATA. Only AHCI or IDE and I really prefer AHCI.


  • Developer

    I have a few Lenovo R61’s and Lenovo R500’s and I was having an issues that would cause XP to Blue Screen and crash on 0.32. I found that the solution was in the BIOS.
    SERIAL ATA (SATA) --> SATA Controller Mode Option
    This option was set to AHCI and I simply changed it to Compatibility.

    Try that first…but if you still have the issue try:
    But you issue may be partition related also. Try changing the image to Multipartiion Single Disk


Log in to reply
 

463
Online

38969
Users

10710
Topics

101656
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.