Pxe-E32: TFTP open timeout



  • Hey so we have our FOG version 0.32 Server running, and I’m in need of re-imaging some student computers, they’ve been imaged before by a previous technician, But now that I need to Image them, I encounter the E32 error, we have reset the TFTP tables, but no luck, and it seems to be certain machines, our custom boxes wont image, but the Dell Optiplex 745 will all day long without a hitch, the other 3 machines will not, but One of the Custom boxes imaged, there’s nothing different Component wise between the Four, Thank You in Advance for Any Help, I have done other things that are posted online but nothing has fixed it, and we are pressed for time always and our list keeps growing daily, but if we can go around this without having to reinstall FOG, That would be the Bees Knees

    p.s. trying to image the machines with windows 7, if there’s anything else I can tell you to help, Please let me know
    Thank You Again
    Juston


  • Moderator

    @liquidprinter Since this thread is a year old, we need all of your specific details. Fog Version, Linux Distribution and Version, and the model of the target host you’re trying to network boot, if you’re network booting in BIOS mode or UEFI mode, and what boot file you’re using, and what you’re using to hand out the file (DHCP, ProxyDHCP).

    Also, you might want to take a look at the WiKi, there are troubleshooting articles in there. Here’s one on TFTP: https://wiki.fogproject.org/wiki/index.php/Troubleshoot_TFTP



  • Thanks for the help guys. I face the same issue.

    Regards,
    John Smith


  • Senior Developer

    Juston,

    I’m pretty approachable. If you have a question, ask, I generally browse the forums in and out. Someday’s I’m slower to respond due to work, but I’ll always try to help people.

    If you want to try my kernel with your systems, please feel free to download it from:
    [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]. It’s currently 3.13.2.

    If you need help please ask and any one of us will definitely do our best to help you out.

    You’re very welcome with the hard work. I’m just trying to do my best and hope others see it as well.



  • I did actually try the Kitchen Sink with the second computer with the onboard nic, after we found out it would work with the first one, but no go, we still had to put in DLink Pci cards, also if anyone else uses this Method of “Madness” for their fix, windows will not load with the ACPI left disabled, it got me for a second
    but I will try to ticker ( if spare time is around ) and see what all is affected and whats not, Also I will check into Tom’s Work, if you know him personally or if you talk to him, let him know I said Thank You for the hard work, there’s a lot of this stuff I do not know, I actually got my first “networking IT” job at my old high school, I work with a Very well educated IT guy, but there’s a lot I still need to learn, There is so much haha, but I have been in the computer “scene” since I was young, 21 now, but I went to a votech for Networking, but If you have Any Suggestions for me I would be more than Happy to read some topics or any ideas

         Thanks Again Jaymes
    
       Juston

  • Developer

    Awesome, glad you got a workaround figured out! Sounds like the issue may have been the card itself, did you try the Kitchen Sink kernel with the original hardware? now that you have them imaged you can tinker with em to figure out what the real issue was :)

    I still find it odd that one would image and the others wouldn’t :/ I would have recommend a different kernel otherwise O.o

    SOMETHING else to think about, Tom Elliot here on the forums works hard to keep 0.33b up and working, he also makes custom kernels, you can take a look at his kernel, they tend to work for most hardware :)

    his kernel is here -> [URL=‘https://mastacontrola.com/fogboot/kernel/bzImageCORE’]https://mastacontrola.com/fogboot/kernel/bzImage[/URL]

    just back up your old bzImage before giving it a whirl.



  • Well it looks like we got it going, I couldn’t find the bios update, but we installed the Kitchen Sink Kernal, temporarily replaced the onboard nics with Pci cards, and then turned off ACPI in the bios, Rom-O-Matic for the Nic Driver, and WHAM BAM, it’s working!
    I Still find it Odd it would Stop after nothing has been done to it since, but anyways now I can get some things done, WHew

    Thanks Again Jaymes, Hopefully I won’t have any other problems but if I do I KNOW where to run, home… haha but I will be on here more

    Juston


  • Developer

    No problem Juston, I live here from 8am to 3pm weekdays :P

    I just try to share what I have learned so far. I implemented FOG about a year ago as an imaging solution for the summer, luckily I played long before the summer and got all the bugs ironed out or I would have been up the creek without a paddle.

    If that doesn’t fix it let us know and we will try some different steps.



  • We had thought about that, I was going to put the hard drive from one that wasn’t working in the one that was working the day before yesterday, but I decided to leave for the day, But the Bios Setting look Right, Boot from Lan Enabled, but yea your right man, something is definitely different between them haha, I’m about to look for the Phoenix Bios update, and hopefully it will work, That is a Great idea, but I will try that and see what happens, and if it doesn’t want to take for some reason (my luck, sometimes), I will keep the DNSmasq solution in my mind
    Jaymes Thanks Again Man, I Appreciate you Fast Response
    Juston

    One more thing that’s strange, They were imaged before school was out last year, I asked my boss if he heard him say he had any problems, he said no, and I’m having troubles with the bios update, just finding it, they have the Phoenix-Award version 6.00 PG


  • Developer

    I know it seems silly but check the BIOS settings, I know you said there is “nothing” different between them, but there is obviously something.

    Have you tried imaging the other hard drives (from the custom boxes) in the one working unit to rule out any problems with the drive?

    It seems to me like the custom boxes may need a BIOS update to see your PXE server properly, I only say this as I had a similar situation happen with some Tangent C105 units. They will image on WDS all day long but won’t talk to FOG, installed the BIOS update and imaging went off without a hitch. Yes I had 3 or 4 that WOULD image to FOG without any updates but the other 25 REFUSED.

    Since you have some working units, we can kinda put the FOG server on the back burner as the main issue. It has to be something specific with the units.

    HOWEVER, Another option is to install the DNSmasq service, it acts as a proxydhcp server during boot and helps to resolve some issues with PXE booting. This can SOMETIMES help with troublesome BIOS set ups.


Log in to reply
 

363
Online

38988
Users

10712
Topics

101691
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.