Setting up and starting MySql...failed! FOG_0.32 on Ubuntu 13.10 32bit

  • Hi, Its been many years between versions of ubuntu and fog and I have trawled through the forums but as a linux novice still, i am having trouble with installing fog0.32 onto ubuntu 13.10.
    After extracting to the /opt directory, running the and punching in all the necessary info (no dhcp server and international language packs though) it has failed at this point (see below). Restarted and retried several times alas no luck. Any help appreciated as this has now become urgent 😞 . thanks in advance

    [QUOTE] Version: 0.32 Installer/Updater

    What version of Linux would you like to run the installtion for?

          1) Redhat Based Linux (Fedora, CentOS)
          2) Ubuntu Based Linux (Kubuntu, Edubuntu)

    Choice: [2]

    Starting Ubuntu Installtion.

    FOG Server installation modes:
    * Normal Server: (Choice N)
    This is the typical installation type and
    will install all FOG components for you on this
    machine. Pick this option if you are unsure what to pick.

      * Storage Node: (Choice S)
          This install mode will only install the software required
          to make this server act as a node in a storage group

    More information:

    What type of installation would you like to do? [N]

    What is the IP address to be used by this FOG Server? []

    Would you like to setup a router address for the DHCP server? [Y/n]
    What is the IP address to be used for the router on the DHCP server? []

    Would you like to setup a DNS address for the DHCP server and client boot image? [Y/n]
    What is the IP address to be used for DNS on the DHCP server and client boot image? []

    Would you like to change the default network interface from eth0?
    If you are not sure, select No. [y/N]

    Would you like to use the FOG server for dhcp service? [Y/n] n

    DHCP will not be setup but you must setup your
    current DHCP server to use FOG for pxe services.

    On a Linux DHCP server you must set:

    On a Windows DHCP server you must set:
    option 066 & 067

    This version of FOG has internationalization support, would
    you like to install the additional language packs? [Y/n] n


    FOG now has everything it needs to setup your server, but please
    understand that this script will overwrite any setting you may
    have setup for services like DHCP, apache, pxe, tftp, and NFS.

    It is not recommended that you install this on a production system
    as this script modifies many of your system settings.

    This script should be run by the root user on Fedora, or with sudo on Ubuntu.

    Here are the settings FOG will use:
    Distro: Ubuntu
    Installation Type: Normal Server
    Server IP Address:
    DHCP router Address:
    DHCP DNS Address:
    Interface: eth0
    Using FOG DHCP: 0
    Internationalization: 0

    Are you sure you wish to continue (Y/N) y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Preparing apt-get

    • Installing package: apache2

    • Installing package: php5

    • Installing package: php5-gd

    • Installing package: php5-cli

    • Installing package: php5-mysql

    • Installing package: php5-curl

    • Installing package: mysql-server

      We are about to install MySQL Server on
      this server, if MySQL isn’t installed already
      you will be prompted for a root password. If
      you don’t leave it blank you will need to change
      it in the config.php file located at:


      Press enter to acknowledge this message.

    Reading package lists…
    Building dependency tree…
    Reading state information…
    mysql-server is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    • Installing package: mysql-client
    • Installing package: tftpd-hpa
    • Installing package: tftp-hpa
    • Installing package: nfs-kernel-server
    • Installing package: vsftpd
    • Installing package: net-tools
    • Installing package: wget
    • Installing package: xinetd
    • Installing package: sysv-rc-conf
    • Installing package: tar
    • Installing package: gzip
    • Installing package: build-essential
    • Installing package: cpp
    • Installing package: gcc
    • Installing package: g++
    • Installing package: m4
    • Installing package: htmldoc
    • Installing package: perl
    • Installing package: libcrypt-passwdmd5-perl
    • Installing package: lftp
    • Installing package: openssh-server
    • Installing package: php-gettext
    • Installing package: clamav-freshclam

    Confirming package installation.

    • Checking package: apache2…OK
    • Checking package: php5…OK
    • Checking package: php5-gd…OK
    • Checking package: php5-cli…OK
    • Checking package: php5-mysql…OK
    • Checking package: php5-curl…OK
    • Checking package: mysql-server…OK
    • Checking package: mysql-client…OK
    • Checking package: tftpd-hpa…OK
    • Checking package: tftp-hpa…OK
    • Checking package: nfs-kernel-server…OK
    • Checking package: vsftpd…OK
    • Checking package: net-tools…OK
    • Checking package: wget…OK
    • Checking package: xinetd…OK
    • Checking package: sysv-rc-conf…OK
    • Checking package: tar…OK
    • Checking package: gzip…OK
    • Checking package: build-essential…OK
    • Checking package: cpp…OK
    • Checking package: gcc…OK
    • Checking package: g++…OK
    • Checking package: m4…OK
    • Checking package: htmldoc…OK
    • Checking package: perl…OK
    • Checking package: libcrypt-passwdmd5-perl…OK
    • Checking package: lftp…OK
    • Checking package: openssh-server…OK
    • Checking package: php-gettext…OK
    • Checking package: clamav-freshclam…OK

    Configuring services.

    • Setting up fog user…Exists
    • Setting up and starting MySql…Failed!

  • I just wanted to add my findings to this thread. Ubuntu 14.10 fresh install, fully updated, downloaded Fog .33b via svn. I got this error repeatedly until I installed it from my user account and not the root account. So if you have enabled and are using the root user via being logged in, it can give this error. Took me WAY to long to figure it out. I don’t know why as I’m not a Linux user but that was my solution.

  • Moderator

    If you are getting those errors it’s probably your kernel. You can swap out kernels using the Other Information -> Kernel Updates page or by downloading and replacing your bzImage in your /tftpboot/fog/kernel folder. Tom has some kernels available on his site also.

  • This post is deleted!

  • I found a rogue dhcp server on the network stuffing everything up so I disabled it (it wasnt the fog dhcp service either 😉 ). So after that I restarted everything and successfully got to the fog pxeboot menu only on PC-1 (dell 760 with old bios v.2 with Intel Boot Agent GEv1.3.22). However after trying to do a quick host registration, errors on items such as below appeared before the screen went funky… (sorry I wrote down what i could see in the time given):
    [INDENT=1]tps65010: no chip?[/INDENT]
    [INDENT=1]Carillo Ranch MCH[/INDENT]
    [INDENT=1]failed excute /sbin/v86d[/INDENT]
    [INDENT=1]vbe_init() failed with -22[/INDENT]

    I thought it maybe the bios so on another pc, PC-2 (Dell 760 with latest bios v.16 with Intel Boot Agent GE v1.3.81) I tried but then the had a massive DHCP error:
    [INDENT=1]PXE-E51 No DHCP or proxyDHCP offers were received[/INDENT]

    I recall something about Kernels about this years ago. Are they auto updated these days?

    Time to hit the search bar (unless you can post a link if its a known issue)

  • Developer

    Thanks for the insight Tom!

  • It’s because the /opt/fog/service/etc/config.php file is generated, from what I can tell, before the actual information is stored in place.

  • Developer

    Explain what you mean by “trying to upload the hosts automatically”. They should NOT do anything with the fog server automatically, other than load the pxe boot IF you have enabled the options in the BIOS. If you have sent commands to the Host after registering it and telling it to upload/image and it continues to try to image after completion, the job did not delete the file when the job was done. This can be done manually and I will explain if you would like, there are some posts on the forum if you would like to research yourself though.

    I noticed the issues with the /opt/fog/service/etc/config.php too. I had to add the database user, host, and database manually. Not sure why.

    Good luck on 13.10, I got it working and running after the hurdles, but I have found that if you have older hardware, 13.10 doesn’t tend to to enjoy it. You should be fine operating a VM though.

  • Thx Jaymes and Tom (sorry been on holidays)

    I downloaded U12.10 and Fog0.32 for now and installed ok but trying to upload the hosts automatically (??).
    When updating the [SIZE=12px][FONT=Arial][COLOR=#000000]var/www/fog/commons/config.php[/COLOR][/FONT][/SIZE][SIZE=12px][FONT=Arial][COLOR=#000000] I noticed that one of my characters in the password was not in the allowed characters list so I added it in. [/COLOR][/FONT][/SIZE][SIZE=12px][FONT=Arial][COLOR=#000000]I also found that in [/COLOR][/FONT][/SIZE][SIZE=12px][FONT=Arial][COLOR=#000000]/opt/fog/service/etc/config.php the mysql username was left blank so I entered “root” in too.[/COLOR][/FONT][/SIZE]

    FYI back on 13.10 I did change the mysql password and updated the config.php files ([SIZE=12px][FONT=Arial][COLOR=#000000]/var/www/fog/commons/config.php and [/COLOR][/FONT][/SIZE][SIZE=12px][FONT=Arial][COLOR=#000000]/opt/fog/service/etc/config.php files with the password ONLY, but yes there were prior installation attempts so I must say that the remove mysql commands would have 99% been the trick.[/COLOR][/FONT][/SIZE]

    [SIZE=12px][FONT=Arial][COLOR=#000000]I will create a new vm for 13.10 when time permits - thanks guys[/COLOR][/FONT][/SIZE]


  • Developer

    That’s the ticket! Installed without a hitch.

    Err… had to manually restart the mysql service to get it to work even after a fresh installation.
    Also had to edit the settings in /opt/fog/service/etc/config.php to reflect the proper mysql user, and host.

    sudo gedit /opt/fog/service/etc/config.php
    Make sure that
    Define (“MYSQL_HOST”, “localhost”),
    Define (“MYSQL_DATABASE”, “fog”),
    Define (“MYSQL_USERNAME”, “root”),
    Define (“MYSQL_PASSWORD”, “”),

    are all set correctly, save and close.

    then run [code]sudo mysql service restart [/code]

    navigate to the fog web page localhost/fog/management and complete the set up.

  • Updated the code from above, it now sed’s the udpcastsrc line. Sorry about that.

  • Developer

    something is still referencing the wrong file.

    Can not stat '…/packages/udpcast-20071228.tar.gz I’m heading home for the afternoon I can try more tomorrow.

  • I see what you mean now. Updated the code.

  • DId you copy the commands exactly?

    I’m not trying to go to /lib, I’m trying (from the packages folder) to go …/lib/

  • Developer

    I believe you are correct about UDPCast… Its close…

    sed can’t read /lib/ No such file or directory should be /lib/common/

  • I had no issues building and installing fog 0.33 on ubuntu 13.10. Please forgive as I forgot in the midst of operating, that you were using 0.32.

    That said,

    To fix udpcast. go to the location on the extracted fog folder:
    cd packages

    I think you need to change the udpcastout variable with:
    rm -f udpcast-20071228.tar.gz
    sed -i ‘s/udpcastout=“udpcast-20071228”/udpcastout=“udpcast-20120424”/’ …/lib/common/
    sed -i ‘s/udpcastsrc="…/packages/udpcast-20071228.tar.gz"/udpcastsrc="…/packages/udpcast-20120424.tar.gz"/’ …/lib/common/
    cd …/bin

    It should build

  • Developer

    Tom, it will ask you to create a mysql password in the current operating window… so if he still had the command window open from running ./ Then, from my experience using FOG and Ubuntu, mysql would have taken the window and finished installation there. I think there is a problem with the repo he is trying to use.

    Try these steps.

    from a command line type
    sudo apt-get clean
    sudo apt-get update
    sudo ./

    if you would like to re-try on your current set up you need to run [code]sudo apt-get autoremove mysql-server[/code] reboot, then run the fog installer again.

    mySQL works with 13.10 and it installed without issues. I had complications installing anything without root but once you put sudo in front of the command it should go without a hitch. I would first run the apt-get clean and apt-get update so it has clean and updated repos.

    NOW I want to warn you… UPDcast will fail installation I am still working on that one. Honestly, I would spin up Ubuntu 12.10 and use my installation guide here on the forums in the mean time.

  • When Ubuntu installed the mysql-server, did you get a separate window requesting you to setup a password? You don’t have to setup a password, but if this doesn’t run, the mysql database isn’t initialized. So it would fail to start the server at all. Just my thoughts. I’m running up a 13.10 vm as well to test the install process.

  • Developer

    I’m your local Ubuntu nut, I will spin up 13.10 and see what I can find. In the mean time I would try the 12.10 Ubuntu, I have not had any trouble setting it up in the past.