Same ip, no pxe boot



  • replaced router but it has the same ip address.
    i’m able to log into the fog web gui but i can’t pxe boot it just times out.
    using ver .29 and ubuntu 10.10

    i have tried looking every where on the web but no luck. can’t seem to find what the issue is

    thanks for any info on this problem.


  • Moderator

    Just verify your IPCOP setup is issuing the next-server and filename options. I believe option 66 and 67 are windows DHCP specific option numbers. the rest of the world uses next-server-name and filename options.


  • Developer

    You could try to install the proxydhcp with DNSmasq, my building is funky with it’s DHCP and I have problems tftpbooting without the service.

    I’d definitely give it a shot if your next server is set for the DHCP to see and you still are unsuccessful in getting your fog pxeboot screen

    take a look here if you are interested.

    [url]http://www.fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]





  • dhcp is coming from ipcop witch acts like a router.
    but the thing is it all worked before i redid ipcop but i’m using the same ip. i may just end up redoing fog. i have over 400 images :(

    so it goes cable modem - ipcop - switch - then everything else. fog is plugged into the switch.



  • You could always use another server to manage DHCP. Most environments have DHCP servers and don’t use the router for DHCP. In case you decide to go that route, this page will show you how to configure DHCP for pxe boot.
    [url]http://www.fogproject.org/wiki/index.php?title=Windows_DHCP_Server[/url]
    What type of router were you using and what are you using now?



  • skylar, is your dhcp service coming from this router?



  • ok im able to use the tftp command and is send and receives in about .2 sec.
    how would i go about using wireshark to see where it gets stuck? thanks


  • Developer

    can you use commands to pull the pxelinux.0 from your server?

    [code]
    tftp x.x.x.x get pxelinux.0
    [/code]

    if you get your pxelinux.0

    set up a box to wireshark and see where the file gets stuck.



  • well what is ipcop. had to redue it and ipcop runs to switch. im using same ip address as old ipcop.

    no errors pop up. tried to boot pxe and then nothing. just times out. tried on different laptop same deal. dont know where the problem is.


  • Developer

    [code]
    replaced router but it has the same ip address[/code]

    Routers are bad, they tend to block things. Is there a DMZ zone you can set for the ip address of your server? can you try a SWITCH and not a router?

    Since the router is the only thing that has changed that is where the problem would steam would be my guess, and that is where I would start.

    It would be a good idea to run Wireshark to see how much information is being passed along.

    What is the error, if any, you are receiving?


Log in to reply
 

437
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.