• Keep getting this error. It does not seem to matter if it is deploying or uploading an image. This is from a Fog restore and all images are put back into the /images directory everything else seems to be working fine in Fog. Running .32


  • Ok fixed it. I just re-ran the installer over the install. Then went back and made sure my Database passwords were in the config file. It seems to work fine now. I am having severe throughput problems with this though. Looks to me though it is a ubuntu running as a VM thing though not part of FOG.

    Thank you for your help.

  • Does the fog account have write permissions to that directory?

  • I am also able to navigate to the /images and see them all via FTP.

  • Yep


  • Are you able to connect via FTP?

  • The FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD look correct - I attached a screen shot. FTP service is running. The username on the machine that I made is “fog”.


  • Are the fog username and password correct in FOG Settings ([URL=‘https://fog.classroom.ohio-state.edu/management/index.php?node=about&sub=settings’]http://<YOUR FOG SERVER>/management/index.php?node=about&sub=settings[/URL] FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD)? This is referring to the user account on the server, not the user account on the FOG web console. This is the account that is used to FTP the files. If the account exists, and the settings are correct, and you’re still having problems with creating tasks, then I’d say check that the FTP service is running:
    [CODE]/etc/init.d/vsftpd status[/CODE]

  • I see so that wouldn’t have an effect on it being virtual then. Any thing in particular I can look for in the TFTP part beside the file I attached?

  • When a task is created in FOG the web server creates a small boot file for the client using the client’s MAC address as the file name. The web server uses FTP to push that file onto the TFTP server so that when the client PXE boots it will look through all the files on the TFTP server and grab the one with it’s MAC address in the name. If no MAC address specific file is on the TFTP server then the client uses the default file. The MAC specific file contains the task information, so if the file isn’t there then the client won’t realize that it has a task.

  • Ok I turned off firewall (I forgot about that - thanks).
    No passwords have been changed
    TFTP server is running (verified that) - settings attached
    Now the MAC specific part - is that look at the server nic or the client nic. This is a VM do you think that could be messing with it?


  • That actually looks like an FTP issue to me. The FOG web server FTP’s the MAC specific boot file to the TFTP server when creating a task. If you’ve changed the password or permissions on the TFTP server, or have a firewall blocking FTP, or the FTP service isn’t running, then you won’t be able to add those files.

  • Sorry I meant TFTP - phone auto corrected me.

  • Yeah I can grab pxelinux.0 via FTP. I also tried to restore the database again. No luck

  • Moderator

    Is tftp working? Can you grab pxelinux.0 from a client via command line?

  • If it helps I am running Ubuntu 12.10 and I have disabled apparmor.

  • No errors in the fog log viewer. I thought maybe a database problem but everything seems to be fine on that side.