• Hi, I migrated my fog server to a new system and during the process I transferred the postdownload script from the old versioned system the the newer one. I’m running into some issue sysprep running and connecting the client to the domain after the download. Is there a new postdownload script I could download and try?

    Regards,

    Jim P.

  • Testers

    @geekyjm If your old fog server was on a version pre-ssl then it may have been pretty dated. There was an older update_unattend script where you would have to put the domain join password in plain-text. Now you can use the $adpass variable that pulls from the foghost’s settings. Then the domain password isn’t passed in plaintext in any script files. So you may need to update how that password is stored on your hosts under ad settings (I believe there’s a global method in the fog settings GUI) and then try again.

    I just started using the update_unattend postdownload script myself and was successful without having to have the password in plain text anywhere and the machines joined the domain.

    As @george1421 mentioned there may be more going on here, as there may be some new steps needed for your fog install, but we can get this working the way you’re expecting again none the less.

  • Testers

    @geekyjm Yes lets see what the script looks like. I have some theories on what’s going on.
    What version of fog were you using and what version are you on now?

  • Moderator


  • @jj-fullmer It looks like the fog.postdownload script calls the fog.custominstall script which intern calls the fog updateunattend. My fog knowledge is very basic. I can include the scripts if it helps.

    Jim P.


  • @george1421 I check my old server and there is no /opt/fog/ssl directory. When it was installed way back when no SSL cert was used. The site is only accessible from http://fog.

    Jim P.

  • Testers

    @geekyjm Are you using a postdownload script to dynamically update your unattend.xml file so sysprep will join the domain with the settings given by fog?
    Or are you using the fog service to join the domain during the oobe firstlogon phase, or after that?

  • Moderator

    @geekyjm If I remember correctly the certificate is in /opt/fog/ssl ( I think ) but it is in /opt/fog directory or below. be sure to rename the original certificate on the new fog server before you copy over the old certificate. Once copied over reboot the fog server computer.


  • @george1421 Thanks, for your assistance. Question where is the certificate located? If I can find it I can then copy it to the new server. But is the certificate based on the server name? When creating the new server I named it something other than the original.

    Jim P.

  • Moderator

    @geekyjm said in postdownload script:

    Is there a new postdownload script I could download and try?

    First let me say that post download scripts have nothing to do with Windows or connecting to AD. Your issues are probably not the root cause.

    Lets assume you have the FOG client connect the target computer to AD (there are other ways to got about it, but most use the fog client) and you have just changed fog servers.

    My bet is that the fog client can no longer talk to the new FOG server, and hence not get the instructions to connect to AD.

    When the fog client is installed (like on the precaptured golden image), it tattoos itself to the fog server’s certificate. That certificate is unique to each install of FOG. My bet is that you didn’t copy over the certificate from the old fog server to the new fog server. So the clients are rejecting the new FOG server because the certificates don’t match.

305
Online

9.9k
Users

16.2k
Topics

149.0k
Posts