Fedora 18 / Fog problem - newbie



  • I have 30 odd windows 7 computers to image and thought I’d use Fog.
    Installed version 0.32 on Fedora 18.
    I have a separate DHCP server.
    Went though the setup fine and can boot clients successfully to the fog menu. I can do host registration and the clients show up in the client list.
    Problems come when I try and upload an image. I understand that I have to set a master password under Other Settings -> PXE Boot Menu. This fails with the error message ->
    "
    [CENTER]PXE Menu updated failed![/CENTER]
    [CENTER]Unable to upload file."[/CENTER]
    [CENTER]Also the menu timeout value (10) - doesn’t match the actual timeout menu when I boot a client.[/CENTER]
    I’ve tried looking at the permissions on the TFTPBOOT folder, setting passwords under Storage Nodes and in the Fog Settings menu and nothing works.
    I Can Get and Put to the TFTPBOOT folder from the command line.
    Tearing my hair out here.

    Also, if I try any of the client tasks (Upload, Debug, Hardware Info etc.) the client always just boots back to the Fog main menu…
    Any help appreciated…



  • I did some firewall configs a while back and posted them here. They’re far from perfect, but they might help point you in the right direction.



  • @David Dreggors, post: 10816, member: 3390 said:

    Good job Tim!
    I ran into several selinux issues myself regarding tftp contexts in the “/tftpboot” directory. I was able to fox them by cd’ing in to that directory and running the following command:

    >for F in $(find ./* -type f); do chcon -t tftpdir_rw_t $F; done
    >```
    Thanks for that David, but I already had selinux disabled. More problematic though is that I don't want to run FOG with the firewall disabled. I've tried configuring the firewall ports to allow NFS by using static ports for the various RPC services, but the imaging process just fails to mount the NFS share with no route to host. Turning off the firewall allows it to work. I'm wondering if the TFTP kernel uses some other ports I don't know about for communicating back to the fog server....


  • Good job Tim!
    I ran into several selinux issues myself regarding tftp contexts in the “/tftpboot” directory. I was able to fox them by cd’ing in to that directory and running the following command:

    for F in $(find ./* -type f); do chcon -t tftpdir_rw_t $F; done
    

  • Moderator

    Glad to hear you have it working and it didn’t mess things up too bad.



  • Just a further update…ran into the same problems others have reported with a blank task screen…I’m running PHP version 5.4.11…as reported elsewhere I replaced &$tmp with $tmp throughout tasks.confirm.include.php and FOG is now scheduling tasks…and [I]@chad-bisd[/I]… not a production server!..a home server…although the install did break mediatomb…



  • I have absolutely no intention of starting an immature flame war over who’s distro is better. Fact is I only use ubuntu for fog anyhow, I use other distro’s for some of my other servers. I think you’ve come to these forums expecting them to be like most others mate… they’re not. We’re all quite friendly and nobody’s forcing anyone to use any distro they dont want to. The moment this forum turns into a distro war platform, I’d be out of here myself.



  • Sorry, was not meant to hijack… I did not expect answers for these issues here. I just meant to mention that these are some of the items I have noticed. Maybe I was not clear but I was listing them here because I found the issues on Fedora 17. The OP is also using Fedora, so my point was that as he runs into some of these (if he does) then maybe there will be answers. I have already (as you know) started mentioning them in the bugs forum.

    Also as to the “forcing users to use Ubuntu”, that was a bit harsh I guess. I was just shocked that the answer was “why fedora?” and “can try a clean install on ubuntu?”. What I meant is that something like “here’s what I did in Ubuntu” is generally received better than “why fedora? can try a clean install on ubuntu?”. It gives the impression that the poster is saying Fedora is not as good as Ubuntu, whether that was meant or not. I have seen many forums turn into a “my distro is better than yours” diatribe that goes on page after page over similar remarks.

    Again, I am sorry if I offended.


  • Moderator

    @Tim, I applaud your bravery for installing FOG on a server that runs a pile of other stuff. During the install, FOG warns you that it will install and overwrite most settings for mySQL, Apache, php, etc and advises you NOT to run this on a production server. I’m glad you got it working.

    @David, We’re always open to feature requests and bug reports. FOG 0.32 is going on 2 years old, and runs best on versions of Linux from about the time of its release. Also, many of the active contributors to the forums and the wiki run FOG on Ubuntu, including myself, and often suggest it for users having issues because we can support it better. That doesn’t mean we are forcing people to a particular version if they don’t want to use it, just that we’re better able to help if you run it on something we are more familiar with.

    If you have a list of issues with FOG, please post them in their own thread and not hijack this one. We’ll be glad to address them to either clarify the issue, or address it however it needs to be addressed.



  • OK…so just skirting around the side-issues here…I think I’ve solved the problem…seems to be an obscure thing relating to VSFTPD and Fedora 17/18 (and perhaps Redhat generally). Here’s the thread and I fixed it by adding “seccomp_sandbox=NO” to vsftpd.conf and restarting the service. I was then able to update the PXEMENU for the master password. Haven’t tested whether I can push and pull images yet.



  • Matt,
    your clearly not sorry, I can tell by the fact that you called me immature, condescending, disrespectful, impolite, and accused me of having a bad attitude in a single post. The points I made were in fact valid, and I never said you implied you had all the answers. I said you were less than helpful to the OP. After reading his responses my points are validated… Tim clearly states that he did not wish to simply wipe his server and start over in Ubuntu.

    I know text is not as transparent as voice and visible body language, but I was not intending to be rude. I was being honest, which I see you have mistaken for disrespectful and having a poor attitude. Please read the rest of my post carefully and you will see that my attitude was of a helpful nature. That said, I am sorry if the truth is offensive to you.



  • In case you hadn’t read my post properly… I never claimed to know any answers. I merely offered up the good experiences I had with my distro of choice. In case you also missed the fact that I said to him that I know it doesnt fix his problem… I clearly did… go back, read it again, and dont be so condescending.

    Sorry, but that was not very polite or even a valid point. Oh, and in case you weren’t aware, as you’ve signed up to this forum only today, we are all quite well mannered here and tolerant of each other. With an attitude like this you are likely to get backs up or make people want to leave. Please try to be mature and respectful of others.



  • I would not say that “just use Ubuntu” is not a great answer to any question. The point of Linux is freedom of choice, you negate that by forcing a user to use a single distro. For that we might as well be using Windows.

    Also, what makes Ubuntu better for software meant to run as a server?
    Ubuntu and Fedora are Desktop distros by definition so in the server arena they are probably very equally footed. Not to mention that the requirements for Fog are Apache, MySQL, NFS, etc… which run fine on both.

    Sorry, but that was not a very helpful answer.

    — EDIT —
    Your issues are either SELinux or password issues.
    Start with setting SELinux to permissive on the server Fog is running on:

    sudo setenforce 0
    

    If that does not help then you are having password issues.
    I have noticed the password issue as well and it is compounded significantly by several facts:

    1. Inconsistent encryption methods (some tables password columns have none others have md5)
    2. Some kept in DB while others are kept in files.
    3. The answer seems to be set them all then same… but they are everywhere. If they should be the same, shouldn’t they be in 1 locate (file or database) and all using the same format (encrypted or not)?

    I have also discovered some other very disruptive issues as well. I will be trying to seek the developers help on them all once I catalog all the issues.

    Examples of some of the issues:

    1. The installer overwrites “/etc/exports” in stead of appending (HUGE NO NO)
    2. The installer assumes locations for NFS shares and HTML Document Root without questioning during the install.
    3. Passwords are kept in files and also in database (choose one place).
    4. Some tables use no encryption for passwords while others use plain text passwords.
    5. Installer assumes MySQL is setup with root user having NO password even though the default installer for MySQL makes you set a password for root when you first start it. Should ask for root pass, then use that to create fog user with default password for fog.
    6. SELinux permissions (a simple chcon fixes this)

    These are just what I found yesterday during first install in Fedora 17. After many attempts and also having to uninstall MySQL, re-install MySQL, pull my exports file from git (thank god it was in git) and merging the new with old… I can now boot a client to the tftp server. However due to password issues I still cannot update kernel from the web console, or get quick image to work. I have tried fog and password for the password prompt, none work. I like what I am seeing with the direction this software is taking, however these are serious concerns. I would be thrilled to see it get better and would love to help.



  • I run a pile of other stuff on this server and have been using Fedora for awhile. Way too much effort. I guess I could setup a separate Ubuntu box and run Fog off it but that would only be temporary…so disappointing! I use DeployStudio for another setup I have (a dual Mac / PC site) and that works well, quirky but well. I was really hoping Fog would be a better windows solution.
    I think looking further into it that maybe something is wrong with the VSFTPD setup because I can’t FTP into the box at all, even directly. I just get Oops 500, Child died, but not knowing how FOG is updating the PXE menu I’m hunting in the dark really.



  • I dont really know whats going on with your install but just a quick question… Is there some reason you have to use fedora? I’ve found ubuntu 10.04 and 12.04 quite successful with the normal FOG install, and 12.04 has been running a storage node for me very successfully for quite a while now.

    I know it doesnt fix the problem, but is there any way you can try a clean install on ubuntu?



  • Just an update…decided to reinstall from scratch just to check I hadn’t done anything wrong. So followed the uninstall (complete removal) instructions and then did a complete reinstall. Got an error message about NFS service during the install so I enabled the nfs service and restarted it. Went through the password updates suggested under fedora install…but same result…fails on updating the master password in the PXE menu step…with error message TFTP updated failed…unable to upload file…
    How does the web interface update the \TFTPBOOT folder…via FTP, via TFTP or directly? Seems like it must be an authority issue between TFTPBOOT and the default fog user…tried enabling logging for VSFTPD but nothing showing…


Log in to reply
 

325
Online

38729
Users

10555
Topics

99937
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.