• Hello,
    i plan to upgrade my server fog to the latest debian stable “bullseye”.
    Can there be compatibility problems ?

    i see that php go from 7.3 to 7.4.
    Do i have to run “installfog.sh” once debian upgraded?
    Do i have to modify /opt/fog/.fogsettings :

    php_ver='7.3'
    php_verAdds='-7.3'
    

    to

    php_ver='7.4'
    php_verAdds='-7.4'
    

    In .fogsettings, does this line is always usefull :

    packages='apache2 bc build-essential cpp curl g++ gawk gcc gzip htmldoc lftp libapache2-mod-php7.3 libc6 libcurl4 m4 mariadb-client mariadb-server net-tools nfs-kernel-server openssh-server php7.3 php7.3-bcmath php7.3-cli php7.3-curl php7.3-fpm php7.3-gd php7.3-json php7.3-mbstring php7.3-mysql php-gettext sysv-rc-conf tar tftpd-hpa tftp-hpa unzip vsftpd wget xinetd zlib1g'
    

    thanks for your help


  • @sebastian-roth
    I completed the upgrade without any major problems.
    I had to reinstall some php packages that had been removed during the upgrade
    (the comparison between the packages installed on the old version and the new one allowed me to reinstall them easily)

    I also had to re-run installfog.sh because I had the same problem as here:
    https://forums.fogproject.org/topic/15254/503-service-unavailable-after-debian-upgrade.

    Also, unrelated to fog, I had to review the configuration of mariadb and more particularly the authentication mode of the “root@localhost” user.
    Indeed the user “root@localhost” was still using authentication with a password, but the new method is to use auth_socket :

    +-----------+------------------+-----------------------+-------------------------------------------+
    | Host | User | plugin | authentication_string |
    +-----------+------------------+-----------------------+-------------------------------------------+
    | localhost | root | mysql_native_password | XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX |
    
    +-----------+------------------+-----------------------+-------------------------------------------+
    | Host | User | plugin | authentication_string |
    +-----------+------------------+-----------------------+-------------------------------------------+
    | localhost | root | unix_socket |
    

    this is all I can say

  • Senior Developer

    @plegrand No manual adjustment of /opt/fog/.fogsettings needed. The latest dev-branch FOG installer script should take care of this! Please give it a try and let us know if it doesn’t work as expected.

    Do i have to run “installfog.sh” once debian upgraded?

    Technically it should work without running the installer again but as I said the installer will take care of adjusting .fogsettings file and I suggest you run it.

271
Online

8.8k
Users

15.5k
Topics

144.4k
Posts