• Hello,
    I have a fog server at the latest version, which usually works very well with any type of machine. I also set up the bios / uefi coexistence:

    “PXEClient: Arch: 00002” and “PXEClient: Arch: 00006”> “i386-efi / ipxe.efi”
    “PXEClient: Arch: 00008”, “PXEClient: Arch: 00009”, and “PXEClient: Arch: 00007”> “ipxe.efi”

    It worked perfectly so far.
    My company just bought a fleet of Fujitsu A3510.
    No Bios boot possible, only UEFI.

    But these do not get IP with my DHCP server> "no configuration methods succeeded"

    I have no idea how to solve my problem, does anyone have any idea?

    Thank you

  • Moderator

    @slang said in Fujitsu A3510 PXE UEFI Boot:


    Thank you for sharing your experiences here. For new hardware we are seeing that iPXE needs to be rebuilt with the latest code from the iPXE project (different from FOG Project). That program manages the iPXE menu. For FOG, you also need to make sure you update the FOS Linux kernel (FOG Web UI->FOG Configuration->Kernel update) to at least the 5.10.x version of the kernel. This will allow FOS Linux (the engine that clones hard drives) to support the latest hardware too.

    One last bit of information, you might want to upgrade to the dev-branch of FOG to bring your fog install up to to address an issue if you plan on cloning Windows 20H2 or later. Microsoft changed the disk structure that requires the upgrade to FOG.

  • Hi all,
    I installed FOG 1.5.9 on 31 December 2021 from scratch on a ESXi VM hosting Ubuntu 18.04.6 server (following this tutorial: https://schulnetz.alp.dillingen.de/materialien/Fog.pdf ), and it worked brilliantly out of the box with most of the PCs in our school.
    However, I had trouble booting a Fujitsu K5010/24 with a Realtek PCIe GbE NIC, type 8168 ( PCI\VEN_10EC&DEV_8168&SUBSYS_125F1734&REV_15 in Windows device manager). The MAC address begins with 98:ee:cb which makes it a Wistron make. The manufacturer lists the card as a Realtek RTL8111H, same as for the Fujitsu A3510 which started this thread. The computer has no option for BIOS, only EFI. It would give me “Waiting for link-up on net0… ok” and then “Configuring (net0 98:ee:cb… … No configuration methods succeeded. (http://ipxe.org/040ee186)” – so, no dhcp.
    snp.efi and snponly.efi said “Received DHCP answer on interface net0” but would then hang on loading bzImage, sometimes at 0% sometimes at 1% or 2%. No good.
    After a (very!) long time of searching I found this thread and followed the instructions - before building iPXE, the kernel message was iPXE 1.20.1+ (g4bd0). The file /tftpboot/ipxe.efi was 958k (in WinSCP)
    In my case (Ubuntu) the path to buildipxe.sh is
    cd /home/fog/fogproject/utils/FOGiPXE/
    Building took a few minutes, but it produced no error messages.
    After building, the kernel message was iPXE 1.21.1+ (ge814d). The file /tftpboot/ipxe.efi is now 1042k (in WinSCP).
    The new file worked perfectly with my test machines as well as the problematic Fujitsu K5010/24!
    I am happy to share the ipxe.efi file in case anybody needs it on https://www.langer.ws/2022/01/fog-solve-client-boot-problems, and I want to express how grateful I am to all the people who developed this brilliant gem of an open-source project, and to all the contributors in the forum as well. Thanks, guys and gals, you are the salt of the earth! 😊

  • @francois said in Fujitsu A3510 PXE UEFI Boot:

    @sebastian-roth I had a similar issue with Fujitsu Q7010, your advice about building latest iPXE binaries fixed mine. Now it boots just fine, thank you !

    Hi, is it possible that you share that kernel?

    Best Regards X23

  • @sebastian-roth I had a similar issue with Fujitsu Q7010, your advice about building latest iPXE binaries fixed mine. Now it boots just fine, thank you !

  • Moderator

    @EZY4 You can try using a different iPXE binary like snponly.efi at first. This might work with the A3510. Though on the other hand you can’t be sure if this will work for all your other devices.

    Not sure if you can setup a particular DHCP policy based on the MAC address just for those machines to use snponly.efi

    Other than that I suggest you build the iPXE binaries from the latest official code base and see if those work on the A3510. Assuming you have the FOG stuff in /root/fogproject try this:

    sudo -i
    cd /root/fogproject/utils/FOGiPXE/
    cp ../../packages/tftp/ipxe.efi /tftpboot/

    Pay attention to the long output when running ./buildipxe.sh as it might fail for whatever reason. If you feel it ends with an error, post the last 20 lines of the output here and we will have a look.

    Make sure ipxe.efi is set in your DHCP again, boot up a machine and pay attention to where the preemble tells you the version number iPXE (g…). That should be different to g4bd0 (default on 1.5.9 installs).