• Hello,

    I wondering if anyone can help me with updating/or adding network drivers for a Lenovo P340.

    I have been using FOG here at my work for around 2 years. We have been using legacy bios pxe boot without issue. I have already setup the UEFI boot options, but we just never used it often. However, we just received several Lenovo P340 computers and while they will boot to the FOG login screen I get an error message about missing network drivers.

    I was originally using a CentOS 7 server OS and updated that to the 5.11 kernel, but I was still getting the missing network drivers error. So I figured what the hell I’ll spin up a new vm with Ubuntu 20.04 and install FOG to see that fixes the issue. So I did that and even downloaded the newest version of the kernel so I’m running 5.11 on that as well. I then installed FOG rebooted my P340 and lo and behold I have the same issue.

    I’m not sure where to go from here. I was following another thread that said to check the FOS kernel and make sure it was above 5.6 or something. But I’m not sure if that is the same thing as updating the server OS’s kernel. If not I’m not sure how to do that. I have also updated the kernel through the web GUI to use the newest available, but still no change.

    Any help would be greatly appreciated as I’m sure this issue will just keep popping up as time moves forward.

  • Thank you everyone. I tried again and I was able to successfully register that computer. I did re-try adding the 32bit and 64bit Kernels via the web gui and when I run the above commands on the server I get a return showing the 5.10.12 kernel.

    root@fogsrvr:~# file /var/www/html/fog/service/ipxe/bzImage*
    /var/www/html/fog/service/ipxe/bzImage: Linux kernel x86 boot ex ecutable bzImage, version 5.10.12 (buildkite-agent@Tollana)…

    root@fogsrvr:~# file /var/www/fog/service/ipxe/bzImage*
    /var/www/fog/service/ipxe/bzImage: Linux kernel x86 boot executable bzImage, version 5.10.12 (buildkite-agent@Tollana) …

    So again thank you for your help.

  • Senior Developer

    We seem to have a few people having issues with that particular NIC.

    While some were able to make it work updating to the 5.6.18 kernel others still have issues to get it to work.

    @jcyrus_rti First let’s make sure it actually boots the newer kernels - see my below post to check.

  • @george1421 Thank you for your reply. I have already done that. I wasn’t sure if that was what the Kernel Update via the web gui did, but I had a feeling.

    I read your post in https://forums.fogproject.org/topic/15038/dell-optiplex-5080-network-interface-not-found/6 that mentioned checking the kernel version from the pxe’d computer. I’m not sure where/how to get to that cli. When I boot via pxe I get the FOG login screen, but if I try to deploy an image or register the host I get the Network drivers error.

  • Senior Developer

    @jcyrus_rti As George said, don’t mix up FOG server OS kernel and the FOS (FOG OS booting to do the work) kernel. The later one will be used on PXE booting the machines.

    Now it sounds like you have updated to 5.10.x already. Please double check if that is the case by running the following commands and post output here:

    file /var/www/html/fog/service/ipxe/bzImage*
    file /var/www/fog/service/ipxe/bzImage*
  • Moderator

    @jcyrus_rti Upgrade your FOS Linux kernel to 5.6.18 under FOG Configuration -> Kernel update. This is the OS that gets transferred to the target computer for imaging and not related to the FOG Server installed OS, in your case ubuntu.