Lenovo ThinkPad P15 & T15 No network interface found! Kernel might not have the correct driver!


  • I need help, I have the Lenovo ThinkPad P15 and the T15. I have been trying to deploy OS on these laptops from the Fog server. When I PXE boot this laptop I can pass the Fog menu select Deploy then get “No network interface found! Kernel might not have the correct driver”

    I have updated the kernel, also on the latest fog server not sure what to try next

  • Moderator

    @infrapeya The quickest way is via the linux command prompt on the master FOG server.

    If you are using a rhel based linux distribution then.

    scp /var/www/html/fog/service/ipxe/bzImage* root@SN_IP:/var/www/html/fog/service/ipxe

    i.e. scp /var/www/html/fog/service/ipxe/bzImage* root@192.168.20.40:/var/www/html/fog/service/ipxe

    The debian/ubuntu versions are a bit more difficult.
    Remote connect to the storage node using ssh (or putty from windows)

    On the linux command prompt key in the following.

    sudo su -
    scp <linux_user_on_master_fog>@<master_fog_ip>:/var/www/html/fog/service/ipxe/bzImage* /var/www/html/fog/service/ipxe
    

    i.e. scp daffy@192.168.11.53:/var/www/html/fog/service/ipxe/bzImage* /var/www/html/fog/service/ipxe


  • @george1421

    I need to update the storage nodes, how are they updated? the Web Master updated it and it worked correctly


  • @Sebastian-Roth awesome, it’s now working although i updated the Kernel from the GUI in the fog yesterday and it said “Transfer Succeeded” “your new FOG Kernel has been installed!” it didn’t update it. because now after I ran the command to check the kernel version it was showing"4.19.145" then I rebooted the server reinstall the new kernel “5.6.18” both 32 and 64bit.

    now it’s working. thank you very much for your help

  • Moderator

    @Thobela network device [8086:0d4c] was added to the linux kernel 5.5.x, so the update to 5.6.18 must not have worked as expected. It will be interesting to see what the file command outputs.

    The right answer is to update to 5.6.18.

  • Senior Developer

    @Thobela As we can see on cateee.net the network card 8086:0D4C is supported since kernel 5.5 and so it should be working as soon as you have the kernel binaries updated as suggested.

  • Senior Developer

    @Thobela Just type in this command exactly like this - maybe you need to be root but usually it’s not neccesary for this command:

    file /var/www/html/fog/service/ipxe/bzImage*
    

  • ![@Sebastian-Roth I`m new in this, how do you run that again in the Terminal, do you go to that directoryfog_2.jpgfog_1.jpg

  • Senior Developer

    @Thobela After updating to the new kernels you can check the version by running file /var/www/html/fog/service/ipxe/bzImage* on your FOG server terminal. Does it show 5.6.18??

    Either way you might want to provide more information about the network card used in this device. Boot it up into Windows and take a look at the network card in Windows device manager. There you should find vendor and device ID information (like VID_045E&PID_0294). Post those IDs here.


  • thank you for your feedback. I’m not sure if there is anything which I need to do once I updated the Kernel to 5.6.8 because it’s still doing the same thing(fog_error.jpg link url)

  • Moderator

    FOG Configuration -> Kernel Update

    Update to 5.6.18 for both 64bit and 32 bit kernels. That should address the driver issue with the latest hardware.

    If that doesn’t work then we will need to collect a bit more info on the hardware itself.

296
Online

8.6k
Users

15.3k
Topics

143.4k
Posts