• I posted my problem in another thread and was asked to post in a specific thread, so here it is.

    After the help of the forum and lots of tests at end i’ve been able to deploy printers through FOG.

    In the documentation you should really mention the program PrinterManagerHelper.exe that can be very useful to sort problems. This program can also add a new printer the same way that the client, so it’s much faster to check if your parameters work.

    One mistake in my setup was a wrong name in the UNC path to the inf file. It helped to check with psexec -s -i cmd.exe if the path was accessible.

    Some doubts/problems I still have after double checking everything.

    If the drivers of the printer are not installed in the host, the installation fails even if the right driver was in the specified path.
    Selecció_486.png

    After that the client thinks that the printer is already configured.

    Selecció_487.png

    It’s not clear what the name of the printer has to be. In the docs states that should be contained in the .inf file, but the name that is shown in PrinterManagerHelper is not there, so the best option is use this program to check the name of the printer after installing it manually.

    If there’s some mistake in the name of the printer or the driver, the IP port is created, and there’s no error in the client log, but the printer does not appear. Don’t know if an error message could be added.

    When you add or remove a printer in the Web UI you have to go to the host list and select the host to see the changes reflected.

    When the printers are removed, it only removes the spool queues. But the first printer added still remains. That’s nothing really important and perhaps is just an issue of the HP universal PCL driver.

    Thanks for your support!!

  • Senior Developer

    @JJ-Fullmer We provide the PrinterManagerHelper with ever release of the fog-client, e.g. https://github.com/FOGProject/fog-client/releases/tag/0.12.0

    I know it’s not perfect and sometimes doesn’t provide all the information correctly. Though I don’t have real printers in my test setup and can’t work on this part much.

  • Testers

    @jaumeramos Remind me where you found the printermanagerhelper. I remember that being added a few years back but couldn’t find it when I was updating the documentation, so I wasn’t sure if we still were including it.

  • Testers

    @jaumeramos Does the system account have access to that share?
    The best way to test would be to use a tool like psexec (https://docs.microsoft.com/en-us/sysinternals/downloads/psexec)
    to open a command prompt as the system account psexec -s -i cmd.exe
    And then you can see if that’s the issue. If it is I think the share needs to have permissions of the domain computer accounts or network system or something like that. If that’s not this issue, then I’ll do some more testing and update the docs accordingly.

    MODs note: Moved from https://forums.fogproject.org/topic/14752/fog-1-5-4-8-printer-management-config-file-field-missing


  • Sorry for hijacking, but I’ve been reading the new documentation and still unable to deploy a printer.
    The IP port is created, and there’s no error in the client log, but the printer does not appear.
    I’ve checked that the UNC path is accesible and been able to install a printer using the inf file in that location.

    Can you give some guidance about how to troubleshoot?

    Selecció_476.png

    Selecció_477.png

    I’m using the latest stable fog version.
    Selecció_479.png

    MODs note: Moved from https://forums.fogproject.org/topic/14752/fog-1-5-4-8-printer-management-config-file-field-missing

306
Online

8.7k
Users

15.4k
Topics

144.1k
Posts