Dell Precision 3930 Rack - EFI PXE Issue



  • Hi guys,

    I am deploying Windows 10 Pro x64 2004 to a bunch of Dell 3930 Rack units, very simple image which is working fine if deployed via PXE with Legacy boot using undionly.pxe.

    I am attempting to use the 10Gb Aquantia AQtion 10Gbit controller that is onboard these servers for faster capture and deployment. As mentioned above it is working fine with PXE boot when the BIOS is set to Legacy mode. However if I change the BIOS back to UEFI, enabled UEFI Network Stack and disable Secure Boot I cannot boot to the FOG bootloader at all.

    What I have tried:

    • Switching bootfile and Option 67 on DHCP to use the following ipxe.efi, snponly.efi, snp.efi to no avail.

    • Switched to using the onboard Intel I210 1Gb NIC and with ipxe.efi it does get to the bootloader which tells me it is the Aquantia NIC having the issues.

    I select the UEFI NIC PXE boot option on boot, I get the downloaded NBP message, then it gets to the iPXE screen, fetches the MAC address, I know the NIC has picked up an address over DHCP as I can see it on the server.

    The message I get is “No Configuration Methods Succeeded” then it times out and reboots. For now I am making do with changing the BIOS settings to Legacy to image then back to UEFI when imaging completes but its a pain in the proverbial.

    Do I need a different boot file? How do I build one that works with this Aquantia NIC chipset?

    Fog Version: 1.5.7
    Fog Server OS: Ubuntu 18.04.4 LTS
    Clients: Dell Precision 3930 Rack with Aquantia AQtion 10Gb NIC
    Switch & DHCP: Netgear M4300-12x12F

    Any idea would be greatly appreciated!

    Thanks,
    Jordan


  • Senior Developer

    @jordynorm I am still keen to see the füll DHCP DORA in wireshark to be sure! Best if you can capture directly in the DHCP server (filter for the machine’s MAC address) or using a mirror port on the switch directly connected to the PXE booting machine.

    There is no need to alter the default.ipxe file.


  • Moderator

    @jordynorm said in Dell Precision 3930 Rack - EFI PXE Issue:

    default.ipxe

    No worries on this one because its just a text file that redirects ipxe boot loader to be able to find boot.php. You can look at that file with a text editor or cat

    Ok that hardware id translates to [ 1D6A:07B1 ] in linux. And all linux kernels 4.16.x and later have this driver available. I need to see if FOG’s FOS Linux has this driver enabled.

    I realize that you need to turn these servers over today, but we can get you a working solution to image these with FOG in about 1hr if you need it. I just need to see if the default FOS kernel has this driver enabled.

    [edit] Yes the default FOG kernel for FOG 1.5.9 has this network adapter enabled as well as the 5.6.18 version of the kernel. So we can built a usb boot for FOS easily.



  • @george1421

    I unfortunately have to relinquish these servers today so cannot continue testing but I did try the latest ipxe binaries, default.ipxe appeared to be missing when I grabbed the latest repo from git so I used my previous one. In any case the Aquantia controller behaved the same with every variant of the latest tftp boot files.

    Here’s the hardware ID of the controller:
    PCI\VEN_1D6A&DEV_07B1&SUBSYS_08731028&REV_02
    PCI\VEN_1D6A&DEV_07B1&SUBSYS_08731028
    PCI\VEN_1D6A&DEV_07B1&CC_020000
    PCI\VEN_1D6A&DEV_07B1&CC_0200

    Driver: aqnic650.sys v2.1.12.0


  • Moderator

    @jordynorm You can use the FOG server for packet capture if the fog server and pxe booting computers are on the same subnet using this tutorial: https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    If the pxe booting computer is on a different subnet then you can use wireshark running on a witness (second) computer with a capture filter of port 67 or port 68 You will get the best quality of the capture if you can do it from the fog server, but the wireshark route will also tell us what the dhcp server is saying.

    Lastly if you can’t get iPXE to work we have a way to usb boot into FOS Linux, you give up some features of iPXE but you can basic image with the USB method. In regards to FOS Linux, can you get the hardware ID of this network adapter from the device manager in windows? I need the vendor and device ID to check against the linux kernel list of drivers.



  • Hi Sebastian,

    Thanks for your fast response!

    I will try the latest iPXE binaries first as that may resolve it easier than trying to packet capture from the Netgear switch (this is running the DHCP service).

    I’m not 100% sure it can be a DHCP issue though as the same Aquantia NIC picks up all DHCP DORA when in Legacy mode and even when in EFI mode I can see on the switched DHCP lease table it has acquired an IP…


  • Senior Developer

    @jordynorm said:

    I select the UEFI NIC PXE boot option on boot, I get the downloaded NBP message, then it gets to the iPXE screen, fetches the MAC address, I know the NIC has picked up an address over DHCP as I can see it on the server.

    The message I get is “No Configuration Methods Succeeded” then it times out and reboots.

    At first it sounded as if iPXE wouldn’t communicate over the Aquantia 10Gb NIC at all but these sentences make me think you get to a point where it sends out packets at least. Might be that it’s not able to receive the DHCP answer.

    Probably best if you can do a tcpdump/wireshark capture on the DHCP server to see how much of the full DHCP DORA (discover, offer, request ack) is happening.

    As you are still on FOG 1.5.7 you can manually download the latest iPXE binaries and see if it works using those.


Log in to reply
 

337
Online

7.5k
Users

14.6k
Topics

137.3k
Posts