SOLVED Weird problem when deploying to groups

  • Hello everyone, I’m having problems when deploying to groups, if the group contains more than one computer the imaging fails with “Invalid OS ID (0) (determineOS) Args Passed:0”.
    I looked at the tasks in the database and they have, in fact, taskImageId set to 0.
    Single hosts or groups with only one host are imaged correctly.
    Image association is right and I have already “cleaned” the db with db maintenance queries, I also truncated tables groups, imageGroupAssoc and snapinGroupAssoc and recreated groups from fog UI.
    Every time I start a group imaging task an error is added to apache error log:

    [Fri Aug 28 10:09:15.572858 2020] [proxy_fcgi:error] [pid 22678] [client ] AH01071: Got error 'PHP message: PHP Warning:  trim() expects parameter 1 to be string, array given in /var/www/html/fog/lib/fog/fogmanagercontroller.class.php on line 595', referer: https://xxxxxxx/fog/management/index.php?node=group&sub=deploy&type=1&id=3

    fog version is 1.5.9 RC 2.11 running on Debian 10 in a virtual machine, I only have the master storage node

  • Moderator

    @Campig This is fixed in the latest. For the commit see here. Thanks again!

  • Moderator

    Moved to bug reports. @Campig Thanks for these details as well.

  • Ok, seems like I solved, I reverted fix #393 and now deploying to groups works as expected.