Kernel Panic



  • SERVER
    FOG Version: 1.34
    OS: CentOS 8

    Client
    HP DC5800

    Hello, I have little problem deploying an image to my DC5800. My PC just panic and want to kill himself 😄

    e3c1955a-49c2-403c-89a6-09311b24c0b4.jpg

    my DHCP server option 66 is the server address and my option 67 is undionly.kpxe.

    I don´t know what else can I do. I´m stuck.

    Thanks for your help


  • Moderator

    @Single said in Kernel Panic:

    A nickle (may be helpful)

    I don’t think that one fits here since we are not doing nfs at this time. What we really need to see is the actual error that happened just before the stack dump that we see on the screen. Possibly if you can get a slow mode video of the kernel booting process we can see what the actual error message is. I’m not sure what we can do about it because its in the linux kernel but it might give us an idea where to look.


  • Moderator

    @ricardomartins Does it do this on all DCS5800 models or just this single computer. If its just this single computer there may be a hardware issue with this computer like a bad RAM chip. I don’t understand why the acpi off is not fixing the issue because others have reported it works.



  • A nickle (may be helpful)
    https://stackoverflow.com/questions/50115956/kernel-panic-not-syncingattempted-to-kill-init

    Something wicked is happening to your init image. Mb try to replace it?



  • @george1421 after loading correctly the bzImage 4152 and init.xz it goes to the error again (kernel panic error )


  • Moderator

    @ricardomartins So in this case you are not getting the kernel panic, its just not starting linux? Your host configuration looks good.



  • Maybe is missing something in my host config

    HOST.PNG



  • Hello @george1421 !

    I updated the bios version from 1.53 to 1.60 (newer version in HP website) and tried to run the deply again with acpi=off.
    It give the exact same error and I confirmed that it uses bzImage4152

    bz.jpg


  • Moderator

    @ricardomartins Are you sure you saw that bzImage4152 was transferred to the target computer, it would be just after boot.php is called then it should transfer bzImage4152 and then init.xz to the target computer.

    Back on the kernel parameters lets try this one acpi=off instead of noacpi=1 They “should” do the same thing.

    Also is this hardware at the latest bios version supported by the hardware?



  • @george1421 I followed everything you said but it is still trying to kill himself.

    Very similar error but a little bit different


  • Moderator

    @ricardomartins said in Kernel Panic:

    didnt solve. Do I need to have specific files in server for it to work ?

    Well over time it appears that the linux kernel is having an issue with those specific computers. In other cases disabling acpi resolved the issue. Other times we had the FOG Admins make sure the bios was updated on these computers.

    For testing go to the URL that I provided before with the kernels. Download 4.15.2 that was listed in the ref post. You only need the 64 bit version for this test. Rename the 64 bit version to bzImage4152 and move that file to /var/www/html/fog/service/ipxe directory. Make sure the case is correct. In this test we will NOT overwrite the existing kernel for FOG 1.5.9RC2. Now go back into the host settings where you manually defined this host. Set the “Host Kernel” field to bzImage4152 leave the “Host Kernel Arguments” with noapci=1 and then try to pxe boot this computer.


  • Moderator

    @ricardomartins said in Kernel Panic:

    my fog version needs a newer TomElliot ?

    You can use the FOG Configuration->Kernel update function inside the FOG UI to do the kernel update. Version 1.3.x was a bit quirky with the kernel updates, plus with that version of FOG I wanted you to load that specific kernel version not knowing if the latest kernel would break FOG 1.3.x. With 1.5.9RC2 you can upgrade to the latest version in the 4.19.x series. The developers just released a 5.6.18 version of the kernel to address an issue with the very latest hardware, but 5.6.18 has not been fully tested yet with FOG. It should work and work well, it just doesn’t have the testing completed that went into the 4.19.x series of linux kernels to date.



  • @george1421 didnt solve. Do I need to have specific files in server for it to work ?


  • Moderator

    @ricardomartins So the optional kernel parameter didn’t solve the issue by turning acpi off?



  • @george1421 I read the ref you used but do I need to fill the Host Kernel with TomElliott_4.15.2 or my fog version needs a newer TomElliot ? I´m saying that because it still give me the same error



  • @george1421 I´m sorry i thought it was the instructions for all versions of FOG. So I have a DC5800 as client giving the panic kernel.
    My server now have the fog 1.5.9-rc2 and still have the same error.


  • Moderator

    @ricardomartins If we can get back to the kernel panic error.

    For testing purposes manually register this DC5800 with FOG. Create the host in the Web ui by hand. You will need the mac address of this computer to register it. Then once manually registered go into the host definition of this computer and add the following in the “Host Kernel Arguments” field noacpi=1 Save the settings then reboot the computer and pxe boot into FOG again.

    ref: https://forums.fogproject.org/topic/12238/hp-dc5800-kernel-panic


  • Moderator

    @ricardomartins ok lets backup. The instructions I provided was because the OP said you are on 1.3.4. You want to use the kernels and inits that were installed as part of FOG 1.5.9 because they are newer than what I provided in the instructions in this thread.

    So with the kernel and inits from 1.5.9RC2 you still get the kernel panic on the DC5800 as in your original post?



  • Hello again
    I updated fog version to 1.5.9-rc2, downloaded the files that you said and move them to the directory having a new error. it get stuck in this screen.
    WhatsApp Image 2020-06-30 at 15.28.47.jpeg

    This happen if I keep the .32 and .64 extension in name files but if I remove the extension it goes to the same screen that my first post.

    once again thank you for your time


  • Moderator

    Your version of FOG is pretty old. Others have had the same issue as you with old kernels.

    Lets start out by manually downloading

    Kernel.TomElliott.4.18.11.32 and Kernel.TomElliott.4.18.11.64 from this URL https://fogproject.org/kernels/

    Rename Kernel.TomElliott.4.18.11.32 as bzImage32 and Kernel.TomElliott.4.18.11.64 as bzImage move these files to /var/www/html/service/ipxe directory replacing the existing files. Watch the case on the file name, because to linux case is important.
    (You might want to just rename the original files before you move these new ones into place, just in case something goes wrong)

    Then try to pxe boot into imaging.

    You can find out the current kernel version by using the web ui or keying this into the linux command prompt of the FOG server file /var/www/html/fog/service/ipxe/bzImage before you do the update.


Log in to reply
 

393
Online

7.4k
Users

14.5k
Topics

136.6k
Posts