HP DC5800 - Kernel Panic



  • 3 new Fog servers running Ubuntu 16.04.4 LTS - Each built a few weeks back at 1.5.4

    This older machine had been working on multiple previous versions including 1.5.2. I’ve tried multiple suggestions. Downgraded kernel to 4.15.2 as well

    Since it was working in previous versions I copied the kernel and init to the 1.5.4 server and named them OldPC and OldPC.xz and directed the host to use them. I was able to get past this error but then encountered “Attempting to check in… Failed”.

    0_1531853819364_Fog-Panic.jpg

    Hoping this is the last year I have to support these older machines and can get by with my old Fog server so worries if not a simple solution.

    Thank you!



  • I had the same problem with the HP DC5800. It was solved like this:

    Host Kernel: TomElliott_4.15.2
    Host Kernel Arguments: noacpi=1

    (Also bios update but maybe it was not necessary)

    However it gives some ACPI errors at the beginning but it works.

    Good luck


  • Developer

    @CS_PCCS Are you sure this kernel panic is related to this specific client hardware? Just wondering if other clients do well booting into a scheduled job from the very exact same FOG server?



  • Hi,

    The same thing happened to me with some HP Z400
    I have placed the following arguments in the “Host Kernel Arguments”: —> pcie_aspm=off pci=use_crs <— and it worked correctly

    Best regards,
    A!


 

414
Online

5.4k
Users

12.6k
Topics

118.9k
Posts