• Moderator

    @TaTa OK for both lets see if we can get the hardware IDs of both of them.

    From the USB stick make sure option #6 (debug) uses the new 5.3.4 kernel. Then usb boot using option 6. After several screens of text you need to clear with the enter key. Eventually you will be dropped to a FOS linux command (just a note, if the system will boot with the usb video adapter installed, install it before you boot into option #6). Once at the linux command prompt key in the following lspci -nn | grep -i net Take a clear picture of the output the closer the better. I need the values that look like this [8086:15cd] (totally made up number). But I need the hex values in the squared brackets with the description. The next one is going to be a bit of hunt and pecking to find the right numbers for the usb interlaces. I don’t think that the FOS Linux command gives us as much detail as on a conventional linux distribution. lsusb from there I need to get the hardware numbers of the video adapter.

    Now your MAC OS may provide a better and quicker way to get the hardware ID than booting through FOS linux. The numbers will be constructed similarly. So you might try OSX first. In windows these values are avaialble via the device manager in the form of “vend_id=8086;device_id=15cd”

    Once I have the device ids I can then start tracking back the drivers needed for them.

    Oh one last feedback on the T2b kernel, did the keyboard and mouse work on this one vs just the T2 patches? I just wanted to know the effectiveness of the HID patch.

  • @george1421 Yes. I want to be able to use built-in ethernet card (and usb-c to vga adapter if possible).
    Yes. 5.3.4 with T2 paches worked through HDMI and I was able to upload/download image correctly.

  • Moderator

    @TaTa said in Mac Mini with T2 chip:

    Built-in ethernet are not able to get an IP from DHCP.

    Do you want to work on this error? We can probably fix it.

    Secondly I just want to confirm that 5.3.4 linux kernel with the T2 patches worked and imaged the computer correctly through the T2 chip? I’ll need to write up what I changed for the developers so they can look at adding it to a future release of FOG.

  • Senior Developer

    @Sebastian-Roth The init’s kind of indicate the fix wasn’t in for those files. Notice the Parclone version is still 0.2.89

  • Senior Developer

    @TaTa said:

    Failed to read back partitions (runPartprobe)
       Args Passed: /dev/nvme0n

    As far as I know this issue should be fixed in the latest inits already. From what I see in the pictures (partclone v0.2.89, ramdisk_size=127000) you seem to use an older version of the init files.

    Please download the latest inits (64 bit, 32 bit) and make sure you update your grub.conf file to use ramdisk_size=275000!!

  • @george1421 Downloaded successfully but with error below. Rebooted the machine and tested both Mac OS and BootCamp partitions. Everything’s working fine. Thanks a million @george1421 & @Sebastian-Roth
    alt text

    I tried T2b kernel. USB-C to vga adapter still does not work (screen went power saving). Built-in ethernet are not able to get an IP from DHCP.

  • @george1421 Uploaded successfully but getting the error below. I’m downloading it now and will report back.
    alt text

  • @george1421 Thank you. I will try it out once i’m done testing this.
    It’s at 71% now and still going strong. Uploading speed is 6.66GB/min.

  • Moderator

    @TaTa I have a new T2 kernel (bzImageT2b) where I enabled the apple usb display and a few other usb attached display adapters, plus I applied the patch for the apple HID devices.

    BTW: 9.5GB/m is doing pretty good after 30 seconds. It would be interesting to know what the rate settles to after 3 minutes.

  • I used USB-c ethernet cable instead and it went to uploading image screen. It’s currently uploading now. I will let you know how it goes.
    alt text

  • Moderator

    @TaTa said in Mac Mini with T2 chip:

    Apparently, it does not like usb-c to vga adapter

    I did not enable this feature in the 5.3.4 kernel I built. I also did not add the kernel patches for the mouse and keyboard because they should have been included in the 5.3.x series of linux kernels. I can enable both and recompile the T2 kernel if needed.

    Just to be clear you are testing with the kernel I built (bzImageT2) with your current testing. I want to make sure we are talking about the same thing with your testing.

    Lastly your link to the latest video is damaged and can’t be viewed.

  • @Sebastian-Roth Apparently, it does not like usb-c to vga adapter. I connected to another monitor through DVI and saw a lot more. I went to a place where it’s trying to connect to fog server x.x.x/fog//index.php but failed to get an IP from DHCP through enp1s0 interface. I noticed it uses Atheros driver (00:13s) instead of Aquantia AQtion (Ethernet maker for this mini Mac).
    My apologize for the out of focus and shaky hands. You might need to download it to be able to read the text.
    https://s.amsu.ng/f8cHjL2HeJON (fixed)

  • Senior Developer

    @TaTa The “log” is just output on the screen. Nothing written to a file.

    Seems like you took some kind of slow motion video to grab the further output seen on the screen. Great idea. Though the picture is not clear enough to read anything. Can you please do the same thing again but this time rest the camera/phone on a pile of books in front of the screen and pay attention to it being focused on the text on screen.

    When the screen goes to power saving mode, machine is still on. It does not response to mouse or keyboard.

    So it’s not just a screen resolution/graphics card issue?! What you say doesn’t respond to mouse or keyboard… does this mean you cannot toggle NUM or CAPS lock? Any chance you can hook up the network card to an old hub or modern switch using a port mirror to capture all the network traffic?

  • @george1421 Yes. Secure boot is disabled (Mac won’t allow to boot to external device if it’s enable). I tried the new kernel and it gets a bit further. Kernel log level has been set to 7. Where does the log write to? I can’t seem to find it anywhere.
    I noticed there are more errors before it gets to USB fog menu (wrong efi file?)
    Video: https://s.amsu.ng/JWcj5VGc5USN

    @Sebastian-Roth When the screen goes to power saving mode, machine is still on. It does not response to mouse or keyboard.

  • Moderator

    I compiled the linux 5.6.4 kernel against the FOS Linux settings for 4.19.65 (FOG 1.5.7 base). I added in support for USB-C and Thunderbolt. The unpatched kernel is here: https://drive.google.com/open?id=1CAxobMHal1XZt57QqKz7x_LtxhaQFRNE

    I added in the patches from the github site below and recompiled the kernel. I discovered that the patched code was not added into the kernel. By doing some reverse engineering I found that the patched code was only added in when device drivers->hw mon was included in the config. Once hwmon was enabled then I enabled apple hwmon support and recompiled. The patched 5.4.6 kernel is here as bzImageT2 https://drive.google.com/open?id=10j8fZ3i3Y_uICxcMgX5lpiuQ2ci9bCJG I have no way of testing this with a mac since I don’t own one. I have a low confidence that it will work, but according to the articles below it should work. To test rename bzImage on the usb flash drive and then copy the bzImageT2 to the flash drive as bzImage (watch your case). If this works I’ll upload the current kernel config used to build this image.

  • Moderator

    @Sebastian-Roth said in Mac Mini with T2 chip:

    Please try increasing the kernel log level (web UI -> FOG Configuration -> FOG Settings -> FOG Boot Settings -> KERNEL LOGLEVEL) to see if you get any further messages on screen that way.

    FWIW: He’ll have to change this in the grub.cfg file on the USB drive. There is a log level entry. I think the default was 4, for more debugging it should be changed to 7

  • Senior Developer

    @TaTa I’ve had a quick look at the video. Now I see where you are at. Sorry I didn’t notice you’re using George’s half official USB boot method right away.

    Please try increasing the kernel log level (web UI -> FOG Configuration -> FOG Settings -> FOG Boot Settings -> KERNEL LOGLEVEL) to see if you get any further messages on screen that way.

    When the screen goes blank (power saving mode obviously as we see in the video), does the machine itself switch off entirely?

    George’s point on secure boot is important as well I think.

  • Moderator

    On this mac is secure boot disabled? Its strange in the video that when it goes to boot bzImage the mac says powering off. I can see if the kernel isn’t signed it might do that.

  • Moderator

    @TaTa I couple of things to add here.

    1. The developers are on holiday until after the first of the year to spend time away from FOG. While they are still check in now and again, don’t expect a timely response. The point is your 24 hr video may be deleted before they can look at it.
    2. There was some discussion of the new macs with the T2 chip a while a go. I know back in august there was a patch on the linux kernel side that was working to get around the T2 chip. I’m not sure where that ended up, but I’ll look. That development was being taken on by the Linux kernel group not the FOG Project. The T2 chip is in the nexus of the macs now. It is actually the disk controller for the new macs, so getting linux to communicate with it properly is essential. Apple is not releasing the specs or drivers of this chip so the linux folks are trying to reverse engineer a solution. Apple is positioning the T2 chip to function a bit like what secure boot is to Windows. With the T2 chip only authorized and signed operating systems can boot on these new macs as far as I know.

    ref: https://github.com/Dunedan/mbp-2016-linux/issues/71
    ref2: https://github.com/MCMrARM/mbp2018-etc/tree/master/applesmc

  • @Sebastian-Roth Video will get deleted after 24hrs: https://s.amsu.ng/1ILdNtSJa0xN