SOLVED Can't find network interface - kernel

  • Hello

    We are trying to pxe boot a Lenovo Thinkpad L390 yoga with the Lenovo Thinkpad USB-C Dock Gen 2 .
    PXE Boot works fine and i am able to select ‘Deploy Image’ from the fog menu.
    After that i’m getting an error =>

    Starting enp0s31f6 interface and waiting for the link to come up
    No link detected on enp0s31f16 for 35 sec
    faild to get an ip via DHCP tried on interfaces enp0s31f16

    I can’t seem to find any debug data or change the network interface of the kernel …

    I am running FOG with kernel 4.19.64 .

  • Testers

    @george1421 said in issue with netcard of dock gen2 of lenovo l390:

    @JJ-Fullmer The r8152.c from the torvalds github site failed to compile on 4.19.65, I’m suspecting its for a later release of linux. The version from the torvalds site was 1.10.10. The version in 4.19.65 was 1.9.9 of the realtek driver.

    I was able to compile the realtek driver from the wget github site. This version is 2.12. Here is a link to that kernel with the 2.12 driver built in. I also enabled the usb-c code in the kernel that appears to have not been set. I don’t know if its relevant, but it should be on for other applications.

    Download this as bzImageRT (watch your case) and copy it to the ipxe directory with the other kernel images. Manually register the host and then in the host definition add in bzImageRT as the kernel for that host. Then pxe boot into FOS Linux debug mode to see if the network adapter inits correctly with this updated driver.

    @Interrupt Give this solution a try, download the kernel @george1421 made and set it on that host. It worked for me with the lenovo usb-c ethernet adapter, it stands to reason it will work for the dock too.

  • Testers

    @Daniel-Miller I’m pretty sure also that this is the same issue, which is the same issue I’m having with the usb-c to ethernet adapter for the same model. My experience was slightly different than here and in the other post cause my l390 got into the image process but then it hangs at a different spot. I’m able to image with a different method utilizing a different adapter. I think that this lenovo usb-c ethernet is missing a kernel driver in FOS. It’s based on realtek, the other post has the windows hardware id of the device.

  • Moderator

    @Interrupt Can you please take a picture of the error on screen and post here? Quite often there a important hints on screen that we’d need to see.

    Other than that - do you see the link LED on the dock or on the switch coming up at some point or is it dead all the way through after the initial PXE booting?