SOLVED FOG 1.5.6 pushbullet Plugin not functioning

  • Moderator

    Feel free to move this if not technically a bug. As requested, I am opening a separate thread for the Pushbullet plugin not functioning. The behavior is as follows after adding the API token to FOG:

    FOG Plugin Accepts the token.
    When the Pushbullet Accounts tab is opened and the List all pushbullet accounts is clicked, this is displayed:

    The entry for the account is showing a blank email and a blank name. Alerts are not triggered on image completion or image upload completion.

    Feel free to take your time on this as there are more important things in the FOGverse to deal with at the moment. I am just putting this in as a placeholder until you can get to it. I have remote access to my FOG server, so if you want any testing done, I can do it this weekend as well.

  • @george1421 I had to use * and * for web filtering url in Lightspeed setup

  • Moderator

    @Hanz said in FOG 1.5.6 pushbullet Plugin not functioning:

    @fry_p lightspeed…I eventually figured it out thank you though

    I use lightspeed too! Relay and the rocket filters. Still getting the hang of them tbh. Glad you got it

  • Moderator

    @Hanz said in FOG 1.5.6 pushbullet Plugin not functioning:

    I eventually figured it out thank you though

    Please don’t be one of “those guys”…

    Please tell what you found and how you solved the problem.

  • @fry_p lightspeed…I eventually figured it out thank you though

  • Moderator

    @Hanz I had re-categorized “” from a blocked category to an allowed one. It all really depends on which filter you use. I’d try whitelisting whatever permutation of all of the subdomains of your filter uses. It may involve something like:

    or if your filter is like mine, there is a checkbox for all subdomains.

    If you still are having trouble, let us know what kind of filter you have.

  • @fry_p which site did you whitelist ? * or I tried whitelisting, but with no success.

  • Moderator

    So, this is really dumb on my part… It was our web filter blocking the calls out to pushbullet. It now displays the email and name in the table and the GUI after I whitelisted it. I will double check that notifications are working tomorrow, but this is looking like a whoopsie on my part. Most likely solved.

  • Moderator

    I forgot to mention in my OP that I can post any logs that are needed or errors that may pop up. So far, no errors but it it is not functioning. I wish there was visibility into the pushbullet side of troubleshooting…

    EDIT: Where might I find the code for the plugins? I can take a look but I am no expert. Not trying to rush this, just might be a fun challenge for me if I am able to figure it out.

    EDIT 2: found it and peeking through now. So in the DB, this is what I find:

    Token is there, but no email or name, just like the GUI displays.

    Digging further.