Unable to change multicast nic.



  • @Fernando-Gietz @Sebastian-Roth

    I’m trying to enable multicast on my installation. And I have a problem.

    Trying to change nic on node definition or in fog settings dont change on the multicast command.

    FOG try to send the stream always from the eth0.

    All my nodes are multihomed with at least 3 VLANs, and eth0 is a management interface on the management network.

    I try to locate where the task get the nic to use but i can’t find it. Well i find some places but forcing manually by nic name and by nic ip dont works.

    Testing manually udp-sender and udp-location is multicast capable.

    The installation are Normal and Node v1.5.6

    Thanks in advance.



  • Adding a comment:

    Currently we are using false nodes to change the multicast tasks. I mean

    To make multicast tasks on desired vlan we are creating a second master node to the location’s storage group, with nic an ip assigned on the vlan that we want to do the task and with false user/password to avoid a redundant synchronization.

    By the moment, this solution is working with version 1.5.6 of Master and Nodes.


  • Developer

    @EduardoTSeoane I am marking this solved for now although I am still not exactly sure what you mean by “That’s a problem to me because all the server’s ip on the service vlan’s are protected.”

    If you still want to elaborate on this we need more information on what exactly you mean and the way you see FOG behaving in your environment.



  • @Tom-Elliott Ok, I understand. That’s a problem to me because all the server’s ip on the service vlan’s are protected. Then i must have the StorageNode on the Management VLAN.

    By the moment i’ve solved the problem like i said on the last post. It’s a valid solution for me. But when i have time i try to implement a plugin to handle this dinamically from the interface.



  • @george1421 @Tom-Elliott Thank’s for the response.

    Yes, I see that, by the moment I solve that with a few of dirty code modifying the multicasttask.class.php file to write multicast into the desired interface.

    I’ll be pleased to work in a plugin that can do it dinamically.
    But I need information about the hooks at least.

    Great job!!!.


  • Senior Developer

    The interface setting on the server used to work for this, but it also caused issues if you had the wrong interface name.

    Rather than deal with the interface naming for a task that needs to be exact, the IP of the fog server is used to automatically determine the interface to use for multicast tasks.

    The interface setting in the GUI, now, basically just sets up the interface to check bandwidth from.


  • Moderator

    @EduardoTSeoane Just so I’m clear on this.

    If you set the Interface on the master node the FOG Multicaster sill picks eth0?
    Storage Node General.png

    Just as a reminder the FOGMulticaster service only runs on the Master node in a storage group, unless something has changed in the code recently. AFAIK you can not multicast from a storage node so the interface setting value on the storage node is not used.



  • @Fernando-Gietz @Sebastian-Roth @george1421

    Testing something more.

    If i change the Storage Node’s ip then yes, multicast works into associated nic.

    What is the purpouse of the nic interface on Storage Node General?



  • @Fernando-Gietz my previous version was 1.4.2 and we hsrdcode to force send by all nics. Current version is 1.5.6 without custom code. Only task typeedit location persidtengroups plugins


  • Developer

    I suppose that the multicast workrd to you well in the previous FOG version, no?



  • @Fernando-Gietz yes i try it but dont works.


  • Developer

    In each node definition you can config the network interface, maybe there?



  • @Fernando-Gietz
    This is the first i try but nothing, systemctl status FOGMulticastManager tellme than udp-sender is using eth0 and multicast continue to work on eth0.

    Same if i change the nic on the NodeStorage Definition.


  • Developer

    I don´t use storage nodes in my environmet but in the FOG settings -> Muklticast Settings -> UDPCAST INTERFACE you can config the network interface to send the multicast tasks.

    I don´t know if this configuration is global, the same for all storage nodes


Log in to reply
 

462
Online

6.1k
Users

13.4k
Topics

126.4k
Posts